Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Sorry, it looks like [...] isn't available right now - Ghost device

Community Member

Hello everyone !

First thing first, as I my smartphone is in french, some terms cited below might be badly translated.

Here's my problem : more than a year ago, I used for a short period of time an Android TV device provided by a small french ISP. The device was named "Pure" and I linked it to my account to use it fully. After some time (like a month or so) and disconnected it as I had to return it to the ISP.

As I reseted it before returning it, I didn't disconnected my account, and now, I don't have access to the device anymore.

From now on, I cannot see the device in my Home app and so cannot delete it, and every time I use the following commands :
- "Hey google, turn everything off"
- "Hey google, turn my TV off"
- "Hey google, turn pure off"

I get the same answer every time :
Screenshot of the ghost deviceScreenshot of the ghost device

Here's a non-exhaustive list of things I've done multiple times, in this order :
1. Delete all of my routines
2. Delete one by one all my devices
3. Unlink every partners connections (from Home app / app parameter)
4. Delete registered Wi-Fi networks (from Home app / app parameter)
5. Delete app position (from Home app / app parameter)
6. Sign out from every unused device from "Security / My devices" in my Google account (including the ghost Android TV named Pure that at that time was still appearing in the page)
7. Unlink every unused third-party apps with account access (Security / Apps with access to your account)
8. Factory reset all my devices
9. Delete the current house
10. Creating a new house

Despite all that, nothing changes, even when there's no house.
As you can see in the following screenshot I get the same error message and in the background in french you can read "Create a house" indicating that there's none created at the moment.

Screenshot of the home app with no house and the error messageScreenshot of the home app with no house and the error message

My only constrain is that I won't change Google account, mine has more than 10 years, I have my YouTube Premium subscription on it, years of interactions, likes, playlists that have set recommendations for my tastes, I won't change it.

About the devices I actually use :
- My smartphone is a Samsung Galaxy S10+ updated with Android 12
- One Google Home Max
- One Google Nest Audio
- Two Google Nest Mini 2n gen
- One Chromecast Audio
- Three Meross Smart Plug

Of course I've called the support center and got to talk to someone very pleasant, whom I gave access to my account, spent half an hour on the line with unfortunately no results as he could see the device but not delete it. He called it very strange and never seen before but with no more tools to help me.

Thanks in advance for your king help !


Maximilien S.


Thanks for your answer,

Unfortunately, I've already tried it with the Google Support Center and it doesn't work. It simply doesn't appears in Settings / Rooms and Groups and in Assistant settings / Devices the device appears but as I click on it, an empty page fade in and out instantly then I get back on the exact same screen.

I should have said in the first place that the device wasn't appearing on my home app, I've corrected myself. The only place were the device appears is in Assistant settings / Devices and when I get the error evoked in the title of the thread. As you can see in the screenshot below, when I get the error message, as I click on the device, I get the message "Can't load status".

Screenshot of the "Can't load status" message returner when I click the deviceScreenshot of the "Can't load status" message returner when I click the device

Maximilien S.


This seems like it's either a bug in the Google Home app or on Google Nest's servers.

@MplsCustomerI tried reinstalling the app on my phone and redo the whole process, I've tried the same with my partner's phone, same result each time, so I guess you're right, it might be a but on the servers.

Do you know if there's any way to intervene on it?

Maximilien S.


I'm just another Google Nest customer and don't have anything else to suggest. You've already contact Support and they could see the device but were unable to delete the device, and apparently were unwilling to refer this to higher-level Support to resolve.

Community Specialist
Community Specialist

Hi folks,


@MplsCustomer, thanks for the help. 


@MassibroDaronne, thanks for posting and for being a step ahead of us. Sorry to hear about the trouble. I wanted to follow up and see if I could be of any help. Try unlinking it directly from your Google account and see if it will make a difference.


Check these links.

Let me know how it goes.




Community Specialist
Community Specialist

Hey there,


I wanted to check in and see if you managed to see Juni's post. Please let me know if you have any questions from here. I would be happy to assist, and make sure you are good to go.

Best regards,

Community Specialist
Community Specialist

Hey there,


I wanted to check in, and let you know that I will be locking the thread in 24 hours.


Best regards,