Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

2nd Gen Wired doorbell used to work, now won't connect

Community Member

I purchased a 2nd gen wired doorbell in late January and had it installed by an electrician (needed to update my transformer) in early Feb. The doorbell worked great for about a month. In early March after an update to the app, it started going offline for hours at a time daily, but would eventually reconnect. I contacted support and they had me remove it from the app and do a factory reset. Since then, I cannot re-connect the doorbell to my Google Home app (iOS). 

I have been going back and forth with support for a month, they have sent a replacement doorbell and it also couldn't connect. Speed tests show that my connection outside by the doorbell is strong and there have been no changes to my internet or anything that could cause interference. I know that the doorbell is capable of working as it worked seamlessly for a month. Support has not been very helpful in pinpointing the issue.

I get through the entire set up process and then it will not connect to wifi, but there is no error message other than saying it cannot connect to wifi. From there, the options are try again or a "get help" link that directs me to Chromecast support, despite me clearly identifying that I am setting up a doorbell.

Has anyone else had a similar problem?




Google Nest Help has a topic on troubleshooting Wi-Fi issues; it may not be of any use in your situation with your 2nd gen doorbell, but here is the link:

Thanks, I’ve already been troubleshooting this over the phone with support for a month. It is not a wifi issue. 

Community Specialist
Community Specialist

Hi everyone,


@AveryReid, thanks for reaching out here in the Community. Try creating a new home structure and add your Nest Doorbell. You may also try bringing your Nest Doorbell near your Wifi router during setup. Reinstall your Google Home app and restart your Wifi router and mobile phone. Let us know how it goes.


I appreciate the help, MplsCustomer.




Honestly this is laughable. I have have done every possible troubleshooting step. When do you start to consider that the issue is your software?

This is also the 3rd time I’ve been asked to disconnect my WIRED doorbell and try bringing it inside by the router. When it’s not attached to the wires it doesn’t have enough power. 

I have set up a new home, tried on 3 devices (iOS and Android), gotten a replacement doorbell, done a million speed tests which show my fantastic connection to the wifi outside with the door closed, reset it a million times, airplane mode on and off, data on and off, forgotten my wifi network, etc etc etc. nothing has worked. I’ve been without a doorbell for almost and month and a half. 

I am having these exact same issues, taken exact same steps.  Not sure what to do next and very frustrated.