cancel
Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google Nest doorbell camera does not charge

Robhill21
Community Member

The battery does not charge at all. I plug it in and it doesn’t gain any charge. Haven’t had the device too long, under a year, and it appears it will be useless after the charge expires (one day left). 

9 REPLIES 9

David_K
Platinum Product Expert
Platinum Product Expert

Are you using a 7.5 W AC adaptor (sold separately) with the included USB cable? Does it work to charge other devices? It takes approximately 5 hours to fully charge the battery using a compatible 7.5 W AC adaptor.

I’m using the adapter and wire that came with the cameras, I bought the package that had three cameras and the doorbell (From Costco). I’ll check 

MplsCustomer
Bronze
Bronze

@Robhill21 

A few customers in this forum have reported problems with the enclosed charging cord or the USB plug. If you have 3 cameras, are you able to swap charging cords?

Are you dismounting the camera when you charge it?

Do you have the USB plug plugged in snugly in the bottom of the camera, with the power cord feeding towards the FRONT of the camera, as it should? (Customers have also reported issues with both of these.)

Robhill21
Community Member

Thanks for the reply! The charging cords for the cameras are different, but they use the same plug. It works for those cameras so maybe the wire is not working. Let me try another one.

Jeff
Community Specialist
Community Specialist

Hey Robhill21,

 

It's been a few days since you mentioned you were going to try a different wire. I just wanted to check in and see if you were able to try and that and see if it worked out for you. If you're still in need of some help, just let me know.

 

Thanks,
Jeff

Robhill21
Community Member

Thanks for checking in Jeff. It took 14 hours to charge up to 52% and I had to put it back. I will try again to see if I can get it to 100%.

Jeff
Community Specialist
Community Specialist

I'm happy to see it's charging, Robhill21. If you have any problems getting it back up to 100%, just let me know and we can look more into things.

 

Thanks,
Jeff

janthadeus
Community Specialist
Community Specialist

Hi there,
 

I just wanted to follow up to see if you still need our help. Please let us know as we would be happy to answer any questions you may have.
 

Thanks for the help here, everyone!

 

Thanks,

JT

Jenelyn_O
Community Specialist
Community Specialist

Hi folks,

 

We haven't heard from you in a while so we'll be locking this thread if there is no update within 24 hours. If you need assistance or want to discuss topics, feel free to start a new thread.

 

I appreciate your help, @David_K, @MplsCustomer, Jeff, and JT.

 

Best,

Jenelyn