cancel
Showing results for 
Search instead for 
Did you mean: 

2014 chromecast is not working after many years of good service

forestgrew
Community Member

My chromecast was bought 8 years ago (2014). Was working fine now we've moved house and I can't set it up despite using google device utility app and the google home app. I've followed all the steps but once I connect to the device's wifi the utility app says it can't connect for some reason. Tried turning it off and on again or putting in a different HDMI port. 

Is it just too old now?

Any help welcome.

1 Recommended Answer

davidking
Gold Product Expert
Gold Product Expert

Try these steps:

  1. Open the Device Utility app, and then turn Wi-Fi OFF in your phone's settings as instructed.
  2. Once the app finds your device, tap on its name if you have multiple devices that need activation.
  3. Go back to your phone's Wi-Fi settings and turn Wi-Fi back ON.
  4. Re-open the Device Utility app and tell it to connect to your device.
  5. It should now connect successfully and you can follow the setup steps.

Volunteer since 2011, Product Experts are not Google employees.

View Recommended Answer in original post

7 REPLIES 7

davidking
Gold Product Expert
Gold Product Expert

What country are you located in and what device brand/model are you using to do the setup?


Volunteer since 2011, Product Experts are not Google employees.

UK. Plugged into a Panasonic TV and trying to connect it using my pixel 6 phone

davidking
Gold Product Expert
Gold Product Expert

Try these steps:

  1. Open the Device Utility app, and then turn Wi-Fi OFF in your phone's settings as instructed.
  2. Once the app finds your device, tap on its name if you have multiple devices that need activation.
  3. Go back to your phone's Wi-Fi settings and turn Wi-Fi back ON.
  4. Re-open the Device Utility app and tell it to connect to your device.
  5. It should now connect successfully and you can follow the setup steps.

Volunteer since 2011, Product Experts are not Google employees.

forestgrew
Community Member

Thank you so much @davidking - it has worked. I can now cast Disney plus again and my 4 year old will be very happy. Cheers!

Jeran
Community Specialist
Community Specialist

Hey there forestgrew,

I'm glad to see that David was able to help you resolve your issue! In that case, did you have any more questions or need any additional help? 

Thank you,
Jeran
 

forestgrew
Community Member

All good thanks @Jeran - am now back to being a happy chromecast user. Impressive it's lasted so well for 8 years. Thanks

Jeran
Community Specialist
Community Specialist

Hiya forestgrew,

 

Awesome, that's good to hear! I've had an older Chromecast model that's outlasted a couple of phones, so I'm impressed by the durability as well. I'll go ahead and lock the thread for now, if you run into any more issues in the future, please feel free to create a new thread.

 

Thank you for your help on this, David!

 

Best regards,

Jeran