cancel
Showing results for 
Search instead for 
Did you mean: 

Can’t add chromecast device to google home

Steviez
Community Member

I have my chromecast gen 1 connected to the tv hdmi. It’s on the welcome screen with its code. 

No matter what I do google home will not recognize the device even with Bluetooth and Wi-Fi on when I go through the “add device” setup on my iPhone. I have factory reset the chromecast by unplugging and also holding down button so it blinks from red to white.  It still won’t recognize. Any suggestions? 

1 Recommended Answer

Steviez
Community Member

This did not work at all and it was what was misleading me and getting me no where.

No matter what I did, I was put in a continual loop that kept searching for the device and never finding it.  The only solution was the 'OLD' that I remembered doing it years ago.  Finding the network the chromecast creates, joining it with my phone, and setting it up that way.

View Recommended Answer in original post

7 REPLIES 7

djtetei
Gold Product Expert
Gold Product Expert

Reset the WiFi router, restart your phone and connect to WiFi 2.4 GHz bandwidth.

Steviez
Community Member

I’ve just rebooted my Orbi Wi-Fi router and even updated firmware just now too. I’ve also restarted phone and turned off and on both Wi-Fi and Bluetooth. 

ok this may sound stupid but the instructions on setting this up in google home just don’t work or I am just not understanding. I wound up instead joining the network manually on my phone that was listed on the chromecast and not my own Wi-Fi network and it connected. Then it let me choose my Wi-Fi. Why doesn’t the google home app handle that? 

Jeran
Community Specialist
Community Specialist

Hey there Steviez,

 

Here is the official documentation on how to set up the older generations of Chromecast. It implies that you should have been able to set up most of it through the Google Home app, do you know which part was giving you issues?

 

Best regards,

Jeran

Steviez
Community Member

This did not work at all and it was what was misleading me and getting me no where.

No matter what I did, I was put in a continual loop that kept searching for the device and never finding it.  The only solution was the 'OLD' that I remembered doing it years ago.  Finding the network the chromecast creates, joining it with my phone, and setting it up that way.

Jeran
Community Specialist
Community Specialist

That is strange! I set up an old Chromecast Gen 2 not too long ago and the steps were still relevant to my scenario. I'm glad you got the device up and running again, though. If you have the time, would you be willing to submit feedback via the Google Home app to let Google know about that loop you were stuck in? 

 

Best regards,

Jeran

Jeran
Community Specialist
Community Specialist

Hey there,

Did you have any more questions or need any additional help? If not, I'll go ahead and lock up this thread in 24 hours.

Just checking up,
Jeran
 

Jeran
Community Specialist
Community Specialist

Hey there!

We haven't heard back from Steviez, and it's been a few days, so I'm locking the thread. As always, feel free to make a new thread if you have any more questions or concerns.

Thank you for your help, djtetei!

Best regards,
Jeran