cancel
Showing results for 
Search instead for 
Did you mean: 

Choppy sound

Groucho10
Community Member

Hi there, I'm having this constant problem where I put a TV show on Netflix for example. The episode plays fine, but then if I want to watch the next episode I can't because the sound goes choppy. I have to disconnect Netflix, connect Spotify let that play for the few seconds. Then I disconnect Spotify, reconnect Netflix and continue watching the episode that was choppy. I've tried resetting Chromecast, different HDMI ports and the problem persists, any suggestions?

6 REPLIES 6

Ashepherdson
Gold Product Expert
Gold Product Expert

Is this happening on any other devices that you're using Netflix on?  Have you try to factory reset of your Chromecast, I know you said you've tried to resetting but I'm wondering if that's just a power cycle or a full factory reset.  Is your Chromecast using the original power bar or you plug into the USB port? 

It happens on all streaming services Disney+, Amazon and Netflix. I'll watch an episode of something or a movie and the next thing I'll watch on that platform it'll go choppy. So I'll have to disconnect from that platform, connect to Spotify let it run for a minute and then reconnect to the streaming service I was watching originally. I've fully reset the Chromecast many times now and still no difference. The Chromecast is also plugged into the wall, not a usb port in the tv or anything like that. Just last night I watched an episode of a show on Netflix and when it was finished, I put a different show on Netflix on and it was choppy. So I had to do the whole rigmarole of disconnecting reconnecting situation I explained earlier.

I am guessing it's a network connection issue, as I have never seen something like this across multiple apps.  You might try power cycling your router as a next step to see if that clears up the issue.  

I don't have a router, only a modem which I have done multiple times already

Jeran
Community Specialist
Community Specialist

Hey there Groucho10,

 

Let me ask a few more questions regarding this sound issue you are experiencing:

  • Does this happen when casting from the streaming apps, as well as from their website on Google Chrome?
  • Does this occur when casting from another device, such as a phone or tablet?
  • If you are able to test it, does this also occur when the Chromecast is plugged into another TV?
  • Is the video fine when this occurs, or does the video stutter or become choppy?

This could point to a few different issues, such as the network, settings on the TV/casting device such as power saving mode, battery draining apps running in the background, etc.

 

I look forward to your response!

 

Best regards,

Jeran

Jeran
Community Specialist
Community Specialist

Hey there,

Did you have any more questions or need any additional help? If not, I'll go ahead and lock up this thread in 24 hours.

Just checking up,
Jeran