cancel
Showing results for 
Search instead for 
Did you mean: 

Chromecast can't connect to wifi

indroth
Community Member

I recently set up a new Chromecast, and it loses the ability to connect to wifi if I turn off power, and requires a factory reset to work again. This also happened right after the initial firmware update. 

 

Immediately after a factory reset it, it works great and I can stream 4K HDR without any problems, so I doubt there are any signal problems. Once power cycled, the home screen comes up, but wifi does not connect. If I try to connect wifi, it does not seem to know what the password is any more, and comes back with a "not found" error when I enter the password and try to connect. At this point, if I factory reset, everything works again until the next reboot.

 

Has anyone seen similar problems? Is there some particular wifi configuration that may be causing this? (FWIW I have tried with both 2.5 and 5 GHz)

 

 

1 ACCEPTED SOLUTION

indroth
Community Member

I was able to resolve this by disabling WPA3 on my router. 

View solution in original post

2 REPLIES 2

indroth
Community Member

I was able to resolve this by disabling WPA3 on my router. 

Jeran
Community Specialist
Community Specialist

Hey there!

I'm glad to hear you were able to solve your issue, thank you for coming back with your solution! In that case, I'm locking the thread. As always, feel free to make a new thread if you have any more questions or concerns.

Have a good one!

Best regards,
Jeran