cancel
Showing results for 
Search instead for 
Did you mean: 

Chromecast doesn't connect to wi-fi

LucasKosloski
Community Member

My Chromecast is not connecting to wifi. Everytime I try to use it I have to configure everything on Google Home app. It always shows that the device was made for another country, but I used it for about 3 years on my old house and it worked right. I moved to another house and this errors started happening. And today my Google Chrome device isn't even recognising my wifi.

20 REPLIES 20

Idorokach
Community Member

I have the same problem

costa11
Community Member

same... worked fine for 2 years and suddenly says network problem, try resetting and nothing.

hiluke
Community Member

Any chance you are trying to connect your devices to a 5GHz WiFi network using a channel higher than 140?

Can you separate your 2.4GHz and 5GHz networks to different SSIDs and see if you can connect to the 2.4GHz network? Or alternatively set the channel of your 5GHz network to something in the 36-48 range?

If either of these work, then your Chromecast may have been updated to the 275449 version. This firmware has broken connectivity to the upper range 5GHz WiFi channels (141-165).

Sam3
Community Member

Thanks, this was helpful! 

costa11
Community Member

My chromecast was always connected to the same 2.4 Ghz. Im using it like once a month, few weeks back it worked flawlessly, and few days ago when i turned it on, it said updating with 0%. after about 3 minutes  at 0% it shows network problem. Tried resetting, it connects to my wifi, and repeats the same update trial and network problem. ( the network worked on other devices and the chromecast itself was connected to this network and worked  before this came up) 

LWO
Community Member

Mine stopped acknowledging the wifi so I bought a new one as it was two years old. Same issue. 

ideutsch
Community Member

Me too. donno what to do. 

Worked for a few years and now suddenly stopped working. When I Reset it, it does connect the network, start an update, stuck on 0 for a minutes and than says "Network problem"... 

ideutsch
Community Member

Any update ? have you managed to solve it ?

LWO
Community Member

Nothing has worked. I’m either gonna have to get a technician out here or buy a new tv. 

Jeran
Community Specialist
Community Specialist

Hey there LucasKosloski,

I apologize about the late response, thank you for being patient! Were you able to fix that connection issue? If not, I'd be happy to help out, as I know how tedious it can be to troubleshoot. Let me just ask you some questions about what's happening:

  • When did this issue start happening?
  • What type of Chromecast do you have?
  • What is the firmware version of your Chromecast?
  • What is the version of your Google Home app?

For now, I would recommend that you, and anyone else here who is encountering this issue, check out this article on Chromecast connection issues, and give the troubleshooting steps inside a try.

 

I look forward to your response, and if you have any other questions or concerns for me, please let me know!

Best regards,
Jeran

Idorokach
Community Member

Nothing was written above helped to solve the problem.

It seems that another of people encounter the same problem.

The chromecast can't complete the update

ideutsch
Community Member

Dear Jeran

I have the exact same problem.

I have 4 Chromcasts at home. All connected to the exact same network

One of them went into UPDATE... stuck on 0% and after 1-2 minutes shows the "NETWORK PROBLEM" error.

  • I did reset factory
  • I tried to connect to another network.
  • I tried to connect to a hot spot network.
  • I also tried to connect it through LAN (I have the adapter which is working for my other Chromecast)

Connecting the network is not the issue. When I set it up from scratch - it is able to connect the network during the setup, and then immediately goes into UPDATE and end up in the same situation.

It started about 10 day ago (give or take).

That's a video showing the problem: https://youtu.be/i_1OmWM920w

Per your questions :

  • my google home app version: 2.47.78.2 (Android)
  • Cant tell you the Firmware version as the chromscast doesnt load 
  • That's a photo of my chromecast

ideutsch_0-1640107689319.png

Thank you!

Irad

Jeran
Community Specialist
Community Specialist

Hey there igerman,

 

Your issue looks a bit different from OP's issue. LucasKosloski moved to a different house, most likely with a different network, and would need to look at factory resetting their device.

 

You, on the other hand, may need to look at getting your device replaced by looking at the video you linked and all the troubleshooting you have already tried. Would you be able to contact Chromecast support, so they could continue to help you out?

 

This also applies to anyone who attempted the same troubleshooting you have, and is still having issues.

 

Best regards,

Jeran

Idorokach
Community Member

I tried to fix it with the when the support with me on line for several hours. Nothing works. 

Jeran
Community Specialist
Community Specialist

Hey there Idorokach,

 

If you worked with Chromecast support over the phone for several hours and weren't able to find a resolution, you may need to look at getting that device replaced as well. I would get back into contact with Chromecast support if you are able to and see what they can do for you.

 

Best regards,

Jeran

yashhassan
Community Member

Hijjeran,

I too facing Chromecast is not connecting to the wifi which use to fork an year and I have tried many ways as suggested by Google but there is no way connecting either, please help us to repair or replace the device, looking for your kind response.

Azarco
Community Specialist
Community Specialist

Hey All,

Since this thread hasn't had activity in a while, we're going to close it to keep content fresh.

We hope you were able to get the help you need. If you still need assistance with your Chromecast devices, feel free to submit another post and provide as many details as possible so that others can lend a hand.

Thanks,
Alex

Jeran
Community Specialist
Community Specialist

Hey there,

Did you have any more questions or need any additional help?

Thank you,
Jeran
 

ideutsch
Community Member

Donno if you did something on your end but remarkably the 2 failing Chromecasts came back to life.

Not at the same time though. about a week in between.

thank you !

Irad

 

 

Jeran
Community Specialist
Community Specialist

Hey there igerman,

 

I'm glad to hear that! I can't say I did anything on my end in particular, but I'm happy that it's working for you again! Do you know if the firmware or anything updated on them, or do they seem the same as before?

 

Best regards,

Jeran