Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google remote DEAD

Community Member

Hello I have a chromecast ultra, and my remote just suddenly stopped working, I have tried everything, I changed the batteries for new ones, forgot the remote from Chromecast and tried to paired it again, and I tried to reset the remote to factory settings but the white light won't come on it's like the batteries are dead but I have tried with several new batteries, I even tried with another google remote that I have ( I have two Chromecast at home) and it worked fine, the remote just seems like it's not getting any energy. Please help


Community Specialist
Community Specialist

Hi dnogmon,


Thanks for posting and for being a step ahead of us. 


Sorry to hear about the trouble. I wanted to follow up and see if I could be of any help. A few things: how long was the remote functional before it stopped working? Are there any error messages from Chromecast when this issue occurred? If so, can you please take a picture of the error message? Could you also send us a photo showing your Chromecast and its remote control? 


Below are the steps on how to upload a photo:


  1. Start a new post.
  2. Click Insert Image.
  3. Choose an image source location.
  4. Follow the on-screen instructions

Also, you can tap the "Drag and Drop" option. Maximum attachment is 5 MB.



Community Specialist
Community Specialist

Hi there,

I just wanted to follow up to see if you still need our help. Please let us know as we would be happy to answer any questions you may have.



Community Specialist
Community Specialist

Hey dnogmon,

We want to ensure you are good to go, and everything is working properly. Please let us know if you are still having trouble, as we will be locking the thread in 24 hours due to inactivity.