cancel
Showing results for 
Search instead for 
Did you mean: 

No longer able to add devices to Chomecast Remote (Chromecast with Google TV)

iketricktor
Community Member

I was having issues with my Chromecast giving no signal to my Sony TV even though it was on. I contacted Google and they said my device was out of warranty and that I needed to buy a new one, so I did. This new device was having the same issues, so it got warrantied.

I am now on my third Chromecast and now I can't add my TV as a device for the Chromecast remote to control. When I go to settings --> remotes and accessories --> set up remote buttons --> add a device, I get to the screen where it's looking for the brand of the TV and I get an error saying "something went wrong". No matter how many times I select try again, it gives me the same error. I have two different remotes paired to the same Chromecast and they're both giving me that error. 

I have tried a factory reset along with clearing the data in the "Android TV Infrared Service" app and neither has worked.

This was not an issue with the previous Chromecast. What can I do to fix this? I really don't want to get stuck in the cycle of continuously getting warranty replacements and having to start all over.

109 REPLIES 109

Blountbassey
Community Member

I have to wonder if Google even monitors or cares about this issue...I want to give them the opportunity to reply but nothing yet.

spongybrick
Community Member

Same issue here - new Chromecast 4K, all updates applied, get spinning wheel for 1 second after pressing ‘Add Device’ > TV then nothing.

Just tried factory reset and set up again via Google Home app and it’s now working (LG TV)

J-Payne-26
Community Member

Me too, I just got the 4K today (16th April 2024) and I can't even get to the next menu where it'll display TV manufacturers. It thinks for a split second then returns to the previous menu. Can I return for a refund? This isn't ideal for me. 

I was having the same issues with both of my 4K's, and doing a factory reset "fixed" the issue with the menu. I know it's not ideal, and having to go through the excessively long setup process is annoying, but once I did, it worked flawlessly.

I nearly returned mine, but decided to keep it since the other alternative devices weren't as appealing to me. As always, your mileage may vary.

scose
Community Member

update the brand new dongle to the latest FW and if already installed just do a factory reset either way and remote setup will work afterwards. The reason? Because Google....

Gmoren
Community Member

I did a factory reset and by `:magic» it even added my Samsung TV without even having to touch anything. Just lost another hour of my life, but it works now

Pewima
Community Member

Same issue here and truly hope there is a better way to resolve this other than a factory reset? Come on Google - why are you no longer replying to this thread??

benweston88
Community Member

Yep. Same here. 75" Samsung 4K TV and brand new, fully updated, Chromecast 4K and selecting ‘Add device’ under ‘Set up remote buttons’ spins for a second then takes me straight back to the previous menu. Have updated the Android TV Infrared Service. Can power TV on and off with HDMI-CEC but no volume control.

UPDATE: I got it working by factory resetting the Chromecast and setting it up manually with the remote, not the Home app. Everything now works as expected. Clearly there's an issue with the automated setup via the Hub. I had also updated the Chromecast to the latest version of the OS before I reset it – it didn't fix the issue but perhaps it helped it after it was reset? Either way, if you update, factory reset and then set up manually, it works.

jwasch
Community Member

Same issue here.  Two brand new Chromecast/Google TV devices.  TV set to enable CEC.  No display of list of TV manufacturers when select to add device TV.  Just goes back to previous screen without doing anything.  Would like to keep them but Amazon Fire Stick is looking more favorable.  Not because there are problems, but because this seems to have been occuring since last October with no resolution or outlook for resolution.  I'd appreciate someone from support team to explain step-by-step the "workaround" others have had success with.  Is this done from Google Home on my cell phone, or from the remote?  Afterwards, is it necessary to disable further SW updates to prevent the fix from being overwritten or once the fix is established, is it okay to update SW?  

I got it working by updating the Chromecast and all its apps, factory resetting and then setting up again manually with the remote, not the Home app. In that order. Tedious but now works.

jwasch
Community Member

VERY happy to say benweston88 reply information worked.  Selected Factory Reset and went through setup again.  This time, when presented with QR code, I selected manual remote method at bottom of screen and typed-in credentials using remote.  On the way up, it mentioned it recognized SAMSUNG TV, and after full setup, volume and power worked as expected.  

User22
Community Member

Now in May 2024...same issue on initial setup. I select Add New Device, then select TV, the in-progress circle displays for just a second and then I'm back to Add New Device with no list of TVs to select from. 

 

The factory reset, as described by Icemage99, worked and now remote works as it should. 

Focr06
Community Member

Just like eveyone else here.. Brand new Chromecast w. Google TV 4K. I go to add device, and it goes back to the previous screen. Did reset it twice already. Same problem. When are you going to fix this? 

Steg24
Community Member

I have the same issue here. On an Samsung TV.

MichalW
Community Member

I had same issue, not able to add tv to remote and for example volume buttons not working. This is my first day with chromecast 4k. Reverting to factory settings solved the issue. That time, during initial setup trough google home, there was no update, and pilot configured itself ! My LG TV was added automaticaly. Volume buttons and power all works. I can also see the list now when i try to add tv, but no need. So... going to system/info and doing reset to factory settings solved the issue and system is up to date.

CPeto
Community Member

Thanks, and yes exactly the same result here. But it did take a couple of attempts and on the 2nd attempt it did it automatically. 

Shoffman
Community Member

Encountering this bug with a brand new 50$ 4k Chromecast. Can not add any other devices to my remote. I click soundbar button, it just sends me back to previous screen.

Rafael-Souza
Community Member

Same issue here. Brand new Chromecast TV. My older one has no issue to add devices

BG
Bronze
Bronze

Just bought a new 4K Chromecast TV, and it does the same thing. What kind of quality control are they doing?!?!? uh none?

CMor
Community Member

Switched to brand new 4k today and have the same problem when trying to add a sound bar...it spins for a second and then back to main screen.

Deyrt
Community Member

Good evening. Just wanted to let you know I was able to fix the problem. It turns out I had to factory reset the Chromecast and then manually set up the internet and login. Do not use the Google TV app. That's what caused the issue. Hopefully they fix it but that's the workaround. 

Mm1983
Community Member

That workaround has been going round for ages. Even in this topic. Its still crap.

Deyrt
Community Member

Thanks for your feedback. It worked for me but if you find another solution or they fix the problem please let me know. Using the virtual keyboard was annoying. Have a good night.

Bobyum
Community Member

I have the onn 4k with android tv dongle and I tried all the options above, including factory resetting and setting it manually instead the Google home app, but it's still broken. Please help!!

Justjosh
Community Member

My older chromecast/TV is the same build level (software) and it works fine. The new one.... Well; it has this issue. 

I already tossed the box so I can't return it... Wish Google would be more responsive for products we buy... 

davidjay43
Community Member

Same issue with a brand new 4k Google TV. Click "Add device", Google TV asks me to select a device, I select TV and it jumps back to the Remote Setup screen. 

 

I really didn't want to do the work around of factory resetting the device. I hate reinstalling apps and logging into everything. Especially since I have a kids profile setup. Such a pain! 

 

@Kimy , what's the story with a fix for this? You were responsive last fall when it first was reported and now we're 9 months later with tons of people reporting the same issue. How about getting this patch into the next sprint? 

Try a factory reset and select Set up with Remote - this fixed it for me

911carbrochief
Community Member

 

SOLVED SOLVED SOLVED

If you have been waiting for Google to issue a fix, stop waiting and try a factory reset.
All Settings > System > About > Factory reset
IMPORTANT - when setting up the device again, select "Set up with remote"
Yes it will wipe your device and setting up with the remote is more tedious.
But it also triggers the proper 'Add device' menu to set up the remote.

When setting up with the remote I was able to add my TV model for Power and Volume. Input button did not appear but once I was back to the home page, the device now appeared in my "Set up remote buttons" and I could select it.

As annoying as this is, it fixed my issue and everything is running smooth now.


pmbentron
Community Member

Hi, I bought a new Google TV 4K device in July 2024. Same issue, the volume buttons on google remote wouldn't change the volume on the TV, and also the google remote was laggy and sometimes went haywire on the TV flicking all over the place. I don't have a sound bar or any other sound system connected to the TV. After looking/changing many settings on the google TV device and in my TV (Hisense 75S8), plus rebooting, updating everything (google TV, my TV, all apps and system)... I finally bit the bullet, and the only thing that got this working was what others have done, which is to factory reset the Google TV device (my last resort), and set it up using the google TV remote only, NOT using the google home app on my mobile phone, I repeat, NOT using google home app on my mobile phone. During this setup with the google TV remote, I was presented with a screen that allowed me to manually select my TV manufacturer and then from there it let me try several sets of IR codes to configure the volume buttons, power button, input button, etc. until one set worked. After doing all this and finishing setup it all worked as it should. Also i mention one other thing, before factory resetting the google TV device, I moved the google TV device to the HDMI ARC port on my tv, which is HDMI1. I'm not sure if this has helped because I didn't test everything again while on this other port however I still mention it here now.

Also to clarify, when I talk about the google TV remote changing the volume on the TV, I mean the actual TV volume and not the google TV/chromecast volume which is apparent when you turn off CEC in the settings. After this is all setup as described above (with CEC turned on), there should only be one single volume (the TV's volume) between the TV remote and the google TV remote. I didn't have CEC turned off at all during my experience but I'm aware that if you turn it off there will be two separate volumes, so I'm just clarifying.