cancel
Showing results for 
Search instead for 
Did you mean: 

Unplug Eero extenders to setup Chromecast

ddornblaser
Community Member

I struggled for months to get my Chromecast devices working. Factory resets. Router reboots. The whole song and dance. No matter what I tried, the Google Home app would not see the device. Never had time to see it through until today. And I solved it!

Someone said to turn off band steering. So I did. No luck. Then I unplugged all Eero network extenders. That did the trick! Chromecast setup is done and the device is working! I wanted to memorialize my success here in case anyone else is having the same trouble. I’ve not turned band steering back on, fwiw, because so I don’t know for sure if it was or wasn’t part of the problem. 

1 REPLY 1

Jeran
Community Specialist
Community Specialist

Hey there!

 

I'm glad you were able to get those Chromecast devices working! I'm going to go ahead and lock up this thread, but rest assured that this thread is going to stay visible for public viewing. Feel free to make a new thread if you have any more questions or concerns.

 

Thank you for your help!

 

Best regards,

Jeran