cancel
Showing results for 
Search instead for 
Did you mean: 

Watching Lorex IP Cameras on Google TV (TCL)

mlandau33
Community Member

I have a Lorex POE IPCamera security system that works with "Hey Google." I set up the Lorex Home app with the system and it works fine on my Android phone. I set up the Google Home app with the 4 cameras and the Lorex Home app and I can view video from the cameras on my phone through Google Home. When I give the TV the Google command to Play the camera on the tv, it recognized it. A horizontal line then shows across the bottom of my tv, the line then disappears, and then the tv displays "Smart Home Camera." No video ever plays and after a few minutes, the screen reverts to the TV's home screen. Lorex support was no help and put the onus on Google support. Does anyone have an idea what is wrong? Thks

4 REPLIES 4

SupportTech
Community Member

Have you gotten anywhere with the issue? I’m experiencing the same thing with my Google nest hubs.

I haven't gotten anywhere. I keep digging on the net and trying different things, but no luck.

You should contact Google Support for Nest for your situation. I had contacted the Support for Google Tv/Chrome cast. I hit the screen button for them to call me and a Support called me right away. She spent over an hour with me and thought it might be TCL's problem.  You, with a Nest camera, they should easily be able to diagnose and solve your problem. 

GarrettDS
Community Specialist
Community Specialist

Hey folks,
It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread.

Have a great day.
Garrett DS