Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

New phone & cannot access Nest account

Community Member

Upgraded my phone, transfered all apps, but cannot access the Nest app. I tried sign in with Google but the new ohone is integrated.  Tried sign in direct with Nest, doesnt work.  Tried to reset my oassword, but the password re-set email never arrives.  Not in spam folder either.  Tried creating another account, but it wont happen until the original account is deleted.  Any ideas?


Community Specialist
Community Specialist

Hi Marien79,


I’m sorry you’re having trouble accessing your Nest account. No worries, we’ll sort this out — a few questions: what’s the make and model of your phone? Is your phone’s software up to date? When did you first notice the issue? Also, is your account a legacy (sign in with Nest) or migrated account (sign in with Google)?

Here are some troubleshooting steps you can try:


  • If signing in with Nest doesn’t work for you, try signing in with Google then choose your Google Account. 
  • Check for software updates on your phone. Obsolete OS versions may break some app functionality.
  • Switch your connection from Wi-Fi to cellular data then try signing in again to your Nest app.
  • Restart your phone. Turn it off for 60 seconds. Then, turn it on.
  • Try another device if your Nest app works with no issues. 

Let me know how it goes.




Community Specialist
Community Specialist

Hey there,


It's me again. I want to make sure you're all good — did those steps work?



Community Specialist
Community Specialist

Hello there,


Just checking in to make sure that you've seen our responses. Please let me know if you have other questions or concerns as I will be locking this in 24 hours if I won't hear back from you again. Feel free to start a new thread and we'll be happy to help.

I appreciate the help, JT.




The problem has been resolved!  Thank you for all the help!

Community Specialist
Community Specialist

Hey folks, 

Awesome — glad to hear that your issue is fixed. It looks like we can consider this one complete, so I will lock the thread shortly unless I can help out with anything else.