cancel
Showing results for 
Search instead for 
Did you mean: 

Heat link and thermostat 2nd gen not connecting

Ling
Community Member

Tried everything but the heat link and thermostat won’t connect. The heat link is flashing yellow and green but try to do restart but doesn’t work. Tried resetting, soft and hard reset, moved thermostat closer, switched heat link on/off but nothing seems to work.

4 REPLIES 4

Frustratedddd
Community Member

Resetting the Heat link is by pressing and holding the button for about 30 seconds until you get a blue light pulsing. Then go to the display, you will probably have the screen which gives the option Reset pairing, click that. Failing that you may have to do the replace heat link, and enter the code on the lid to pair.

CristianC
Community Specialist
Community Specialist

Hey @Ling,

I'm sorry for the late reply. Let's try these steps:

1. Bring the display and base closer to the Heat Link and make sure the boiler is not in between the Heat Link and thermostat - only if possible.
2. Turn off the router and other WiFi or Bluetooth devices ( router, speakers, cordless phones, baby monitor, etc. ).
3. Select Replace Heat Link.
4. Enter the entry key ( do not confirm it yet ) — you can find it at the bottom side of the Heat Link, near the screw.
5. Restart the Heat Link twice by pressing on the Nest button for 30 seconds each time.
6. Confirm entry key.

Let us know how it goes.

CristianC
Community Specialist
Community Specialist

Hello again. Just checking in. Did the steps help?

Chris12345
Community Member

I have the same problem. 
I have followed the above instructions but the exact same problem is happening.