cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Thermostat: "nest thermostat can't connect to assisting device"

rgaila
Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original Poster: Jen Frazier 

I'm trying to set up a new Nest Thermostat using the Google Home app on iOS. It's not the learning thermostat or the E, just the "Nest Thermostat". The Home app is able to connect to it (supposedly) but it can't setup wifi. It gets stuck at trying to use "assisting devices" to connect to my thermostat. What is an assisting device? I have a few Google Home Mini devices but I guess they aren't assisting! Either way, I just end up with this error "nest thermostat can't connect to assisting device" and I'm out of luck. 

 
I've gone through all fo the troubleshooting steps short of changing my router settings because frankly I'm pretty sure my router is set up just fine. I have my Fios modem broadcasting a dual 5g/2g signal and another router with separate 5g and 2g access points and connecting to any of them on my iPhone doesn't fix anything.
 
Any tips??

 

15 REPLIES 15

srkmr23
Community Member

I have the same issue with my thermostat, were you able to figure it out?

mdagata
Community Member

same issue here

joshdannenberg
Community Member

I am having the exact same issue. Arrrrrgh!

PeterBklyn
Community Member

Same issue. Any update or resolution from this group??

Peter, the only solution I found elsewhere is to create a new "Home" in the app, and link the thermostat to it. It's a real pain if you already have a bunch of devices already connected to your current "Home", and it will require you to transfer all of them over. But it does work when setting up the Next Thermostat. 

Google should really fix this issue.

curly2134
Community Member

Same exact issue, and had to set up a new home. How 30 min install stretches into hours.

greekscramble
Community Member

Same issue. I'm going to return it. I'm not setting up a new home.

I was able to fix this problem and now have 5 thermostats running fine. I spoke to support and walked through it. Took awhile but we learned the glitch. Essentially after the first thermostat links to the wifi network every subsequent Nest needs to both have wifi signal and link to the first thermostat. That require the first thermostat to be awake and active. If you install a couple nests all at once, you should avoid the issue. If there is time between setting them up, go back to the first and reset it so it is fully rebooted and awake when you attempt the to link the 2nd.  During troubleshooting at one point I did uninstall and reinstall the app on my phone as well. You don’t lose anything doing this as all your home details are saved in the cloud. 

the main conclusion here is you do NOT have to create multiple homes. There is a bug in this process that I anticipate will be addressed at some point. If the instructions I hinted at above are not enough, just call support. The person I spoke to was super helpful and had real suggestions to walk through and we made quick process. 

good luck

Thanks! I have two other learning thermostats that have been installed for over a year. This third being the google nest thermostat. I'm hoping that you've identified my problem. I'll give it a try.

Jake
Community Specialist
Community Specialist

Hey all,

 

Sorry for the late reply. I wanted to follow up and ensure everyone is good to go. Please let me know if you are still having any trouble from here, as I would be happy to take a closer look and assist you further. 

Best regards,
Jake

I am having no luck with my second thermo. It can't detect the first one for the "assist". Do I need to factory reset the first one and install them both within minutes of each other? I tried the soft reset and turned them both on so that they're alive and awake.

 

This was my exact problem the first time and I did perform a factory reset on the original thermostat and then successfully added the second thermostat immediately thereafter. For subsequent thermostats, though, I did not need to do another reset though I did make sure the original was “awake” when adding new devices. I thought/hoped there had been an update to address the issue you’re encountering but perhaps not. What might be the issue is adding the first device after the original. Once there was more than one in my system I did not run into the problem again. I believe I have added 7 total including later changing one out for a learning model. 

Rs2
Community Member

Still doesn’t work.   I can’t add the second thermostat, even after adding a “new” home.  It doesn’t like my address?????   This is beyond ridiculous.   I NEED both thermostats working please!!!

mdagata
Community Member

Yes, I am still having trouble.  I have replaced two old nest thermostats with new G3 E Thermostats....I cannot add them to the app because the process of using another device for assistance always errors out.  I have seven thermostats total and a 2.4ghz-only network.  it used to be adding to the app was easy but this using other devices to "assist" is glitchy.

Taylorlehmann
Community Member

Just let people set the new device up directly and not force them to do Nest Assist. Easy.