cancel
Showing results for 
Search instead for 
Did you mean: 

Nest thermostat is blinking green with a black screen, tried to charge but not working

rgaila
Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original Poster: Sung-ihk Yang 

My Nest thermostat is blinking green with a black screen. I have tried to charge for several hours and force to manually restart the device but it is not being fixed.
 
3 REPLIES 3

rgaila
Community Specialist
Community Specialist
Hello Sung-ihk, 
 
Sorry to hear about your thermostat issues! I can understand the frustration behind decoding our thermostat's blinking lights. I'm more than happy to help look into this for you. 
 
A blinking green light means your thermostat is updating, starting up, or restarting. Since the restart isn't taking, it might be updating its software.  You can check your thermostat’s software version by going to Settings  >  Software on the thermostat. You can also use the Nest app: In the top right corner of the app home screen, tap Settings  > select your thermostat > scroll down and tap Technical Info.
 
Generally, how long it takes for a thermostat update to finish will depend on the quality of your thermostat's Wi-Fi connection to the internet. If the update takes more than 15 minutes, try restarting your thermostat again. 
 
If your issue continues to persist, let me know. I'm here to help! 
 
-From Ai, Community Specialist.
 

LL
Community Member

I am having the same issue but after it restarts it immediately dies. I remove from wall externally charge battery and then it only lay about 15 minutes before it does again. It is out of the box brand new and this has been going on for about 4 weeks. It originally worked for about 3 days and then this never ending cycle began of charging resetting and then dying. 

TL54
Community Member

I had that problem, replaced the Nest with another new one and it happened again. I spoke to tech support to no avail. I checked on some forums and found that I needed to connect the C wire. So instead of using four wires I had to use five for the wiring hook up. Since I did that it's been working fine now for the past two years.