cancel
Showing results for 
Search instead for 
Did you mean: 

Thermostat e shows download app logo can't connect

Kris1
Community Member

Having issues. I've downloaded the App signed in etc followed the instructions to plug in the thermostat etc.. I keep getting the download  logo on the thermostat. Even after resetting it I can't link it in the app on my mobile tried the turn off and on reboot, sit it next to the router reset router etc etc etc ..  but still the download logo appears on the thermostat.. any help would be appreciated.. 

3 REPLIES 3

Fionachunter
Community Member

I am having the same problem. I couldn’t connect to the network so I gave up trying and did a factory reset. Didn’t work so I reinstalled the app and removed the nest. Now it’s stuck on the download icon and I can’t pair it with the app. It’s ridiculous and have seen so many similar posts.

Jake
Community Specialist
Community Specialist

Hey all,

 

Apologies for the delayed response. I wanted to reach out, and ensure everyone is good to go. Please let me know if you are still having trouble with the download logo appearing on the device, as I would be happy to assist further.

 

Best regards,

Jake

Nope - still the same problem. I’ve let it run down battery a couple of times too in the hope it would miraculously reboot