cancel
Showing results for 
Search instead for 
Did you mean: 

there was a problem connecting to the Nest Service. Try again in a few minutes

redkiwi
Community Member

I keep getting the error "there was a problem connecting to the Nest Service. Try again in a few minutes" I am using iPhone XS and it has the latest iOS software and the latest Nest app. I have tried killing the Nest App, reinstalling the Nest App with no success. I dont get the error when using the web browser based Nest Home site.

13 REPLIES 13

Pat22
Community Member

I'm having the same problem. I have an iPhone 7 and it's been fine until the Google migration. Camera connects just fine. Thermostat doesn't.

scott300
Community Member

Me too. Any resolution to your problem

 

Pat22
Community Member

No… thinking about spending hours on the phone/chat to try to figure it out. I’m afraid to reset the whole thing because I might not be able to set it up again. Aaarrrggghhh.

redkiwi
Community Member

Nest told me it was a hardware issue and I would need to buy another one!! I cant believe that is the truth as it does connect sometimes. I thought it might be a router issue, but when I connected my Nest via my cellular data connection I still get the issue. All my Nest Protects and Nest IQ Camera connect fine. I cant stomach having to buy another Nest Thermostat for $400. They didn't even give me a discount code or anything. I am sure Nest prior to Google acquiring them would have had much better service.

GarrettDS
Community Specialist
Community Specialist

Hey there,
Sorry for the late response, but I wanted to drop in here to help.

I understand that this can be confusing but I definitely wanted to stop by and see how I could help.

Just wanted to double check to see if you were still needing help on this? If so, what troubleshooting steps have you tried? It looks like some people are saying that they are having success with this now, but please let me know if you have any other questions or if you're still having issues.

I look forward to hearing from you.

Best regards,
Garrett DS
 

Pat22
Community Member

Hi Garrett, I think I have tried every option to get the app to show up on my phone except totally resetting it because then I'm afraid I will lose the current programming. I've tried adding a new device, connecting, deleting the app and then trying it again. I've tried to get it on my iPhone, my husband's iPhone and my Samsung android notebook and nothing works. I quit trying until I had  a looonnnngggg time to sit at the computer and try to figure it out on chat. Others have said that I should get a new thermostat. This one works just fine except it works like the old fashioned one that I stand in front of and set the dial. All I see when I go to the app that's on my iPhone is is picture of a house and the outside weather. I've tried many times over the last few months. Seems to have started when I migrated to Google.

redkiwi
Community Member

I just tested mine again. I open the Nest App on my iPhone and I can see my Camera, Thermostat and Protects are all online and working fine. I left the app open on my iPhone for less than 5 min and sure enough my Thermostat goes OFFLINE but the other two services are connected and working fine. I also went to the nest.com website and the thermostat is OFFLINE there too. 

GarrettDS
Community Specialist
Community Specialist

Hey there, 

Sorry to hear about the troubles you're still having with this. I understand that you may not want to do a complete restart of the devices or the app, but unfortunately that may be the best option for you to be able to fix the issue. You can always try to uninstall and reinstall the app, clear the cache from the app, then as a last resort do factory resets on the devices.

 

Although it may restart your current programming, it may be the fix that you need. 

Please let me know if you have any further questions. 

Best regards, 

Garrett DS

Pat22
Community Member

I went to chat, spent a couple of hours with it ultimately doing a total reset. Lots of tries a re-tries later I was finally able to connect to the app. 

GarrettDS
Community Specialist
Community Specialist

Hey folks,
It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread.

Have a great day.
Garrett DS
 

MikeNeil
Community Member

I’m having the same issue with 12+ cameras in 3 different locations and networks.  It isn’t a HW problem.  It is something wrong with the app or service.   Does Nest/google even monitor these posts?

Jcisking
Community Member

I am having the same issue. 

Thoidai4khong
Community Member

I have the same issue