Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google Wifi LAN port drops to 100 mbps

Community Member

Hello all
I have the problem, that my wired Ethernet speed drop to 100 mbps with using Google Wifi on my network.

My set up:

1000/100 mbps ISP Modem/Router -> 1 port connected to Internet (WAN) on Puck 1 -> Ethernet (LAN) connected -> Unmanaged Gbit Switch 1 ->  Unmanaged Gbit Switch 2 -> Puck 2 (WAN port)
To the switches I have 20+ connected equipment, camaras, printers, AppleTV's and also a Puck 3
All the Google WiFi pucks are wired to a switch in the network..
I have had this set-up for several years without any issues. I have a similar set-up in my summer house in Sweden.
My problem:
6 month ago, suddenly the ethernet speed dropped to 50-80 mbps on the network. Also wireless near puck 2 and 3 was slow, whereas puck 1 was fast.
When measuring with Google home, the speed 800-900 mbps is reached, but measuring with a computer after Switch 1, results in 50-80 mbps
I identified the problem to be the cable between Puck 1 and the fist switch, since the light on the switch port signified that the speed was dropped to 100 mbps. I then exchanged the cable to a new Cat6 cable, but it did not help.
I then exchanged the switch, but it did not help.

I then replaced Puck 1, but that did not help either.
The only thing that helps is to hard-reset the puck 1 and/or delete my home / network setup on google Home.
Then it works for 10 min with 1Gbit on the network, but then it drops to 100 mbps.
I have tried with many cables, but it just feels like that the firmare in Google Wifi automatically drops the speed on the LAN port no matter what.
Have anyone any good suggestion on next step? or any other advice (beside putting my pucks in the bin) ?


Platinum Product Expert
Platinum Product Expert

I escalated this thread in hope of getting Google to look into this.

While we're waiting; what exact switches do you have?

I don't work for Google.

Community Member

Hi olavrb

I is four different models of switches, all from d-link the one attached to the router puck is a DGS-1008D

I have tried in different combinations

Community Specialist
Community Specialist

Hello everyone,

@olavrb, we appreciate your help here. 

@Bierwurst, thanks for posting. If you haven't already, please try changing your DNS servers to on your primary and on your secondary servers, respectively. You may also enable bridge mode for your ISP modem-router combo to avoid double NAT issues that might cause slow speeds. 

Let me know how it goes.


Hi LovelyM
I will try this as well. I did try bridging-mode before, but my ISP have since reset the modem/router.

The DNS servers, I have not tried changing.

I will let you know how it turns out!
Thank you!

Hi @Bierwurst did you got any solution for this problem? I am having the same issue.

Hey @LovelyM Is there any KB provided from google to help on this issue?

Hi @LucasSchirm . Yes it is working now (se description abowe)

Hi again @LovelyM 
Now I had tried the above changes on DNS servers and bridging mode and it is working really well. A measure now say 900/100 mbps, and that is on the following path: ISP Router (bridge) -> Puck 1 -> Switch 1 -> Switch 2 -> Computer. So that works really well!!
I did also did som re-wirering from : ISP Router (bridge) -> Puck 1 -> Switch 1 -> Puck 2 -> Switch 2 -> Computer. (I have now moved puck 2 not to use the LAN output)
So, thank you very much! I will continue to test for a few days.

Community Specialist
Community Specialist

Hello LucasSchirm, 

We have your form here. I'll bump this up with our senior specialist team so they can work on your case as soon as possible. Please check your Inbox from time to time so you won't miss their email.


Community Member

The issue has been solved (see below) and at the same time the LAN port on the Google Wifi now continues to run at 1 gbps (signaled by the LED on the connected switch)

Community Specialist
Community Specialist

Hi there,

I’m glad to hear that this has been sorted out and thanks for sharing your resolution in the Community!

@LucasSchirm, give Bierwurst’s resolution a try and let us know how it goes.


Hi @Alex_S ,

I am not using a switch, but I already changed my modem to bridge mode and try to reset the whole network and still have the same issue. 



When I try to do speed test on the Home App it does 500mb speed, but when I test the google speed test or ookla from the same device I am using the app or a laptop  it does show my speed as 100mb.


When I trigger the speed test from multiple devices at the same time they share the 100mb and get the avg of 50/60 mbp per device.

Hi @LucasSchirm Did you try @LovelyM suggestion: changing your DNS servers to on your primary and ?  I am not sure what difference it should make, but never the less, it worked for me 😉
If you can borrow a Gigabit switch, you can try if your puck lowers the bitrate, by looking at the LED for the port (Normally green for 1gbps and yellow for 100mbps). That was what my puck did, but that problem has disappeared. I have even switched back to the original cables and it still works fine now.
BTW, I also did speed tests on both laptop and stationary PC's, and discovered that the LAN port on my Lenovo laptop only runs at 100mbps (that was not the issue, but still good to know)
Good luck!

HI @Bierwurst thank you for getting back to me.

I am using the google DNS as suggested but no difference for me. I know that I have a giga lan because when I test speed from Google Home App it does get to my 500mbps bandwith, only on the devices connected to the network that I am seing this limitation.


On my laptop when I try to connect direct to the modem wifi it goes to top speed as expected, as soon I switch to the google nest it goes back to 100mbps.


I ordered a cat 6 cable and a dongle to test it direct on the laptop from the dot, but I suspect it will be the same, since I already know that the NEST is getting the right speed.

I hope the cat 6 cable will help! Good luck!

Community Specialist
Community Specialist

Hey folks,

@LucasSchirm, I want to check if you were able to test using a Cat 6 cable. Let me know if that did the trick or if you still need further help.

@Bierwurst, thanks for your suggestion.


Change cable did not improved it, but I noticed that if get close to the spot connected to the router the speed is closer to 500 but if I go closer to the second spot it goes back to under 100mb

Community Specialist
Community Specialist

Hi LucasSchirm,

I would like to check if you've tried to factory reset your Wifi devices according to this article. If you did, please fill out this form and we'd be happy to look into your issue further. 


Submitted the form again, never heard back from them