Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest connect yellow blinking light / yale lock won't connect

Community Member

I just replaced my wifi router with a Deco S4 router mesh system.

I tried to configure the Connect to my new wifi network but it failed. I removed it from the app and re-added it and it seemed to connect (blue then green light to indicate OK) but after a while it blinks yellow.

I have checked and I have a good internet connection on all other devices on the network, only the Nest products are problematic. Thermostat works fine. Just the Connect seems to be failing and preventing the Lock from getting on the network.

I tried to do a factory reset of the nest yale lock in case there was some conflict with it being linked to the old network but that didn't help.



Community Specialist
Community Specialist

Hi there,


Sorry for my late response. Thank you for all of your patience while waiting for a reply. I just wanted to make sure that your issue is addressed. I am terribly sorry to hear that you have had such a hard time with this! I would love to look into this issue further and help find a solution for you. First off, I have some questions I’d like to ask you.

  • Do you still need help with this issue?

  • What troubleshooting steps have you done thus far? 

  • Have you tried to restart your device if you haven’t already?

  • If the restart didn’t work, have you tried to do a Factory Reset? This would be a last resort option, but would clear out issues and the device would essentially be ‘brand new’

Please let me know if you need further assistance. 

Best Regards,


Community Specialist
Community Specialist

Hey folks,
It looks like we haven't heard back from the OP so I'm going to go ahead and lock the thread. If you have any further questions or concerns, feel free to create a new thread.

Have a great day,
Garrett DS