cancel
Showing results for 
Search instead for 
Did you mean: 

Google Speaker Groups not working

MsLevis
Community Member

I'm also having similar problems-  Have mix of Google audio cast and google enabled speakers across the house- most of the time casting doesn't work - If I go into the home app the groups are disappearing and re-appearing alot- I'll select a group that worked the day before and only one speaker plays - it still shows all devices playing-  I can try it a few times- go in and out of the google home app and try to force it that way- sometimes it works, sometimes it doesn't - all the firmware is up to date and it's just SOOOOO frustrating -  I even went and got a new google home speaker thinking maybe gen1 was causing an issue- nope still same problem-  COME ON GOOGLE!!!  

395 REPLIES 395

Eoin
Community Member

@frances wrote:

Hi All,

 

Thank you for taking the time to try and troubleshoot this issue. I appreciate your time and will try to help all of you. Thanks for your patience!

 


I'm reading your replies and you are literally no helo at all. Just the classic "Okay we'll email you". Are you for real?

 

Patb095
Community Member

Cut the carp… you are not helping… google has been having this issue for YEARS!!! 

frances
Community Specialist
Community Specialist

Hi @MsLevis

 

Thanks for reaching out. I have made a case for you so that you can receive more help from the support team. This will be sent to the email address associated with your community profile. Your Case ID is: 9-4321000031991.

camoreno02
Community Member

Hi, my Vizio TV with Chromecast built In does not appear to be available for my group of speakers. My TV is V655-J09

marcinjkt
Community Member

Same problem here, although I cannot play anything on the speaker group (includes 3 Nest minis, 1 Nest hub, 1 Nest audio, 1 Chromecast-enabled 3rd party soundbar) at all. Tried from Home app, tried by voice command, tried via routine, tried via casting to the group. Nothing works. When I give voice command it says 'playing XYZ from Spotify on Everything' (Everything being name of my speaker group with all  speakers) and nothing happens. When I try to play it via Home app it loads for a moment and then displays error message 'Unable to play on that device at the moment' (very helpful, thank you very much). Tried clearing the cache from Home app, tried reinstalling the Home app, tried removing and re-adding the speakers. It's been that way for months by now. What the hell guys.

ClausBP
Community Member

My issues with Google speaker groups are only with giving voice commands

1.
The issue is only with speaker groups with mixed brands - e.g. a group og 1 Google Nest Audio and a JBL Bar 5.0 with Chromecast built-in™

2.
The voice command will work fine right after the group has been created

3.
After some hours the speaker group will not respond to Voice commands anymore

4.
If I rename the Speaker group e.g. by switching the first letter between upper and lower case - it will work again for some hours. e.g. rename group name from "House" to "house"

5.
GoogleHome-Support has given up and says that I am the only one with this issue (not likely - as we can see in this group) - and refers to JBL. Very disappointing, Google!
JBL support has also given up.

6.
Here is GoogleHome-Support's final remark:
"I hope all is well. Upon checking with our higher tier, because you only experience the issue with the third-party speakers in group then we need to refer you to your speaker manufacturer as we don't have ways on checking the settings or issues on your third-party speaker.

For your reference your case number is 3-1156000031930"

ClausBP
Community Member

SOLVED?
My mixed brand speaker group is suddenly working stable with voice commands.

I dont know why - but the issue with voice commands not working on my speaker after 24 hours  seems to be resolved.
It has now been working fine several days!!!

Odd. I updated to latest home app that came out a few days ago and still have issues.

Will roll back to very old APK (where room renaming worked) and see if it works better, likely not though as the issue is likely on google servers as voice commands isssued goes there first, then sent back to host item to execute (if i get it right, its not like its local at least 🙂 )

 

If all fails ill send back

3 nest hubs v2

2 home audio v2

4 mini v2

1 JBL link

and try Alexa instead, at least they have zigbee built in that i need anyway for parts of home automation.

If i tell Google to play musinc on group test, it only plays on jbl link, not google audio speaker 🙂 JBL doing something right?

Maybe ill keep the jbl send rest back. After all its portable and ip x7 and has charging cradle 😉 while google audio has none of above (but slightly more base and warmer sound)

pdeperio
Community Member

also have a JBL Link Portable in a group with Mini and Sony soundbar, which randomly works sometimes (more often not)

ClausBP
Community Member

Yes - my issues are also only related to groups with speakers of mixed brands.

Always working if I play directly from apps.

But sometimes voice commands will not work and I have to rename the group.

But as I mentioned - voice commands have worked perfectly for the last couple of weeks!!!!

Pretty annoying that I don't know why... 🙄

sheppp
Community Member

I, too, have a JBL Link Portable (2 of the, in fact). I also have 4 other mixed-brand speakers that connect via Chromecast Audio. All play fine via C.A. if I play them individually. When I attempt to play all 6 together in a group, however, much of the time (but not always), the 2 JBL's won't connect right away. Furthermore, once they have connected in group mode either one or both of the JBLs will drop out much of the time. I've done the factory reset thing several times, changed their names, re-created my group, etc., but nothing eliminates this problem. I utilize a Netgear Orbi mesh routher with several satellites. Regardless, I have the connection problem no matter whether the JBL's are within feet of the satellites or not. Any suggestions that work would be greatly appreciated.

DanS
Community Member

I'm seeing a common thread of many having mesh networks.  That would coincide with the start of my issues.

sheppp
Community Member

SOLUTION (somewhat pricey - but cheaper than Sonos speakers):  After trying a myriad of possible solutions from many sources unsuccessfully, I finally upgraded my old Netgear Orbi mesh router (RBR50) to an Orbi RBK753S (WiFi6 mesh)at Costco (I chose Costco because Netgear is horrible/expensive to deal with after 30 days - and Costco takes anything back well after that time period). Although Netgear's instructions for setting up the RBK753S (RBR750) as an access point are completely insufficient/wrong (instead, if going through a typical ISP router/modem first, you actually have to connect the new Orbi directly to a non-networked computer so that it will recognize it - then change the Orbi to an "access point" in "Advanced" settings), I eventually got the router working. Once that occurred, and I re-configured my wireless Chromecast Audio devices with the new Orbi IP address (which introduced a new set of headaches), my group Chromecast audio has been working flawlessly!

Thanks to all who either privately or publicly attempted to assist me!

Renaming speakers/rooms only work for google gen 1 in the latest home app.

Renaming nest v2 speakers/screens/rooms only work with very old home APP (download via APK). There's s long thread on the subject, also unresolved and had been there since 1year +

MAYBE the issues are connected? Especially given that you say group play work when changing room name.

Actually - the issue with "mixed brand speaker groups that will not respond to Voice commands after some hours" was resolved some time ago for me. I don't know how - probably due to an update in Googles server environment.

I have no issues in my 2 Google Home environments in my apartment and summerhouse.

My 2 mixed brand Google homes with  Chromecast Audio, Google Hub, Google Nest, JBL Soundbar,  JBL link portable and B&O M3 works fine with voice commands and I am able to rename both devices and groups with newest version og iPhone/Google Home App.

Sadly I don't know why/how the issues was resolved...

OmaCoder
Community Member

I do. Google only devices, speaker groups do not work. Haven't for about 3 months now. 

ClausBP
Community Member

@OmaCoder
Do the speaker groups not work at all - not even when casting from an app?

Or is it only using voice commands that the groups don't work?

OmaCoder
Community Member

You are correct. Not at all. I had a ticket open but stopped hearing from them after the first month of me claiming. Their latest solution for me was that I have to rename everything. So my Kitchin room, I'd have to name that Cook. Or my loving room I'd have to rename that to Library.

 

At that point I said I was out and wanted all of my equipment replaced under warranty. That's when I stopped hearing from them. 

Most of my issues are all mentioned above. But those aren't all the issues. Everyone has been chiming in with completely odd behaviors as well. This has just turned into a major issue about speaker groups and naming locations. I wonder if the Russians have it hacked. 

ClausBP
Community Member

I can certainly understand your frustration.

Did you try another Internet router?

OmaCoder
Community Member

That's exactly when it started happening. I moved. Speakers just got thrown in boxes and I didn't keep track which one was assigned which room. I got new internet and a new router. 

Same, all google devices

Maybe if we all do this 300 times a day:

  •      "Hey Google, Send Feedback"
  •      (wait for speaker to acknowledge you and ask for your feedback), and then say exactly:
  • "GHT3 Issues with speaker group"

This is the advice I got from support on my ticket to help escalate.

I have no idea what it does or what it means. Likely nothing. LOL. But it feels better to do SOMETHING than just sit here and complain

curious
Community Member

Hi Claus... so you're saying that your JBL Link works in a speaker group combined with other Google-branded speakers? For me, that didn't work and I returned the JBLs, but I would definitely buy them again if I knew they would work in speaker groups.

ClausBP
Community Member

Hi Curious!
Actually I have only tried to use my JBL Link Portable directly with voice commands.
But I will try to make it a member of a group and test next time I am in my summerhouse - and let you know.

dollnighshrimp
Community Member

I'm having similar problems to the others here. We've got two Google Home Minis (1st gen) in a home group. For months now, when audio is playing on one speaker, trying to transfer or add play back to another speaker just doesn't work. Play-back on the group results in audio on one speaker only. 

It's worrying to see so many people having similar issues and for so long. 

Really hope Google can help!

CeyssensD
Community Member

I also have issues with my speaker group, my parents also have the same problem.
I have 2 mini's, 3 hub's, bedroom clock, 2 Google ap's... everthing works except de hub's... they just do not want to play as a group... problem started like a week or 2 ago out of nothing...

LauraB
Community Member

Yep me too!! About a week or two ago suddenly the group I created doesn’t work properly. Google assistant either replies with “there is an error with that at this time” or nothing happens?! 

please help and resolve this problem. I’ve tried resetting devices etc. thank you!!

My hubs both play SOMETIMES (mostly google doesn't understand and tells me to instead say the name of the device), but volume is only increased on one of them, NEVER synched when i say i.e. volume 10 (or 100%)

Maybe if we all do this 300 times a day:

  •      "Hey Google, Send Feedback"
  •      (wait for speaker to acknowledge you and ask for your feedback), and then say exactly:
  • "GHT3 Issues with speaker group"

This is the advice I got from support on my ticket to help escalate.

I have no idea what it does or what it means. Likely nothing. LOL. But it feels better to do SOMETHING than just sit here and complain

I think I'll go back to manual knobs, SO MUCH FASTER 😁 and noone can spy on my volume or audio choice on DVD/CD 🧐

Unpack Atmos AVR and let google work this out some 5-10 years more and see if

Xiaomi, Amazon or google are good enough then. At least my Xiaomi home works flawless 😅 and costed me allmost nothing 4 years ago

 

Chris101
Community Member

My group just disappeared. When I tried to recreate it only my max hub shows up. All 5 are Google home devices. Newly created groups don't even show up anymore. So I can now only play one device at a time. Obviously a generic bug. I recently added two audios not sure if it's related to that? 

Breeva
Community Member

My group of 1 Nest plus 1 Home mini has disappeared from my app but voice commands still work. 

Hmmm i have one audio and same issue. 

I bought all gear at once though. Im pretty sure its annapp or server dide issue though as the lawsuit from sonos removed the speaker view (where you can adjust all speaker volumes in one view) so my guess is google just threw out a untested solution and cant keep up on development

DisappointedUsr
Community Member

My group shows up in the Google Home app but doesn't work. Music cant be casted to the group as it shows `connecting` all the time. It has been more than 1 month since I managed to connect to my group. I really hope the customer service could be better! Dont act like a stupid robot and ask the same **bleep** question about `how the group didnt work` or `give us the bull**bleep** instructions of how to set up a speaker group`. Use the 3 respects to guide your work!

Mookie
Community Member

Seems that there are multiple issues with Google Groups. My issue - same as ClausBP - is limited to voice commands: I can cast and it plays music on my group ( 1x nest mini, 1x chromecast audio, 1x LG speaker) like expected. However, if I voice a command like "play music xyz" (my group is set as default), google answers my correctly "playing music xyz on device abc", but most of the time the speakers remain silent - sometimes it works, but most ofen it doesn't.

funbi1112
Community Member

I also have this issue +1 (nest mini and max combo)

MeteorMan88
Community Member

I'm experiencing the same issue referenced above, where the audio only plays from one speaker instead of syncing across both devices.

I'm using an iPhone 11 (iOS 15.1) with with a speaker group comprised of a Home Mini and a Nest Mini (not sure which generations), and I've confirmed that the issue persists across multiple services (Spotify and YouTube Music). 

I also have a Chromecast (1st gen, I believe) that serves as a third speaker in a separate speaker group. Unfortunately, it also experiences the same issue when trying to sync audio across devices.

I've tried the following solutions with no success:

  1. Reset my wireless router multiple times
  2. Deleted and recreated the referenced speaker groups multiple times
  3. Performed multiple factory resets on both Google devices
  4. Deleted and recreated my 'Home' in the Google Home app
  5. Deleted and re-installed the Google Home app

Finally, I've been unable to fully remove my previously created speaker groups from the list of speaker groups when selecting the default music speaker, though it's unclear how that could be causing the issue.

What should I try next?

Obviously, UPnP/multicast needs to be enabled and working well across your home wifi network for Google Home audio groups to work at all...

I fixed all my group casting issues by deleting my Google Home (removes all devices and rooms - you can probably just remove your speakers from your Home...) hard resetting all my Chromecast Audios, powering all the CCAs off, then powering them on and adding them back to my newly created Google Home one-by-one.  One-by-one.

Google cocked up Home audio groups pretty good.  Every time I added a Chromecast Audio, I also had to manually add it to a room in Google Home - this allows you to access device settings.  No room, no settings, big problems.  Then in the main settings panel for my Google Home, I deleted the location/room I just added the CCA into.  Yes, odd.  Then, I renamed the Chromecast Audio from its settings panel...and finally I deleted the room the new CCA was in from the Google Home *again*.  Ultimately you want your device to be fully unassigned from a room/location before assigning it its correct location.  That's how I was able to properly add my (11) CCAs to my home in order to create audio cast groups.

Note that attempting to rename a group from its settings panel causes Google Home app to crash.  Best practice is to never modify groups - just create a new group and delete the old one.

Lots of other weird problems with names of rooms, locations, etc. related to audio groups.  Gotta have everything named and assigned properly in order for Google Assistant to work lol.  Total time waster thanks Google luvya you're welcome.

Moozicmon
Community Member

That is way, WAY too much effort to be expected by any user at any level. Kudos on finding a fix, but Google needs to formally address this BS.