Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Hub stuck on grey ‘g’ screen, factory reset not helped

Community Member

Hub stuck on g screen factory reset brings it back to g screen. Power off overnight, no change. 

1 Recommended Answer

Community Specialist
Community Specialist

Hey folks,


Thanks for sharing all the details about the issue. 


We understand this issue has been happening for quite some time now, but rest assured that our team is aware of this and looking into this issue at hand. Please try to plug in the device to a different power outlet, then attempt a reset.


If unresolved, perform the workaround below:


  1. At the back of the Nest display, unplug the power cord and wait for 10 seconds, then plug it back in and wait until the screen with the "G" logo shows up
  2. Repeat the first step, 10 more times.
  3. After the customer plugs the power cord back in, wait for the device to reset. The device announces "Welcome to Google Home" to signify that it's ready for setup.

Put your device to recovery mode:


  1. Put the device in Recovery Mode (Unplug the device, then perform a long press on the volume up and volume down buttons while the customer plugs the device back in. Once the device turns back on, release the volume buttons.)
  2. Once the device boots into Recovery Mode (a long press on both volume up and volume down buttons at the same time), attempt a factory reset.


If the above steps don't work, please reach out to us to get immediate support on this link:




View Recommended Answer in original post

1,523 REPLIES 1,523

Community Member

Adam, of course they did and looking at all the posts they still do not want to admit it. How can the google bricked by itself and all of us having this problem. Unfortunately, they do not want to replace the units not bought directly from google or their appointed representatives. I had mine bricked months ago ans they just tell me to be patient.  You all can send all send your requests directly to #########

Mines doing the same thing and has been for a few months now.

Mine is doing that as well. I’ve got a bunch of hubs and speakers in my house is there a fix?


Yes, move to Alexa.

You are so right, I started to replace slowly all my google speakers with Amazon echo and so happy to finally have something with no Glitches

Same here. Still waiting patiently for something bricked by Google.. which country are you in. Need to check if Singaporean are treated worse off as we are asked to be patient while many others have recently been replaced. 

Community Member

i am...i actually tot I'd get better service since i bought it from courts

I am having the same issue. I Tried unplugging the device, holding down the volume button, and plugging it back in. I got the factory reset menu to come up, but then when it reloads, it just comes back up with the gray screen and the G. What do I do?

Community Specialist
Community Specialist

Hello @Brussell93


Thank you for trying a variety of troubleshooting steps. I have made a case for you so that you can receive more help from the support team. This will be sent to the email address associated with your community profile. Your Case ID is: 7-2751000032470. 

Community Member

I'm having the same trouble as the users above:

  1. Stuck on the g screen;
  2. Unplug, plug back in = stuck on the g screen;
  3. Holding down both volume buttons while plugging it back in = factory reset menu, but then when it boots up it's again stuck on the g screen.

I've started a new case for myself using links from the accepted solution, and chatting with a live agent.

Community Member

i couldn't find any link or chat line for this..can u forward one to #########?

Community Member

I am also having the same issue, stuck on grey screen with g. The device was getting progressively worse the last few weeks /months. I'm seeing other people blaming it on google pushing out a new os that is bricking old devices. Please fix this. There was nothing wrong with my hub and now it's garbage because of forced software upgrade

I feel exactly the same. I have newer hubs that are working perfect but not the old one which was fine until last night. 

God luck. Better not update your newer hub just in case.

Seems to be. Downgrade to me! Now mine is useless too!

I have the same issue. Had a power outage last night and when everything came back on the Hub is stuck on the G logo.

Community Member

Same here 

I love this I hope they can replace it

Community Member

Which country are you from. Not all replaced as it depends where you are at.

Community Member

My hub has the same

issue and I have been unable to get through to speak with anyone. What are my options?

Community Member

Think the cases are growing everyday. Push for a replacement if you can.

Community Member

All the best! My case ID had been for months. Wait patiently they said.

I am having the exact same issue!!!

Just silly to have to do all these for something bricked by Google themselves.

same same :((

I am also having the same problem Gray screen.  It allowed me to try the factory reset and account it down and then went back to the same thing Gray screen. I've tried to unplug it from the back of the though nest and still nothing back to the Gray screen.. Help

I’m also having the same problem, tried recovery mode and factory reset but still just rebooting to a grey screen with a G in the middle. 

I am also having the same issue. Factory reset/recovery mode not working. Just got this thing like not even a month ago too…

Return it and change for Alexa instead.

Community Member

Hi I have the same issue, please advise me how to fix it. Thanks.

We have the same issue for 4 days now. We don’t know wat to do anymore. Please help. 

Community Member

Hello I am also having this issue factory reset does not resolve

Factory reset won't help this. This is a hardware and software defect. There is not solution to fixing this other than getting a replacement or just throwing it out in the trash.


Thanks, this is really a software issue since the device was fine until some random update.

Community Member

As far as I know there is no fix. You need to get a hold of Google via phone or chat and set up a case number and let them now. They will either replace your nest hub if it’s in warranty or you’re on your own at that this point.  Until they figure out what the heck is wrong  with the freeze, nothing will get resolved.

Community Member

So many of us faced the same issue. Google need to take some responsibility. They need to activate a recall for this bad update.

Community Member

I'm having the same problem. It just suddenly appeared, I think because of a new update. Nothing fixes it. Pls, share if someone has a solution.

Ask for a replacement.

Community Member

has there been any resolution to this issue as my Hub after power outage is displaying the same grey G  

Community Member

Any solutions? Replacements?

Facing same problem, FCC ID A4RHIA