cancel
Showing results for 
Search instead for 
Did you mean: 

New Nest Hub (2nd gen) won't display photos from Google Photos albums.

Moofey
Community Member

Separate from my other issue, I have my photo frame settings set on my Hub to display around 100 different photos from my Google Photos album, but my Nest Hub only ever shows curated art from the art gallery.

I've confirmed that Google Photos is selected in both the Home app and the Hub, that I have albums selected, and I have personal photo curation set to "Live albums only."

My Hub is running firmware version 1.56.313652.

Update 11/24: I performed a factory reset due to another issue and this did not fix the problem.

22 REPLIES 22

Bricemb96
Community Member

Im having the same issue

Dan_A
Community Specialist
Community Specialist

Hi folks,

I'm sorry to hear that you're having some concern with the selected photos not showing on your Nest Hub 2nd Gen. Was it working before or is this the first time trying? Since you have already tried the factory reset and confirmed that Google Photos are selected in both your Home app and your Nest Hub, could you also double check all on https://goo.gle/2Tp6dIH and make sure you use the same account as your Google Home.

It would also be helpful to check the personal results if it's active. Open your Home app then select your Nest Hub 2nd Gen. Go to the upper right corner where the gear icon(settings) is and choose Recognition & sharing>Recognition & Personalization and then turn on Allow personal results.

Keep me posted.

Best,

Dan

Moofey
Community Member

This is my first time trying. I have never successfully been able to get any of my photos to show up on my display. Additionally, I am using both the same account in Home that I am trying to use in Photos and personal results have been enabled.

Bricemb96
Community Member

No it’s not my first time trying iv tried many many times same issue among MANY issues with the 2nd gen nest hub.
Yes the options you mentioned are turned on and it’s on same account.

Bricemb96
Community Member

Anything?

Dan_A
Community Specialist
Community Specialist

Hi folks,

 

Apologies for the delayed response and thank you for your effort doing the steps provided. We want to go further and it would really help narrow things down if you could check your Nest Hub 2nd Gen device's settings. From the bottom of your Nest display screen, swipe up and go to settings. Tap the photo frame and see if you you can see any options.

 

To get more details, check out this guide.

 

Tell me how it goes.

 

Best,

Dan

Moofey
Community Member

I tried changing the photo frame via settings on the device itself. From there I'll select Google Photos, select the albums I want to display and tap done. After a few seconds, the display will start running its curated art album instead of the albums I selected, and if I go back to the settings menu I see photo frame is set to "Art Gallery" instead of "Google Photos."

This is just one of a couple of frustrating issues I've had with this thing, including the device restarting by itself. I'm contemplating whether or not I should just return it at this point.

Dan_A
Community Specialist
Community Specialist

Hey there,

 

If photos in your private and shared albums don't show up as expected, could you turn off curation for those albums when you change the Personal photo curation settings to Live albums only?

 

Cheers,

Dan

Moofey
Community Member

Changing curation to "Live albums only" did not fix the problem.

Muddi
Community Specialist
Community Specialist

Hey Moofey,

 

Chiming in to ensure everything is covered here. To confirm, are you using shared photos?

 

Cheers,

Muddi

Moofey
Community Member

The albums I've been trying to use are private. I believe all of my albums are and none of them work.

Muddi
Community Specialist
Community Specialist

Hi Moofey,

 

To confirm, are those photos uploaded or backed-up to your Google Photo account? To make sure that's it's already backed-up, please follow the steps on this link.

 

Let me know how it goes.

 

Cheers,

Muddi

Moofey
Community Member

Backup is off. The photo albums I'm trying to use are all manually uploaded.

Bricemb96
Community Member

Same!

Shouldnt matter wether it’s private or not though!

Muddi
Community Specialist
Community Specialist

Hey Moofey,

 

We appreciate your efforts. Please fill out this form with all the needed information then let me know once done.I’ll keep an eye out for your response specifically, so please let me know once you’ve filled it out.

 

@Bricemb96: What are the troubleshooting steps that you've done? Also, are you using a personal or business account?

 

Cheers,

Muddi

Bricemb96
Community Member

@Muddi its a Personal account.

as corn troubleshooting I have returned and exchanged one already thinking it had to be hardware defect but it wasn’t.

Still the same problems exist sometimes other problems will randomly come about as well.

besides the exchanging the device iv also factory reset the device countless times, factory reset then used a different google account, done all the above and tried on different Wi-Fi networks. It’s bugs in the code.

Muddi
Community Specialist
Community Specialist

Hi Bricemb96,

 

We appreciate your efforts. We'd be happy to take a look into this for you. Please fill out this form with all the needed information. I’ll keep an eye out for your response specifically, so please let me know once you’ve filled it out.

 

Cheers,

Muddi

Muddi
Community Specialist
Community Specialist

Hey Moofey,

 

We got the form you've submitted. We'll be reaching out to you via email and let's continue working on your concern through that channel.

 

@Bricemb96: Have you had the chance to fill out the form?

 

Cheers,

Muddi

Muddi
Community Specialist
Community Specialist

Hey Bricemb96,

 

I haven’t heard back, so I'll be locking this thread if we won't hear from you in 24 hours. Feel free to create a new one if you have more questions or have other concerns in the future.
 

Cheers,

Muddi

Bricemb96
Community Member

Yes, iv submitted a form.

 

as well as contacted Google support I don’t know how many times now.

Its always the same result, everybody with Google just blows it off anyways they can just like your doing now lol.

 

Talking about locking the thread in 24hours. Just so you don’t have to deal with it. Typical Google rep response.

Muddi
Community Specialist
Community Specialist

Hi Bricemb96,

 

Thanks — we got your form and has sent it over to our team for review. Please check your inbox from time to time as someone will be reaching out to you. Regarding closing the thread, as Community Specialists, we occasionally do a bit of housekeeping to keep the conversations in our community fresh and relevant. This includes locking threads after a period of inactivity, and if there's a case created. This is to avoid confusion as to where you will get an update for the issue that you have on your device.

 

I will keep this thread open until someone reach out to you via email.

 

Cheers,

Muddi

Muddi
Community Specialist
Community Specialist

Hey Bricemb96,

 

Upon checking, one of our team already reached out to you via email. I'll go ahead and close the thread now and continue working on your concern through that channel.

 

Cheers,

Muddi