Showing results for 
Search instead for 
Did you mean: 

Rooms just got wonky?

Community Member

Hello I have had several rooms set up for a number of years now but after a recent update it looks like things got screwed up.  Specifically I have a master bedroom room and master bathroom room. I use to be able to tell my google home in the bedroom to "turn off the master bathroom lights" and things would work fine.  Now when I do this it turns off the master bedroom lights.  It seems as though it gets the word master and stops its recognition. Any idea how to fix this?  Please know I have several bathrooms with smart lights so I can't just make a generic "bathroom" room.


Diamond Product Expert
Diamond Product Expert

Hi @josephkiser04 

I see there is an escalation over in the Google Assistant Community with users reporting exactly the same: Why is my google system controlling the wrong room? - Google Assistant Community 

I can let the Google Nest team for this community know as well.

In the meantime, send feedback and you'll need to rename the rooms without "master" name that is causing this new behavior.

Thanks for reporting!


Community Specialist
Community Specialist

Hi josephkiser04,


This is not the experience we want you to have, let me help you. A few questions: which Nest speakers are we working with? When did your issue begin? Were there any recent changes made?


To isolate further, it would help a lot if you could do a sequential reboot first: 


  1. Unplug the power cord of your router, followed by your Nest speakers, then your smart lights.
  2. Plug them back in after 3 minutes.
  3. Restarting your phone might also help.


Also, try to control your smart lights by saying the name itself instead of the name of the room and tell us how it goes.


Thanks for helping, JillG!




Hello Dan I have been programming my smart home for a number of years through the home assistant integration and have quite a bit of experience here.  In this case it's a nest mini 2nd gen. This issue came up about a week ago i think.  No recent changes. I have cycled power on the router and speakers and restated my z wave hub for the lights before making this post. It did not work.  It has something to do with the voice logic as I can call the lights individually and they work correctly.  When I call master bathroom it turns off the master bedroom lights.  If I move the master bathroom lights to another room (just bathroom for example) it works.  It seems as though the voice assistant logic gets to the word master and just functions on the master bedroom room. Removing master from either room brings functionality back.  I can't do this however since I have several bathrooms I need to designate the one as master bathroom. I do know this was an issue early on when the first Gen minis were still being sold (when I first started programming this home) but an update fixed this logic along the way. 

Since my question was moved (and thank you)!

  • This is a mix, Home Mini, Nest Mini, Google Home, Wi-Fi Point, Phone only via taps, Home Hub. all with same response mistake
  • router was not only rebooted but deleted from home completely via Home app, and had to be setup using QR codes. this made no difference ultimately, as the behavior reverted.
  • phone reboot was performed, and app and settings were removed from each household member's phones, as well as 2 ipads. app exists only on one device now, a Pixel Pro 7
  • lights can be controlled correctly if called out individually

Of note though, I AM participating in the public preview of Google Home. Maybe this is the common factor of all of us? Anyone NOT parcitipating and still having this issue?

Matthew Winfree

Community Member

I have the same issues. It started yesterday. GH confuses master bathroom and master bedroom. I also have another bathroom which  I simply named "Bathroom". When I ask google to turn on/turn off the bathroom lights, it defaults to master bathroom. It worked flawlessly until yesterday.

I have no understanding of how Google Home and Assistant are getting this wrong. Master Bedroom commands are being executed for a completely different room, with consistency, and through automation commands as well as verbal commands. The rooms do not sound similar, and the command is recognized correctly as seen below. Last night I spent 2 hours, removing everyone, clearing the cache and data from 3 phones, then deleting the house and setting EVERYTHING including the Google Wi-Fi up from scratch. Re-imported all the 3rd party devices and still the same crap. When I go to a room within Google Home, and turn on and off lights through a tap, everything works as desired. When spoken or automated, it fails. This started about a week and a half ago. Was just living over it, but this has worked for years correctly, and no changes on my end.


Matthew Winfree