Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Something went wrong. Try again in a few seconds.

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original poster: Stephanie Divito 


Tried rebooting and unplugging all first gen home speakers (mini, home, and hub). Every time I say Hey Google (to any of them), it says something went wrong. Try again in a few seconds. Or there was a glitch. Try again in a few seconds. This has been going on for a couple months now. I'm pretty annoyed. Should I factory reset all (9) of them?
207 REPLIES 207

Community Member

What's going on with this I'm getting sick of waiting for Google to sort this out


Community Member

Every so often, when issuing a command, the three dots on the screen will freeze, a few seconds will pass and the Hub will claim that 'something went wrong'. This is happening everyday for the past few days, and the Minis carry out the command instead, which are working fine. I wish these devices would actually allow me to see exactly what went wrong. Is this caused by an update, or is there any way to fix it?



Community Member

It keeps telling me "something went wrong try again in a few seconds"  Then it will say "there was a glitch try again in a few seconds"  I have all my other devices connected to the same network and they are running without issue.  I have also unplugged, rebooted, and changed networks all with the same Hmmmm.  I have also restarted my gateway and switch and nothing seems to fix this issue.... I need some answers on what else I can do cause its been like this all day except for a brief moment when I asked what time it was.....

Community Member

I am having  Issues with 2 Nest mini's (one 1st gen. one newer nest mini) and Google Home 1st gen when asking: "Hey Google"   Assistant comes back with   "There was a glitch, try again in a few seconds"

-Issue only started over the past 2 months, never an issue before then

-I have boosters set up throughout my home so the devices with the issues are close to those

-Other smart display devices set up do not have the issues

-I have done factory resets on each with no success

Thoughts on how to fix? 



I am also facing a similar issue with my Google Nest Mini (2nd gen). Whenever I try any voice command on it, the 4 white lights on the mini glows up, waits for about 10-15 seconds and then says 'Sorry, there was a glitch. Please try again later.' or 'Something went wrong. Please try after fee seconds.'

Community Member

I have a Google Nest Mini speaker which was working fine for almost half a year. Recently I've noticed that it becomes unresponsive. When I give any command to the speaker (play some music, what's the time?, are you connected to the WiFi, etc.) The 4 indication lights stay lighted for abt 15-20 seconds and I either get the message "Sorry, there was a glitch. Please try after some time." or "Sorry, something went wrong. Please try again after few seconds." The device goes into completely unresponsive state during this time and give only one of these errors. This error is only fixed when I unplug the device and plug it back again. I tried resetting the device by muting the device and pressing down the center touch button for about 10 seconds. This issue still repeats. I also have WiFi extenders across the house and I use these networks for other mobile and laptop devices at my house, all of which works fine. I also tried connecting the speaker and mobile to same networks but none of these things have solved this issue. I also tried unplugging and plugging the device for about 10 times, which didn't work either. Can someone please help me here?



System Firmware version: 250118

Cast Firmware: 1.54.250118

Language: English (India)

Country Code: IN

Community Member

Setup goes well (and this is easily the 10th time I have done this) and also "connects to network" but errors out with the following

"Somehting went wrong" SPeaker may be set up, but we could not communicate with it from your iPhone. Make sure you have enabled local network access in your iphone's privacy settings . then try again.

Tried countless times, done a factory reset also (twice) made sure network enabled - also tried setting up from scratch (with new Google play) on my ipad - SAME error?

Gone through the community posts, not found anything that helps

appreciate anything,,,,,

Community Member

I could accept this with Gen 1 device going end of life and no longer working and needing replacing but this device is only 2 years old. I dont believe it is IP6 every other device my network is woring fine. Google need to own this and resolve it. Not a happy customer

Community Member

Same issue as everyone else and have tried all of the recommendations. First time 'something went wrong try again in a few seconds' then works after. It seems to fail in a very short time after working.

Community Member

I have the same problem on 4 hubs 1 mini and one max. Something went wrong or there was a glitch and when I try again 10 seconds later it works but my phone is always responding even though I have responses while phone is locked disabled now! Help please!

Worth noting that the Google app on the phone is completely independent from the Google Home/Nest devices.  Other than using it to connect and setup.  Interesting and very important point. If your Google phone app can connect, and work correctly, and your hubs and mini fail, it shows the network is not the issue, and it is clearly an issue with the devices.  Google, are you paying attention?  

Community Member

When I tell Google to turn off a light my phone will actually respond and be able to do it in my pocket even though it's disabled from work while the screen is locked. Then the Nest Hub I was trying to talk to you along with a couple others all say error please try again in a few seconds! Meanwhile my phone says please unlock to do that and if I ignore it and tell the nest hub again to turn off the light it works. I feel like I'm taking crazy pills! This is all after a couple years of no problems.

Community Member

it does that to me and always syas try agun can you please help me I’m trying to fit my email is 

Community Member

I have replaced my 6 Google Home speakers with Amazon Echo speakers. Reliable, faster, good sound, cheaper. When I searched "Google Home problems", I got 1.69 BILLION hits. Searching Amazon Echo problems, I got 36 million. That convinced me to make the switch.  

Community Member

Google should post the Answer/Resolution at the very top of this feed. I have read disabling IPv6 will fix it.. and adding DNS to DHCP in router.. I too am very frustrated. My Google Home and Mini worked flawlessly for several years.. and then all of a sudden a couple of months ago, this started. If this doesn't get fixed soon, I may consider getting Amazon Echos.. but I hate Alexa.. I DON'T WANT TO MOVE TO AMAZON TECHNOLOGY.

Community Member

Same here, for at least the past week. I have rebooted, removed the device from Home app & done a factory reset and set up again from scratch, and all the Nest Mini does is say something's not right, or "there's a glitch".

Community Member

Since last week, my Google Nest Mini stop working. Everytime I said "Hey Google", it answer "Something's not right,  try again in a few seconds[...]"

I removed it from my Google Home app, try to add it again, unplugged it, try to add it again... everytime I had the error that it's impossible to connect to Wifi. I tried to reboot my router too... nothing's worked...

My old Google Home Mini worked... but not my Nest Mini...

Community Member

For days now, my alarms and actions are not working. If I call out hey Google, it only answers on my phone. My devices won't work. My internet speed is the same with no change. I've reset all devices several times. It says I'm sorry there's a glitch, or it won't respond. 




Community Member

The only workaround that seems to work, at least for some of us, is to disable IPV6 in your router.  

Emphasize 'some' but not all of us.

Yes, that's why I said "some".  

Community Member

I'm a victim of this insane error as well. Have to command my Google home to do everything twice.


Randomly my GOOGLE TV says something went wrong. What the hell is going on


Community Member

This is still happening. The first try never works. After a while none of them work until a factory reset. It'll fix it for a couple of days and then the same pattern starts again.

Community Member

Hello google! As a customer of your product google home mini I Would like to see google come out with a statement on when they will fix this issue. Getting very annoyed  😡

Community Member

All of a sudden mine works just fine. I have a brand new second generation one sitting there that I got for only $50 but now I'm probably stuck with it because I probably can't take it back. I went away for Thanksgiving and when I got back it hasn't skipped a beat since.  What's up with that?

For about a month now two of my 2nd gens are working fine, two of my 1st gens have the error for every single command. Requested warranty replacement, still no response from google on the replacement of my 1st gens. Class action?

Community Member

Hi everyone, I've got the same issue.


  1. "OK Google play Ben Mazué"
  2. "Ok Ben Mazué on Deezer"
  3. then "Something went wrong give it another try"

After searching, I can say that it only happens with vocal command for Deezer on two of my 4 nest Audio, the ones which are paired. 

If I managed to run a command from another device, I can play music but I've got strange bugs when I want to play on another devices:

Screenrecorder-2021-12-11-15-51-07-479 (2).gif 


Casting from Deezer app works, I can play music from Deezer across all my devices.

It works well with vocal commands with Youtube Music.

So in my case, it seems to be a problem between Google and Deezer.





GET a NEW Router!  Read below.  Trust me, I've tried EVERYTHING!  I even went out and bought a NEW Google Hub thinking it was broken!

Community Member

I bought a HUB last month for black friday , figured I would see how it stacked up against my existing Alexa devices.  So far not impressed, as Everytime I wake it up it takes a several second pause , then says "there is a glitch try again in a few seconds" . It then works fine the second time unless I ignore it for awhile and it goes back to sleep.


It's very annoying to have to ask everything twice.. please fix this bug 

Community Member

I was able to resolve the issue by disabling IPv6 in my router settings. A google search revealed this is a very common issue with Google Devices.

This has kept my own home devices working for weeks now.  Kinda important to underscore that disabling IPV6 is a workaround and not a fix.  Microsoft actually recommends against doing this.  Google needs to get it together and solve the real problem.  

YES!  I DO THINK that I may have solved my "glitch"!  After alot of phone calls and research, it turns out that my specific Router "Sagemcom RAC2V1S, FAST5280" is NOT, I repeat NOT compatible with the Google Hub!  Geez..So, I contacted my internet provider (Spectrum in my case) and was able to get a different, NEWER router which (OMG) far solved the issue!  I am almost afraid to say it BUT so far it has NOT glitched once!  Removing the IPv6 was NOT an option for me as it would remove my 5g optional streaming service (I was told).  I KNOW nothing...NOTHING about this crap.  I found out that the Modem brings in the internet the router sends it to your products (computers, video games, tv, etc.).  Both NEED to be uniform and updated (from what I understand).  I simply went to my provider's main office, and traded both my Router and Modem for the MOST updated one's they had!  BEFORE I disconnected ANYTHING I took photos of the BACK of each thingy so I would know where to plug in all the cords which made this SUPER easy!  Then, I had to "cync" EVERYTHING again...(new passwords for the new internet connections).  Took a little while but within about 1/2 hour I was up and running and I tested my "Google Hub" about 100 times asking 100 questions and every single time, it answered without ANY "there was a glitch, try again in a few seconds"!  

SO BEFORE you go and delete anything check YOUR ROUTER and Modem and GO GET THE most UPDATED equipment available.....!!!!  WO HOOOOO!! It WORKS!

Community Member

I did as you suggested and it worked!!  I swapped out my modem, came home hooked it up and have NOT heard Something went wrong again!!!  Thanks so much!!


Community Member

PLEASE read below!  YOU are correct that Google needs to "man up" and AT LEAST tell us how to FIX this correctly.  Honestly, I figured it all out on my own!  Let me SAVE you 10 phone calls and READ below!


Community Member

I was having the same issue as everyone else with my two minis. Then all of a sudden they both were working perfectly again for about 2 months. Now I have the same “hmm something went wrong” problem again. I have done nothing either time to cause a change — this is so frustrating. Definitely won’t be purchasing any additional google hardware and now I need to decide if I keep what I have (including a Nest Thermostat, alarms and sensors, and Doorbell)  and deal with the lack of google communication or purchase another manufacturer. Google knows about it but refuses to address/acknowledge it which really is the worst part. 

Community Member

What kind of an amateur operation is this where there is no feedback loop between such a high volume customer issue and the product team?

Community Member

tried 'everything' - assistance needed


Well, I too tried everything to fix it.  I suggest replacing your router.  I contacted my internet provider and traded my current router for the newest, most updated one available.  Since replacing it, I haven't had that "there was a glitch, try again in a few seconds.  I even went so far as replacing the "Google Nest Hub".  REPLACE the router!  Some routers are NOT compatible with Google Nest!

Community Member

Yup, reporting in that this is an issue for me as well. First started around a month and a half ago, and annoys the absolute crap out of me. I have two Google Minis (which is considered 1st gen I guess?) and one Google Nest Mini (2nd gen?). Only the 1st gens do this, the 2nd gen is fine. I've had the 1st gens for around 2 years and never had a problem before.

 Once I say Hey Google it lights up, but the lights then stay solid for about 15 seconds until it finally gives one of the canned error phrases. It responds fine if I ask the exact same thing immediately after. It does this every time without exception, and regardless of the command. There seems to be some kind short reset period, where if I immediately say another command, it works fine, but after some time it will once again error the first time. I haven't timed it, but this period is less than 10 minutes. It errors the first time 100% of the time without exception, and regardless of the command

It began at first with them just taking a really long time to respond, and then after a week or so degraded to the current state of things. It kind of seems like they're sending a request that's timing out. I haven't timed it but I suspect it's always the same amount of time before they respond with an error. 

We had the same router for months before they started glitching, but had it replaced about 2 weeks ago for an unrelated reason, and still have the issue. I tried separate 2.4 and 5ghz bands, and a merged one. The router automatically selects the least congested channels, but I tried switching them around anyways. I've unplugged, waited, and replugged the minis countless times. I've factory reset. I turned on the assistant history to have some record of this happening, but it's like i never said anything, theres no record of my command or the error response.

There are 2 accounts on the devices, both with voice match set up. I've removed and re-added them, removed voice match, retrained the voice model.

I loved the devices before, but they've become basically useless because of this. I use them because of the convenience, because I can get information fast or activate something quickly. With the time it takes to say the command, wait for them to error, and re-say the command, I could've just done the darn thing myself. Which I've started doing. So they are now literally pointless to have.

I've avoided contacting support because Tier 1 is always just going to tell you to turn it off and on, and would probably eventually tell me it's a user problem, something with my network. 


Honestly this looks to me like Google beginning to quietly drop support for 1st gen (pre-"nest" branded) devices, which is a pretty bad look. I'd sooner switch to Alexa than have to buy new 2nd gens to replace them.

Community Member

What is the solution to this problem? I thought my mini was dead so I bought a 2nd generation nest hub and the same issue. I'm just about ready to throw them all away.