cancel
Showing results for 
Search instead for 
Did you mean: 

Broken "Return to App" Link when Linking a 3rd Part App (i.e. "Works with Google")

Adaire
Community Member

I wanted to share this fix, as I have been unable to locate one posted for this scenario after a few days of troubleshooting. 

Problem: When attempting to link a "Works with Google" account via the Google Home app, the user authenticates, but is presented with a blank html page with a blue hyperlink: "Return to App." The link does nothing and no device is added to Google Home.

Solution: Install Google Chrome and ensure the html page is loaded via Chrome. If using a different browser, it may be possible to use the (...) menu in the top right to simply load the page using the "Open in Chrome" option.

Additional Notes: I encountered this problem on Android using Microsoft Edge as a browser. Simply redirecting the html page through Chrome resolved my issue linking with apps such as Phillips Hue and Wemo.

Hope this helps.

4 REPLIES 4

Azarco
Community Specialist
Community Specialist

Hey Adaire,

 

Thanks for posting and we appreciate your time in providing the Community of the steps that resolved your issue — it's a big help. Feel free to respond to this thread if you have additional questions or concerns and I'd be glad to answer it for you. 
 

Cheers,

Alex

Princesss
Community Specialist
Community Specialist

Hi there,

 

We just want to check if you have seen our response posted above. Let us know if you have additional questions, otherwise we'll be locking the thread.
 

Best,

Princess

Adaire
Community Member

No questions on my end.

Princesss
Community Specialist
Community Specialist

Hi Adaire,

 

Thanks for your prompt response. We'll go ahead and lock this thread now. Feel free to start a new thread if you need assistance with your Google Nest devices. 

 

Cheers,

Princess