Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google home- Netflix- on Roku TV

Community Member

Hi all, 

Starting my day with coffee and Gilmore Girls. I never had Google Home work when I demand “Hey Google watch Gilmore Girls from Netflix on the Roku Tv. ” However, I was able to find this works by the following; 

Hey Google, Turn on the Roku Tv

Launch Netflix

Play Gilmore Girls

However, now this isn’t working. Google will bring the show up under Netflix but in the search screen but won’t play.  Google says “okay, playing Gilmore Girls from Netflix on the living room TV”, but it’s  not playing it. I’ve tried to say Hey Google, play Gilmore Girls on the Roku. And again, it will bring the show up under search and even though Google says it’s playing it’s only showing me the show. Not sure if this is a google home issue, Roku issues, or Netflix issues. 
I do have my Netflix sync to Google Home. I have reset both TV and Google Home. I did uninstall Netflix app and reinstall, and nothing is working. 
If anyone can help me to have Google Home actually play a show instead of showing me the show’s details that would be great! 


Community Specialist
Community Specialist



Thanks for visiting the Community.


If you're trying to control your Roku TV using your Google Nest speakers, you might find this link helpful:


Also, just to clarify, has this been working before or is it your first time trying it?




Thank you.

The only way it has ever worked for me is to ask Google home to launch the Netflix app on Roku TV. Then ask Google to play “show”. That used to work, but now when I ask to play a show: Google home says, Now playing “show” from Netflix. But the show isn’t playing, it’s only showing me the show on Netflix under Search. 
I normally do this only because I can’t find the remote and don’t have my phone next to me. From what I’ve read, you should be able to ask Google to play “show” on Netflix on the Roku TV. 

Community Specialist
Community Specialist

Hey Crystalakababes,


Thanks for letting us know. Make sure your Roku device is on its latest version. Try relinking your Roku account in the Google Home app. Also, could you try rebooting your Roku, Google Home and router to refresh the connection?


Keep us posted.



Community Specialist
Community Specialist

Hi there,


Buzzing in — I just wanted to follow up if you were able to try the steps provided. Please let us know as we would be happy to answer any questions you may have.



Community Specialist
Community Specialist

Hello there,


We haven’t heard back from you, so I'll be locking this thread in 24 hours. Feel free to create a new one if you have other concerns in the future.