Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google home fail to link philips hue

Community Member

For some time now I've had a problem with Google home: my philips hue lights no longer work.
This prompted me to unlink / link my Philips hue account. Unfortunately, since then I've been unable to connect it, and I keep getting the same error: "could not reach philips hue".
I've since tried everything I could find on the internet (reboot the bridge, my internet, my phone, create a new hue account, "clean up" in the hue app, uninstall google home, from another phone, ...)
Note that everything works from the Philips hue app. But I can no longer control my lights by voice.
Someone have an idea, I do not know what to do!
Thanks a lot!

1 Recommended Answer

Community Member

I was finally able to find a solution that wasn't ideal, but functional.
From my old phone it didn't work, but from my wife's phone it did.
I don't know if it's because the Google account isn't the same, but it works with the same Hue account.

View Recommended Answer in original post


Community Member


I'm sorry to hear about the issues you're experiencing with your Philips Hue lights and Google Home. Here are some troubleshooting steps you can try to resolve the problem:


  1. Ensure both Google Home and Philips Hue Bridge are on the same Wi-Fi network.
  2. Restart both devices and try relinking your Philips Hue account in the Google Home app (Sometimes a simple restart can fix connectivity issues.)
  3. Update Google Home and Philips Hue apps to the latest versions.
  4. Re-Link Philips Hue Account.
  • Unlink the Philips Hue account from the Google Home app.
  • In the Google Home app, navigate to "Settings" > "Assistant" > "Home Control."
  • Click on the "+" icon to add a new device and follow the prompts to link your Philips Hue account again.

5. If the issue persists, reset the Philips Hue Bridge and set it up again. 

6. Verify Permissions.

  • Make sure that the Google Home app has the necessary permissions to control your Philips Hue lights. Check the app settings on your phone.
  • 7. Check Firewall or Router Settings. 
  • Ensure that your firewall or router settings are not blocking the communication between your Google Home device and the Philips Hue Bridge.

I hope these steps will help.

Community Member

Hello, thank you for your help.
Unfortunately I have already tested each of these points.
My concern comes in point 4, I unlinked my Hue account and since it is impossible to re-link, I have this error consistently: "could not reach philips hue".

Community Member

I'm facing the same issue with my daughter's account (which I manage through Family Link).  The Philips Hue was linked in her Home account, but some of the bulbs were missing.  I made the mistake of unlinking Philips Hue and now I get the same message as you when trying to relink.  I have tried on her Pixel 4a, IPad and a factory reset Pixel 5.  After trying countless things to resolve this, I tried to link a couple other 3rd party apps (Roborock, MyHue) and received the same exact message.  So I'm not sure this is a Hue problem and maybe a Google Home issue adding 3rd party apps.  

Community Member

I was finally able to find a solution that wasn't ideal, but functional.
From my old phone it didn't work, but from my wife's phone it did.
I don't know if it's because the Google account isn't the same, but it works with the same Hue account.

tried a lot of this options, just for people that doesn't have bridge, this f***s woks with 2.4 hz wifi, not 5.8. Just changed wifi signal and paired.

Community Member

Started having issues a couple weeks ago with Google saying "hmm something went wrong". Unlinked hue and now I'm in the same boat. Man I'm tired of Google products.

I have this exact issue - did you manage to solve it?

No, I'm sorry to say I gave up, sold all my Google home devices and I just use the hue app now.

Everything works fine with Alexa, so we can be certain this is a Google issue and NOT Hue. It's frustrating that no one from Google is bothering to provide assistance. It's just community members fiddling around, trying to accidentally stumble upon a fix. 

It’s because google are robbing barstewards

Switch to Alexa. Everything works just fine over there. Google is too big for its britches. No customer support. 


Community Member

I have exactly the same problem. It is not possible to connect Google Home with Hue.

After I enter my credentials and give permission to connect, I get an error message "Could not reach Philips HUE, please try again". I have a Pixel 7a with Android 14.

Community Member

I have the same problem with Samsung Galaxy S21. Since the last android update I get the connection mistake. Does anyone have a solution yet? 

When you purchase items from Apple  and you need help, you think they have experts  to tell us how to use, upgrade their product! Greed and they don’t care 1 bit. They control the web. Apple will say, sorry you have to go thru this. Bla bla.  Bull

Community Member

I spent all of yesterday on this and today found the solution on Reddit. Unplug the hue hub home for 10 sec, plug it back in, wait till the 3 blue lights are on and then on the Google home app add it under other devices. Worked first time. Cannot believe I didn’t think to unplug it and plug it back in sooner 🤦🏽‍♀️

Thanks - after power cycling,  I was able to add via Smart home > Google Assistant in Hue (which then took me to Google Home & completed the repair). 

Community Member

I had the exact issue and error messages. I tried the same troubleshooting measures. I finally managed to get it connected by doing this:

- Open Philips Hue app

- go to Settings, scroll down to "Smart Integrations", tap "smart home" and select "other app" (you may need to tap + in the top right corner first)

- tap "get pairing code"' then tap "next" and you'll be presented with a 11 digit code... Copy this code!


- Open the Google Home app

- tap the "+ add" button

- select "new device", make sure your home is selected and then tap "next"

-select "Matter-enabled device", then "setup without QR code" and then paste the code that you copied from the Hue app.


I hope this will help others.

Finally, this worked! Thank you!

This worked. Completely non-intuitive, but it worked. 

Thanks for sharing! 

Worked for me, thank you so much.

This worked for me. From the Hue app selected other, then used the code provided in the Google Home app using the matter option

This needs pinning or something!

Despite me trying literally everything else, including a factory reset of the Hue Bridge (losing all my scenes and setups for far too many devices), this was the only solution that worked.

When I go to the app it just buffers. It won't let me go to settings. 

The only problem for me is that I don.t have the ‘smart home’ option. I only have the ‘voice assistant option’ there.

Yes ,  somebody who knows how should Pin this on top of the subject /inquiry , this works , and quickly 

Thanks, the code trick worked. Wouldn’t found if not for your post.

It only reconnects, it doesn't solve the problem for me😔

I can turn on/off individual lights but not entire rooms at a time.

It's so frustrating, I'm not buying google again. 

I don't know if I got lucky, but it's all kinda working now. 

Omg this is the only thing that worked! Thank you for this fix 😄

You sir are a genius! Top answer!

Community Member

It worked, but instead of an 11-digit code with my version of Android, I had to select "Get Started." The next page asked what do you want to link to your Hue system? I clicked the icon Google Assistant, and the Philips page popped up and asked me to grant permission.  I granted it and it worked, the link was made.

Community Member

Update: I spoke too soon; yes, my Nest Hub is linked to my Hue bridge, but I cannot access any of its functions on the Hub. I have an older standard Hub in the house, and it had no problem; in fact, it is linked to two hubs, one 100 miles away in my apartment. So no joy, any ideas?

Community Member

Not working, fails at generating matter credentials 

Community Member

I have the same issue, did the update of the apps, uninstall/reinstall and still no luck. Its definitely something with either google or android, They better fix it. I didnt spend all this money on light bulbs and google home devices just so they dont work!

Community Member

Same issue. Disconnected Hue from Google app per the recommendations and now it won't reconnect. I tried the matter enabled device idea and it just says it cannot find device. It was working for years! Google customer service is non existent. 

Community Member

Not quite sure how I've managed to achieve it but have reconnected it now via the 'matter' set up my home app eventually just found it and connected. Thank the lord. 

Community Member

This is very frustrating and disappointing. Following Google's recommendations actually seems to have made things worse. Very odd that after years of having Google and Hue working seamlessly, all of a sudden, without warning, and without any alterations on my part, they are completely foreign to one another. 

By the way, Alexa works just fine. This is 100% a Google issue and it would be GREAT if I could get some customer support. 

Community Member

I've been checking every day to see if Google created a fix, and after a few weeks, voila! Everything connected.