Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google home not connecting to Wyze Outlets

Community Member

My Google home used to connect to my four Wyze outlets. Approximately 2 weeks ago, Google home replied to me that it couldn't connect to Wyze home. 

I've tried the following to fix the connection:

1. Reset one of my Wyze home outlets. 

2. Reset my Google home mini.

3. Began to use the wyze home app

4. Reset my Google home app. 

I don't know what else to do... 

Please help me! 



Community Specialist
Community Specialist

Hi Laurenn1,


I know how it feels when something isn’t working the way it should. Let’s further look into it.


  • Open the Google Home app > Settings > Works with Google.
  • Unlink your Wyze account.
  • Force close and reopen the Google Home app.
  • Go to Works with Google and relink your Wyze account.
  • Command your Google Home Mini to “Sync my devices”.


Let me know how it goes.


Community Member

Thank you for your suggestion but it did not work and I've resorted to-connecting my wyze home devices again to my app. They all work on my phone I can turn them on and off through the phone but they no longer work with Google home. I have tried totally uninstalling both apps and that does not work nor does reloading the whole software. I've reformatted the Google The Nest several times and every time I try and connect the wise home it says it doesn't connect. It worked fine for over a year I cannot tell what the problem is now and why it is not working anymore. Did you just have an update that may have made it so it doesn't work any longer with my wyze home?

Very frustrating! 

Community Specialist
Community Specialist

Hi there,


We appreciate all your efforts. What is the exact message you are getting when linking Wyze to Google Home? Do you have home members in the Google Home app? Try to create a new Home and link your Wyze account.

Kind regards,

I had the exact same problem, and it started at about the same time.  I have just now fixed it.


First, I unplugged and then re-plugged in my Wyze outlets, but they were still showing as "offline" in the Google Home app, and my Google Nest Hub (I THINK that's the new name for it) kept saying it could not reach Wyze Home.  (It would actually give me 2 similar, but slightly different error messages every time I asked it to turn the lights on, but I can't remember the exact wording now.)


I then reinstalled the Wyze app on my phone, and had to sign into my Wyze account again, and it appears to have been updated/revamped, so I think I had to agree to new terms.


I was then able to control the lights from within the Wyze app, but nothing changed in the Google Home app, or on my Nest Hub.


The last thing I did, which actually fixed the problem for me, was close to what Alex_S suggested, but a bit simpler:

I went into the Google Home app, then to the Settings tab, scrolled down to Services and tapped on Works with Google.  Once in the Works with Google menu, there was a Linked section which contained only Wyze Home for me.  I tapped Wyze Home, but then, instead of tapping Unlink account, I tapped Check for new devices.


That fixed it for me.  I don't know if you'll still have that option, since it sounds like you may have already gone through the process of totally unlinking Wyze Home.  If so, maybe someone else with the same problem will see this and have similar luck as me.

Community Specialist
Community Specialist

Hi AnthonyGL,


Thanks for taking the time to share this resolution here in the Community! Let’s wait for an update from Laurenn1 and see if these steps will also work for her.