Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Lenovo smart clock

Community Member

I have a Smart Clock CD-4N341Y that was purchased in the US and  when I am trying to setup the device in Europe it gives me a WiFi connection error "Lenovo CD-4N341Y was manufactured for a different country. and may not be compatible with your WiFi network" but I cand proceeed and in the end it can't connect due to the the error "check your wi-fi settings".

I'm not convinced the issue comes from Google home app due to the fact I'm already using it in my region ( Romania) with other smart home devices (google nest mini, vacum cleaner xiaomi, smart bulb tplink) with no issue, so is suported in my region from official store.

I have the latest version and I've tried setting it up on 2 phones huawei and samsung plus one tablet.

I already tried to reset the first the Smart Clock Essential to its factory settings by pressing and holding its Alarm and Volume Down button at the same time for 12 seconds,  reinstalled the Google Home app on my smartphone and reseted the router.

I tried 2 routers on 2.4 and 5 GHz --> the error message says that I might not be able to connect to wifi due to the fact it was made for US market but let's me proceed, in the it says it can't connect to the wi-fi and to check the wifi settings .  Is there any solution to make it work?

Model: CD-4N341Y , P/N ZA740005US

Thank you


Community Specialist
Community Specialist

Hello ivanka, 

Thanks for posting — let's get this sorted out.

Go ahead and try to set up your Lenovo Smart Clock using a mobile hotspot with the same Wi-Fi name and password as your network. Please note that you will need two mobile devices for this setup (one will turn on the mobile hotspot and the other will be used to set up your device). Factory reset the device first before going through the configuration process and once connected, turn off the mobile hotspot. Check if your smart clock will automatically connect to your Wi-Fi network.

Let me know how it goes.


Community Member


Thank you for your response. I did what you said, the clock connects on the mobile hotspot but after doesn't automatically connect to my Wi-Fi network. Are there any wi-fi settings specific for this clock?

I tried setting it on 2.4 GHz and 5 GHz, WPA-2 PSK, protocol Ipv 6 but no luck so far. 

Community Specialist
Community Specialist

Hey ivanka, 


Please check with your Internet Service Provider and configure the following recommended router settings:

  • Enable: Universal Plug and Play (UPnP), multicast, Internet Group Management Protocol (IGMP)
  • Disable: AP / client isolation, virtual private networks (VPNs), proxy servers, IGMP Proxy. VPNs and proxy servers should be disabled (if applicable).


Keep me posted.




Community Member
Hello LovelyM, 
    Thank you for your quick answer.
    I've done the following settings on my router and unfortunately the situation is the same:
- Universal Plug and Play (UPnP) - was already on
- multicast - I enabled Wireless multicast forwarding from IPTV menu, I couldn't find anywhere else this option
- Internet Group Management Protocol (IGMP) - I enabled IGMP Snooping from IPTV menu, I couldn't find anywhere else this option (I tried both IGMP version 2 and 3 with restart between them)
- AP - was is off, I'm using it as a router
- client isolation - I could not find it
- virtual private networks (VPNs) - no VPNs are used
- proxy servers - no proxy servers menu found
- IGMP Proxy - disabled it from IPTV menu, I couldn't find it somewhere else
- VPNs and proxy servers should be disabled (if applicable) - no VPN or proxy used
I'm using as a router TP-Link AX50 model, and you can find below a link with an emulator that shows exactly all the options available:
I should mention that Google nest mini works just fine on this router with any settings made so far.
I tried to connect with Smart connect off and on and there is no difference --> all the time after I change a setting I'm restarting the router and Lenovo smart clock essential to be sure.
Do you know what else I could try?
Thank you,

Community Specialist
Community Specialist

Hi ivanka,


We appreciate your efforts, and we're sorry for the inconvenience. Since it's happening with your Lenovo device, it's best to contact them for additional support. Please note that we have very limited support for third party speakers with built-in Google Assistant, like Lenovo.


If you have Google Nest devices and would like assistance with them, let us know; otherwise, I'll be locking this thread after 24 hours. 




Community Member

Hi Juni,

I finally resolved the issue, it turned out to be a parental control setting of the internet provider.

Thanks anyway.

Community Specialist
Community Specialist

Hello ivanka, 

Thanks for keeping us in the loop! I'm glad that everything worked out for you. We're going to lock the thread within 24 hours. If you have further concerns, please feel free to create a new post.

Best regards,