Showing results for 
Search instead for 
Did you mean: 

Philips Hue - Shows Offline, Cannot Remove from Google Home App

Community Member

I followed the instructions in a different thread to remove all Google-related apps from my Hue account. I also followed the "Clean Up" instructions in the Hue app on my iOS device. Despite this, a separate "Philips hue" device remains (looks like the bridge itself) as well as all of my Hue devices. All show offline. When I click on them in the app and select "Unlink", Philips Hue does not appear in my list of linked devices, so I can't remove them.

After the clean-up, I tried to re-add Hue (even though all of the devices still appeared in the Home app). It goes through the motions, but when I try to re-add all the individual devices, the app does nothing. I suspect this is because they're already there in the Home app, but "offline" (and as I said, will not go away). All devices work as they should in the Hue app.


Similarly, I have a number of TP-link Kasa devices that show offline, but also work fine in the Kasa app. I went through the trouble of unlinking Kasa, but the offline devices remained while all of the rest were removed from the Home app. It's frustrating having both Hue and Kasa devices that for one reason or another Home cannot reach, making me scroll through "dead" devices. A clue with the Kasa devices is that it appears as if the unreachable devices are several years old (they're smart switches and plugs, and, again, still work fine in the Kasa app). By replacing them with new switches and plugs (not an inexpensive endeavor), I can regain control of the devices they're connected to in the Home app. But the old, offline devices remain.


Community Specialist
Community Specialist

Hi turbojimmy

Thanks for reaching out and for providing detailed information on your issue and the steps that you've done — these are of great help!


You can remove your linked devices directly from your Google Account then relink them again using your Google Home app. Check the steps below.


Step 1: Check the Linked accounts page


  1. Go to the Linked accounts page of your Google Account. You might need to sign in.
  2. Select the third-party account you want to unlink from your Google Account and then Unlink.
    • Before you unlink your account, you’ll have the chance to read the third-party’s privacy policy to learn about the kind of info it shares with Google.

If the third-party account you want to unlink isn’t on this page, continue to step 2.

Step 2: Check Google apps

  1. Go to the Google app where you linked the third-party account with your Google Account. For example, the Google Home app, the Google Assistant app, or the YouTube app.
  2. Select Connected accounts, Linked accounts, or Apps. This may be in the Google app’s Settings section.
  3. Find the third-party account that you want to unlink from your Google Account.
  4. Next to the third-party account you want to unlink, select Remove or Unlink.

Check this link for more information.


Hope this helps.




Community Member

It's frustrating that your advice is to go somewhere other than the Google Home app to remedy the situation, even though the Google Home app is where I linked Philips Hue. But I tried what you said. Philips Hue was there as a linked account on the "Linked Accounts" page. I unlinked it from there. It did not work. Philips Hue was indeed removed from the list on the "Linked Accounts" page, so I guess that's good, but the unreachable Philips Hue devices, and the Philips Hue bridge still appear in the Google Home app. And, again, when I try to unlink directly from the app as you describe in Step 2 above, Philips Hue does not appear in my list of linked accounts.

So I'm still stuck with these zombie devices. There are a bunch from Kasa as well, despite my having deleted and re-added my Kasa account.

All of this now makes me wonder whether unlinking an account really unlinks it or whether that third party still has access to my data. I've removed permissions but the devices persist in the app.

Community Member

Hi Juni, do you have another suggestion when all you describe do not fix the problem?

Community Member

I have the same Issue, I went to the link you provided, and Philips Hue wasn't there anymore, but still appear on Google Home App as "Offline Device". So, Philips Hue is already unlinked but the devices are still showing there, it could be an issue with Matter? because I already add the Hue Bridge via Matter, Matter integration works fine but I don't like to see these other devices as "offline".

Community Member

Hi, I am experiencing the exact same problem. Did you manage to fix it somehow?

No I did not. The devices are still in the Google Home App but unreachable.

I found some kind of a workaround. I have managed to connect all my hue devices again, and then I have created a additional home in the Google Home app and moved all the zombie devices to that home, but I had three zombie devices I could not move to the new home, and thus created a seperate room for them in my current home. It is not the perfect fix, but I have search a lot on this topic and it do not seem that either Google Home or Philips can contribute with any other suggestion rather than the normal troubleshooting, which is not helping at all to the issue. 

Community Member


I have since a week or 3 the same issue.
Tried to unlink Philips Hue account but it wasn't even connected to the Google Home app.
I can't clean up the devices also.

Those bulbs cost a little fortune so getting them working again so that would be awesome.
Making a new home as Bjergxp suggested is not really an option as we have too much connected devices. 
(and I'm also too lazy to reconfigure everything :D)

Please help me out.

Community Member

Same issue here, Google Home and Pixel 6.

If you go to link the account, I get that no compatible devices are on it for home, yet the ghost offine devices are there, just offline.

Hue app can control them, and Google assistant can also control them by voice.

Unlinked it on website for my account, but had no effect on home app.

Dev's appear stuck since we haven't heard anything more on this.

Community Member

Having the same issue - devices can be control from the Hue App but not Google home,not even by voice.

Community Member

Yep exactly same problem here and going around in circles trying to unlink fully. I don't even get am unlink option for hue in home app, could only do it via hue account but its not reflected in the Google home app. Very frustrating.

Community Member

So the way I fix this was by unlinking the Hue Bridge from the Google home App and then linking it again.

Community Member

I am having the same issue.

Community Member

Anyone have a fix other than to nuke the whole home account??

This happened for me after swapping routers.

Community Member

Had the exact problem and this worked for me. I created a temp home and moved all my hue devices (including the bridge) over to it. I then went back to my actual home and tried to connect my Phillips hue account and it surprisingly worked. I was able to add all the devices to my actual home without issue. I then went back and deleted the temp home (which of course still showed those offline devices in it). Hope this helps everyone 

Community Member

I'm having the same issue, somewhat magnified by now controlling someone else's lights.

We moved house last month and had Philips Hue set up on Google Home (but it was showing all devices as offline). Despite Hue not being linked to Google (on either the Hue side or Google's side), voice control did manage to control the lights. Before I left that house, I disconnected Hue from Google, unlinked my account from the Hue bridge, deleted the old 'Home' in Google Home. Moved house and started a new home. To my surprise all of my old lights were listed as other devices. Needless to say we'd left all Hue devices at the last property, because that was included in the sale.

I set up a new home called 'Old stuff' and moved those bits into there, into a single room, because it was required. And my new home is called 'Home'.

Our of curiosity, I asked a Google Home speaker in my new house to 'turn all the lights off', and it actually attempts to turn the old lights off. I don't have Hue set up yet, but have all of my bulbs and accessories ready. Waiting for this to be resolved. It's clear that my voice commands are still controlling that old Hue hub, which definitely shouldn't be the case. There needs to be a solution for this.

I actually tried deleting my Philips Hue account, but that didn't help matters, and my Google account is far too precious (photos/videos/movies/tv/apps/games/cloud console) to attempt anything weird and wonderful.

Hue isn't linked to Google Home, so I can't unlink it. There must have been something weird happened on Google's side that's caused this to happen. Why can't we just forcefully delete the Hue bridge and lights instead of using an 'unlink' method that doesn't actually work?

Here's a link to the album with some screenshots of the issue -

It makes zero sense. If Google doesn't have a connection to Hue, and Hue doesn't have a connection to Google, why on earth is there still a connection?!

Community Member

I went through all the steps everyone described. The Phillips hue devices were still showing. I removed everyone from the household, except myself, and the zombie devices went away.

 Hopefully this helps.

Community Member

TLDR: Try removing the lights using the device of another member of the home.

The post from mannyone led me to the fix for me, I tried the following without success:

Unlink Hue from Google Home
Remove link from my Google Account
Log into Hue account and remove any Google interactions
Cleared up Hue Hub

Still I had offline lights that I could not remove from Google Home. Reading mannyone's comment, I thought I would try from Goggle Home on a device logged in by the other person in my home and I could delete the offline devices. After that I could link Hue and all lights are now working from the app and voice control from Nest Hub.

Community Member

@GaryBritton, yes, this was the issue for me. Somehow despite closing the old home down and removing the members first, my young son had also linked Hue. Removing that link resolved the issue entirely and allowed the new owners of the house to not have us controlling their lights 😂

Community Member

Such a silly issue but glad we could find an answer.