cancel
Showing results for 
Search instead for 
Did you mean: 

google keeps asking me for the device name

nanomatic
Community Member

Hey Guys,

I have a new LG TV linked to my google assistant.

Commands like turn on, or turn off the TV work,

Anything slightly more complicated such as "play X on youtube" and i get the following error:

"I also need to know which device to use. try saying that again, and include the device's name"

 

i know this feature works at my friends house, and also works flawlessly with the google asssitant built into the actual tv

HELP 😞 

10 REPLIES 10

besttmomm
Community Member

I have the same issue!  When I include the device’s name, google just gives me the same reply.  

Azarco
Community Specialist
Community Specialist

Hey folks,

 

Thanks for reaching out — let's check this out.

 

A few questions: what Google Home or Google Nest speaker are you using? Also, are you casting from your speaker to your TV?

 

  • Make sure your devices are connected to the same network and connected to the same network.
  • Try to use these commands" "Open YouTube on the TV" "Play [title of the movie/show on TV]"
  • Try rebooting your TV, speaker and router to refresh the connection.

Keep us posted!

 

Best,

Alex

nanomatic
Community Member

Have tried these things 100 times. Nothing works 

Azarco
Community Specialist
Community Specialist

Hey nanomatic,

 

Thanks for the update. What devices are connected to your Google Home speaker. Also, are they set up on the same home structure on your Google Home app?

 

Regards,

Alex

nanomatic
Community Member

Yes. Able to setup same structure. 

I hAve lights, heaters, blinds. Fridge, washer 

 

only the tv has issues.

 

as stated above “open YouTube on the tv” works... and turn on the tv works...

 

but anything more complex like “play Big Bang on YouTube” and it gives me the error. 

the TV is brand new, and the latest model... all firmware is updated. I’ve synced my devices. 

Azarco
Community Specialist
Community Specialist

Hey nanomatic,

 

Thanks for the additional information. Could you try removing your TV from your Google Home app?

 

Best,

Alex

nanomatic
Community Member

Yes, I’ve removed and re-added more than 20 times. I’ve done all fundamental troubleshooting 

Azarco
Community Specialist
Community Specialist

Hey nanomatic,

 

I appreciate you doing all those steps. Since it's only happening with your TV, I suggest contacting your TV manufacturer so that they can check if there are settings on your TV that needs adjustments.

 

Thanks,

Alex

Azarco
Community Specialist
Community Specialist

Hey nanomatic,

 

Hope your TV manufacturer was able to help you with your TV concerns, Feel free to respond to this thread if you have additional questions or concerns and I'd be glad to answer it for you.


Best,

Alex

Azarco
Community Specialist
Community Specialist

Hey nanomatic,

 

Just one quick final check in here since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need assistance, feel free to start a new thread in the community and we’ll be happy to help.


Kind regards,

Alex