cancel
Showing results for 
Search instead for 
Did you mean: 

Home/Away Assist, returning home always stuck in eco mode

Dawdie
Community Member

So I have 2 nest thermostats which are controlled with Home/Away. Whenever I go out the thermostat goes into eco as expected. Whenever I return home the app shows "Home" and so does the log so it defintatly knows I have returned, but the thermostat however is still stuck in "Eco" mode till I manually turn it off.

 

I have all the "learning" stuff off (Auto Schedule/True Radiant) so I have no idea what I need to do to fix this aside from just turning home/away off and putting the old thermostats back in.

 

Potential fix (using google home not the nest app) https://www.googlenestcommunity.com/t5/Nest-Thermostats/Home-Away-Assist-returning-home-always-stuck...

1 ACCEPTED SOLUTION

MelbaDT
Community Specialist
Community Specialist

Hey folks,

We understand your frustration about your Nest thermostat not working as it should, and we appreciate your reports here in the Community.

 

If you're experiencing this issue, please give all the steps listed here a shot: https://bit.ly/38qgivs. These steps have worked for others experiencing similar behavior and should help get you back on track.


If the issue persists after trying the steps on the link above, we want to be able to dig into this further. In order for us to differentiate between different countries' thermostats, go ahead and reply to the following threads with the following info:

  • The type of Nest thermostat you have
  • What mobile device you have and the OS version
  • The software version of your thermostat


EU users: https://bit.ly/3LZlrg2
US/CA users: https://bit.ly/3Jxm52R

We thank you for your patience and we look forward to taking a closer look.

Thanks,
Melba 

View solution in original post

750 REPLIES 750

Iany1954
Community Member

I agree completely. But I’m not prepared to waste money heating an empty house or live in cold until I remember! As soon as the app is fixed I’m going back to using it alone.

xtof2021
Community Member

As I posted a few days ago, I found a solution:

I disabled the learning feature.

I reset the Home/Away thing in the thermostat (not the Nest app).

Now it works perfectly. It enters Eco mode when I am Away and gets out Eco mode and start heating (if needed) when I am Home. Working very well like this for a week.

Thanks for letting us know.

Per52
Community Member

Hurray, ther's hope for all of us.

From the advise of Evernon, I sent an email to Sundar Pichai.

I advised him to take a look on this community issue.

A colleague of his answered me this evening :

I have seen this specific post from our Community in some other correspondences. Our highest tiers of support are involved regarding this, as it seems to be a trending problem. While I don't have a specific ETA for when a direct fix will be provided, I think it will be done so via the next Google Nest Thermostat software update. Thank you for your patience and understanding in this matter.
 

 

heshie75v
Community Member

I received the same email from someone else at Google Nest. The reason I do not believe what they are saying, its worded almost exactly the same.

 

Thank you for the update. That's certainly not intended behavior, however the troubleshooting step you perform by opening your app in order to activate normal operation is a good temporary resolution. I've been made aware that our highest tiers of support such as our Engineers are aware of this problem, and currently working on a definitive fix. While I don't have a specific ETA, I want you to be assured of our commitment to resolving this. Thank you for choosing Google Nest

 

Lets up I am wrong

Herman

Let's all hope so but I'm afraid I will only believe it when it happens. 

Until it happens I would advise others in the market for a new smart thermostat to go elsewhere.

Per52
Community Member

Ok, maybe I'm a bit naïve 😁

We'll see.

But it's clear that it's not usefull to spend any more time on this issue.

They admit there's something wrong with the software.

NU654
Community Member

I have the exact same problem. Very frustrating.

Posting here to keep track of the comments and see if this gets solved. 

Rohan10
Community Member

Same issue. Glad I’m bot the only one. 

where is google support?

Iany1954
Community Member

Well, it’s now Thursday and I’ve been using the SmartThings app to provide correct eco/heat control since Monday). It’s been working great. No problems with going into or out of ECO according to its geofence. Nest app still correctly gives Home/Away status but Eco/Heat stays is controlled by SmartThings. It’s set up correctly using two phones for individual location response.

SmartThings now reports temperatures in Centigrade although it is obviously doing some conversions as the Nest schedule set point is not quite reported correctly (12 C is reported as 11.9 C in SmartThings). Must say I’m impressed with Smarthings and may continue to use it.

Hopefully success continues!

Iany1954
Community Member

Well, yet another failure. SmartThings app now needs to be opened to allow it to run location based routines!!! Originally (about a week ago this was not the case). The app permission is set to ALWAYS but to force a location based routine to operate I have to open the app. Curiously this is a requirement when leaving the location but not when returning!!!!! I’m not sure where to go now. Google has messed up Nest and Google Home, Samsung has broken SmartThings and Nest cannot work with Apple products. Perhaps 2022 will bring about a change and these companies start listening and provide useful customer support.

Well……

looks like SmartThings and iOS managed to corrupt the SmartThings  location permission. Despite being set at ‘always’ it functioned as ‘when using’. I changed the location setting from ‘always’ to ‘never’ and then returned it to ‘always’ and it now seems to work again! I’ll not hold my breath for this continuing!

Jonlea
Community Member

I also have this problem. Bought this product 4 weeks ago set it up properly and keep coming home to cold house. Wife not happy

Take it back and demand a refund. The functions you paid for do not work. Refer your retailer to this thread. You can buy a thermostat that you can manually control with your phone for a fraction if the price of a NLT. I've a feeling Google aren't going to fix this. It can't be that hard. They may have deliberately broke it. Maybe they've a new NLT in the pipeline they want us to buy. 

Amywithwings
Community Member

We were out of town and returned home at 7pm. The heat didn’t kick on, nor did it kick on when we manually adjusted our two nest thermostats to heat. When we got home, the outside temperature was 16° and our inside temp was 40°. I’ve watched the degrees tick down further and further as we’ve spent hours messing with the nests. Restarting them. Reinstalling the app. Messing with all the setting on our apps and on the actual nest thermostats. Our next step was to either go to the store at 11pm to get space heaters or to call the local sheriff to ask for help since everything is closed. My husband finally found info online to completely disconnect and reinstall the entire nest system, which he did, and now they are both working. But this has been scary! We’ve got kids complaining and confused as to why our house is an ice box. This is an issue google needs to address asap. This is unsafe. 

That is absolutely awful, but it sounds like you had a different issue; the Nests were not working at all, even when you manually adjusted them. The home/away failure was probably a result of everything else on the Nest not working. Both Eco and Safety temperatures would normally default to more than 40° (what do these say in your settings?) If this was just a home/away failure your home should have stayed above the Eco temperature. 

At least it was a software issue. I had a hardware failure last winter. My NLT just stopped working late on a cold weekend. I tried everything, but eventually had to get the HVAC guys out. They diagnosed a hardware issue with the Nest. The base plate, which looks like a dumb connector for the wires, had failed. If you search online this is a common failure. I have no idea what it contains that could fail. Nobody stocks that part, so you either have to buy a whole new NLT in the store, or wait for a base plate to be delivered. I now keep a spare on hand ($50 part) to avoid being caught in the same position. 

Iany1954
Community Member

After some more investigation it seems that for some users of Apple devices iOS 15 has broken location activity (not all phones or apps are affected). Users of some other home automation devices have also found that their app needs to be opened to force location to be loaded! This obviously does not affect the Nest problem as it correctly sets home/away status but fails to change the heating to/from eco. My use of SmartThings workaround would work if it didn’t suffer from the Apple induced problem!

 

Looks like we must wait for Google to fix Nest and Apple to fix iOS (both are apparently working on this). 

DavidE
Community Member

@Iany1954 wrote:

Looks like we must wait for Google to fix Nest and Apple to fix iOS (both are apparently working on this). 


Have you seen some information that Google are working on the Nest issue?

Iany1954
Community Member

Some members of this community (Per52, heshie57v) have shared that Google are working on a fix.

heshie75v
Community Member

Everyone here seems to have one issue or another related to the home/away function on the Nest thermostats. Some people have claimed its IOS 15 ( definetly not ). This has been going on for better part of a year, if not longer.

The question is not what the problem with this product is rather, when will this be fixed or can it even be fixed at all ? I've heard lots of promises, but again the question is WHEN?

Nontechmike
Community Member

I don't think its just Apple IOS 15.  I run on Android and a few days ago I also started getting problems with SmartThings not recognising home/away status even though permissions set to always - it had previously been working fine for over a week.  Opening the SmartThings App, it immediately reported my location status correctly.  Seems a bit of a coincidence that SmartThings has also now started needing to be open/running in background for Location services to work??

Iany1954
Community Member

There is definitely an iOS problem as it’s been reported and accepted by Apple. With Nontechmike’s experience it seems like there is Google, Apple and Samsung problem!!!

bjleend
Community Member

I am very sorry to hear various NLT failures in the middle of winter. However, some of the recent posts are not directly related to the issue that we have in this thread. Some iOS, Android issues, Hardware issues are NOT for this thread. They could be better dealt in the separate thread. This thread is dealing with "NLT fails to change ECO/Set-Temperature even it correctly responded to Home/Away using phone location" with some minor variations of similar issues. It is helpful that we should have a narrow focus in this thread so that Nest/Google can pin-point and potentially solve the problem. 

Iany1954
Community Member

Whilst I agree with the comment about hardware as an engineer I’m of the opinion that when fault finding all information is useful. Whilst this particular problem may not be related to iOS or Android we cannot know this and the feedback provided can help others by identifying workarounds that can be successfully used whilst waiting for Google to respond. Let’s all hope that they act soon (this is now a 2 month old problem) and then this thread can be closed.

heshie75v
Community Member

It’s been months since the problem has become so obvious to most users. I as well as other people on the forum have gotten responses from google that they are aware of this problem and are working on it.

my question is how long is this going to take, why is nothing happening?

I know that my issue has been a year at the minimum, doesn’t google think enough time has passed?

 

LizHC
Community Member

We’ll hate to say this, but I reported this issue around four years ago… Had the runaround with nest before Google stepped in.  Just had another look today to see if I could get it working, but seems that everyone has the same issue whether apple or android.  

fkyougoogle
Community Member

I've been dealing with these jokers since early December trying to get the issue resolved. All the support people ever do is ask for the same endless amount of information they asked for last time, tell you to factory reset the thermostat and reboot your phone. They won't accept that it's an update that's caused this issue.

The Consumer Rights Act 2015 in the UK does say that if a company breaks a device with a software update that you may be able to claim compensation. I've raised this to support and they've passed it onto their legal team. I won't be holding my breath.

They don't have any intention of fixing this issue, so I'm going to dump this piece of junk in the trash where it belongs and buy something that actually works

heshie75v
Community Member

When will this be fixed if ever ?????

Don't they read these complaints, and problems?

Btoller
Community Member

Been following the posts. I have similar problem with home away and nest thermostat. Have tried everything but a waist of time. Home away used to work perfectly in the past. Very frustrated that there is no useful information from google. I suspect there are many like me who have not posted but who will have long memories…………….

LifeonMars
Bronze
Bronze

Have received the following message from Google support.  “ We've checked your case and it looks like the case is still under review. We understand the situation and, again, we are sorry for the inconvenience it may have caused. Rest assured that our colleagues will come up with the result as soon as possible and we'll keep an eye on the case until we get the result.“

 

not very good for Nest Thermostat marketing.

heshie75v
Community Member

This is absolutely not reassuring, google as been “ looking “ at this issue for a while now. People on this thread have had this problem for a while now.

i have had this problem for over a year now and nothing has been done. I have very little confidence that this issue will be solved in the near future or at any time at all.

Legfitter
Community Member

I had this issue but it seemed to rectify itself immediately as soon as I turned off 'use this phone' for proximity sensing in the Nest App. Then, when I tried to turn it back on I got a message warning me that using both Google Home and Nest for sensing can cause conflicts. So, as it's all set up in Google Home, I've just left it off in the Nest App. Seems to be working fine now.

Midjet76
Bronze
Bronze

I notice that people have been saying it's broken since the app was updated.  I'm on android and have downloaded previous iterations of the app both recent and from over a year ago, namely 5.66.0.7 and 5.56.0.2 hoping for a fix but no.  I also tried Samsung Smartthings which worked once but then when I added it to my wifes phone it went out of sync.  I only had Smartthing no nest on wifes, none samsung phone.

As others are saying it does feel like the geofencing is failing somehow in Nest but I am wondering if I've installed older app and the actual NLT hasn't had an update since 2019, I don't understand what else there is to break what was previously working fine.  What other variables are there?

I've reset to factory the NLT and wiped Nest and Home apps from both phones.

I've also experienced various failures in the home/away assist. ie Away but heating on, Away but showing as at Home on the app but also in Eco mode and the Home but stuck in Eco mode.

This may sound daft but it feels a bit like when light switches upstairs and downstairs get out of sync so that they're not all in the same position when lights are on or off. 

Sorry,I know not much help but needed to share my experience.  Like many others still waiting on further feedback from Google after going thru the usual crap a few days ago with telephone conversation.....

Also has anyone had any joy with getting compo from them?  I haven't even got a receipt for mine as it came with a new install....

Furthermore, I've just checked my activity log for today having had a busy to and fro kinda day and the Activity log accurately records my comings and goings but as others point out this isn't reflected by the NLT's response.

I'm pretty sure that there was an update in November for the NLT itself that started the issues. I've seen it install the update completely on its own. The screen switched on and showed it installing software version 5.9.5-2

I've completely give up relying on the home/away function and troubleshooting it. Because it doesn't always switch to eco mode either. And that's worse for my wallet when I'm not home than being stuck in eco mode.

This problem is going on forever.

 

My NLT is on 5.9.4-5 installed September 2019. I have this home/away/eco problem which I only noticed from November 2021. This was when the iOS app was updated to 5.67.0

I suppose it’s irrelevant which part of the Google empire is at fault (or when) they just need to fix it. This was the most useful part of the system which has now been broken for over 2 months! Some action PLEASE……..

DavidE
Community Member

@Midjet76 wrote:

 

... the actual NLT hasn't had an update since 2019


Mine shows as having last been updated on 16th Nov 2021 (Settings -> About -> Technical Info).

 

For Me in the UK

the last update to my 3rd Generation NLT  which I think caused the problem was in November Version  5.9 5-2

The Nest App on my iPhone X running iOS 15.2.1.  is version 5.67.0.6

Just to clarify, there are several iterations of Nest thermostat and the software updates are potentially different for each. Mine is a Nest Learning Thermostat second generation. My NLT software has not been updated since 25 September 2019. Other/later generations have been updated later. As my NLT was fine until November 2021 when the iOS app was updated I’m confident that the fault is not in the thermostat but is in the app or it’s interface with the Google system. My experience is that Home/away functions correctly (so it’s not a location problem) but the eco mode does not work correctly in tandem with Home/away (it’s a Google problem).

Ah, I was quoting others, I forgot about the different versions, I'll have to recheck mine but I am on the 3rd Gen Nest.....wonder if the update was in Nov that we can downgrade them to previous version?

My Tech info says Model 3.4, Software 5.9.5-2, Updated Never and i've had it about 18 months. So it doesnt look to me that it can be the Nov update as I've always been running on this version....