cancel
Showing results for 
Search instead for 
Did you mean: 

Home/Away Assist, returning home always stuck in eco mode

Dawdie
Community Member

So I have 2 nest thermostats which are controlled with Home/Away. Whenever I go out the thermostat goes into eco as expected. Whenever I return home the app shows "Home" and so does the log so it defintatly knows I have returned, but the thermostat however is still stuck in "Eco" mode till I manually turn it off.

 

I have all the "learning" stuff off (Auto Schedule/True Radiant) so I have no idea what I need to do to fix this aside from just turning home/away off and putting the old thermostats back in.

 

Potential fix (using google home not the nest app) https://www.googlenestcommunity.com/t5/Nest-Thermostats/Home-Away-Assist-returning-home-always-stuck...

1 ACCEPTED SOLUTION

MelbaDT
Community Specialist
Community Specialist

Hey folks,

We understand your frustration about your Nest thermostat not working as it should, and we appreciate your reports here in the Community.

 

If you're experiencing this issue, please give all the steps listed here a shot: https://bit.ly/38qgivs. These steps have worked for others experiencing similar behavior and should help get you back on track.


If the issue persists after trying the steps on the link above, we want to be able to dig into this further. In order for us to differentiate between different countries' thermostats, go ahead and reply to the following threads with the following info:

  • The type of Nest thermostat you have
  • What mobile device you have and the OS version
  • The software version of your thermostat


EU users: https://bit.ly/3LZlrg2
US/CA users: https://bit.ly/3Jxm52R

We thank you for your patience and we look forward to taking a closer look.

Thanks,
Melba 

View solution in original post

750 REPLIES 750

Midjet76
Bronze
Bronze

Friday was another 2 trips away from home day and we achieved 75% success first time away Away/Eco then Home/ Eco, with manual back to Heat then later in the day Away/Eco then Home/Heat.   No other changes to settings other than the manual setting back to heat.

Saturday 2 trips away but down to 50% effective, only working the first time away second time didn't switch to eco.

Sunday, failed to switch to eco on our first and only trip away from home... So far....

JamH
Community Member

My issue is similar, but perhaps simpler, although still perplexing and google help line was (of course) no help.

Our NLT s in a vacation home.  We used to be able, via phone, to tell it AWAY or HOME.  Away set to ECO, Home to a schedule.  We turned off all sensing and location services.  We simply want to manually set to AWAY or HOME.

 

As it turns out, the NLT follows the HOME schedule even though it is set to AWAY, and shows thus in both the Nest and Home apps (Samsung S8).  

Google suggest rescheduling all HOME schedule to 50 degrees, not what we paid $$$ to do.

steve99uk
Community Member

Samsung SmartThings let’s you set routines for location detection and also you can manually change the NLT mode to ECO, HEAT etc from the app. 

This was our vacation home and we loved the nest which we still have 3 from 2012 to monitor powere outages and adjust easily.   Now we are here retired and basically full time.   Its the new one Bought yesterday) that now is the problem.    The others are manageable but I am afraid not the new one from Home Depot for $129.  Should have gotten it from Amazon and I can return a longer time and get the warrantee back easier.

Hoosierphilly
Community Member

Which nest do you have.  I had to replace one  of my four bought in 2012 as it seemed totally dead.     I don't want My  older nests messed with by any electronics or the darn app in my phone.  I prefer the old management from my computer.  My new one got installed a  G4cVZ  $129 at home depot and was time consuming to get into  my i phone 11 then the blue tooth disconected.    Nest then told me maybe poor electrical connectivity so recommended I get a power connector to place at the furnace.   I have trouble believing power is a problem as never ever saw it on off or on low power mode ever.    I hate the app. I always use the scheduling to control our temperatures as we cannot be observed by 4 different thermostat areas or 4 thermostats to suit our schedules.  On the new one I couldn't so do that. I suggest you try using scheduling by hour and day to control yours maybe that may work or make them replace it.  google their customer service phone number for a live rep who might be able to help.  

I'm just wondering Hoosierphilly how many on here are UK based and how many are Stateside and does that make a difference?  Certainly from tech support it's possible....perhaps, here in UK they try and be helpful, I was even "promised" by Chris that it would be resolved only later down the line to be told in an email by Chris, to take it up with who installed it...Really?  As far as I can see the majority of us on here who have contributed, regularly so far feel like Google are taking us all for fools....

in the USA.   I threatened to put my standard thermostats in (I still have them), but I want to be able to lock them so only I can change.  This was best when we rented one floor and also when selfish relatives vist who like it too cold especially in the summer.   If mine continue to break, I will look for another brand. or just keep the good one (if a good one)  in the main room.  I don't use the Google search engine as of recently and if they don't stop so many pop up adds I will change my e mail (get too much junk anyway).  

Steve59
Community Member

Google Support are hopeless with no real escalation route, there is clearly a problem that they fail to address 

  • UK here, Agree I do think Google are taking us as fools, or don't care. The Selling of Google Nest Thermostat does not work, and is a con until they get the Home/Away/eco functioning again. Before Google had control it worked perfectly. Strange how a big tech firm has mucked it up and unable to rectify it.   All went wrong in November 2021. When being away did not function or it did and went into eco but did not change on returning Home.

 

Steve59
Community Member

Same problem, app knows I am home as it says I am home but thermostat stays in eco - Google are useless

islandniles
Community Member

I decided to try Samsung Smart Things, but I’m having trouble with it before I even try to add routines.

I successfully linked my Google account and got the thermostat displayed. At first I was impressed, because it was showing the house temperature even more precisely than the device itself or the Nest app (19.7C). But for some reason, it has since changed to displaying the temperature in Fahrenheit, which is useless to me. Bizarrely it still reports the ‘temperature set to’ in C, but the current temperature in F. There seems to be no way of changing this in the app. I’ve logged into my account from a browser and checked that the units are correctly set to C, but still the thermostat temperature shows in F.

So, looks like this workaround is a non-starter for me.

Sounds strange, but you can just ignore this issue. I set up a schedule in the nest app for my NLT, and just use Samsung ST for the home/away functionality. 
this app just puts my NLT in Eco/Heating mode.

My NLT does display  in the SmartThings app as F usually but if I refresh the screen that shows the full details of the NLT ( Heating Temp, Temp, Humidity, Status and Mode) it then switches to C.

TBH all I will use SmartThings for is the routines. I use the Nest app for scheduling my CH & HW.

I think they can work together and you only need use the SmartThings app if you need to alter any home/away routines.  

Biggbrother
Community Member

I have 4 zones, with 3 of the new Nest Thermostats (the cheaper one that has a mirror screen that sells for $129) and 1 Nest Learning Thermostat (that typically sells for $249).  BTW, the naming scheme Google has used for these products is atrocious at it's easy to confuse them and searching for solutions for the newer ones is impossible)

Have any of you tried switching the thermostat to the cheaper and newer one just to see if it changes behavior)? You could always return it.  It is compatible with a bit fewer system types.

We have the NLT in our bedroom and I actually prefer the other 3 better because they easily allow you to set temperature preferences and schedules for Sleep, Eco, and Comfort modes.  Plus they behave like the NLT by switching to Eco when you are Away, and Comfort when you are Home.  And they are all controlled remotely from the Home app, like the NLT can be as well.

The NLT on the other hand is a more imprecise with it's learning algorithms and you almost need a PhD to set up a schedule on it (we don't have a schedule on it).  I usually find it sets our room too cold in winter and too hot in summer and no matter how many consecutive days I change it, it will learn for a week or so, and then creep back to being to cold or too hot (winter/summer), as if it thinks we'd forget we're too cold or hot so we can save energy.

And the only time I had a problem with the Home/Away mode triggering... was with the NLT.  But all four thermostats are working fine now.  I'm on Android (Pixel 6 Pro) in the USA (New England).


@Biggbrother wrote:

The NLT on the other hand is a more imprecise with it's learning algorithms and you almost need a PhD to set up a schedule on it (we don't have a schedule on it). 


It's not that hard, if you go into the "Schedule" screen you can just add blobs to increase/reduce the temperature at different times of the day and week. So I basically set mine up to heat in the morning and evening (like with my old manual programmer 🙂). I find it's easier if you log into home.nest.com on a computer, then you get a big screen to work on - it's rather fiddly on a small mobile screen.


Hoosierphilly
Community Member

I don't believe you save much in 3 hours.  Maybe if Northern Canada etc.

I had spoke to google tech support about my three thermostats and did what they told me to do ( again), worked for one day, stuck in eco mode AGAIN.

Here is a rhetorical question, WHAT IS WRONG WITH THEM?

they don’t want to acknowledge that there is a problem 

Midjet76
Bronze
Bronze

So today I've achieved 100% success with Nest App and Samsung ST. 

My setup for now....

1 Android phone only connected. Heating Schedule setup on the actual thermostat. Hot water configured via nest app.  All settings in the heating menu off.  Main menu, what devices if your home, phone location off, activity sensor off. 

In Samsung Smart Things obviously paired with the Nest Thermostat and then home away routines set, one for heat when home and another for eco when away from home. Fingers crossed it still works tomorrow, I've also made sure that neither of these apps Auto update to stop it getting broken again ... Assuming it keeps on working of course.

Do you have Home/Away Assist on or off?    Do you also use the Google Home App?  If so do you have presence sensing (mobile phone location) off in the Google Home App?

Not at the moment. Don't need Google Home with only one phone as far as i can tell. My logic is to try and avoid duplicate settings eg in Google Nest and Home.  As per others responses to my question above about SST and eco mode, SST directly switched the Thermostat between Heat and Eco mode which appears to be the case. 

One quirk using this method will mean that the Nest app will only display Home regardless of whether home or away but crucially it correctly reports Heat/Eco status 

Another quirk in SST is it has a tendency to switch to Fahrenheit but i just refreshed the page and it switch back to Celsius as Steve99UK also pointed out above...

I did think of an app conflict even if not using a Google account, as you need one to use that feature in Home App, anyhow unlinked Nest from Google Home - made no difference ! Nest app knows the phone is home or away but thermostat does not

We all know it reports accurately whether home or away, BUT, what we're all crying out for is accurate use of Heat or Eco modes, that's where Samsung ST is a game changer, just turn home/e away off wherever it is enabled and just use the geolocation from SST.... assuming it continues to work.... but as above it's worked 100% for me today and that's a first since joining this group.  Somewhere down the line I might meddle with adding SST to 2nd phone but gonna just give the current setup a few days to make sure it's not a fluke....

I also suspect that with enough patience Samsung Smart Things is i infinitely more useful for adjusting temps and setting schedules and so possibly/probably could do it all from there and literally just have the Nest app to register the device and nothing else....???

Still a sorry state of affairs when all is said and done.

I have home / away ON, I do have the google home app, downloaded by google, not me. I have turned off presence sensing. Mobile phone location turned ON in the google app.

I think that the bottom line currently is that the NEST app doesn’t switch the NLT from ECO/HEAT reliably but SST does. I’m on day 3 with 2 phones and no probs. 

So how many routines are needed to be configured on 2 phones in SST Steve99uk?. It's it just a home and away routines on each phone and as long as one phones home it'll stay in heat mode?. 

I linked my wife’s SST App to mine and then any routine I add/update on my iPhone immediately gets replicated into her iPhone. I have 2 routines. One is if we are both away from home set NLT to ECO mode. The other is that if either of us are at home switch NLT to HEAT. 

 @steve99uk  Are you running beta  iOS 15.3 on your iPhone or iOS15.2.1  ?

Beta iOS 15.3

Is your account a Google account or Nest, Google I expect

Google Steve. 

I have both Google & Nest accounts 

Please explain further, and what do you control in the Nest app (schedules ?) how do you log into the Nest app, have you migrated a nest account to a Google acxount

Oh you might have given me a clue on my thermostat with a mind of its own.  I have both the home and next apps because I also have the doorbell and the wifi mesh network.  Perhaps the home app is overriding the thermostat and the nest app which is where I keep making all of these bloody changes to try to fix the problem !!!

sboden2315
Community Member

Oh my gosh I feel like I found a support group in reading this thread.  My issue is even more nuanced.  Because I have been suffering with this for a week I turned off the home/away feature, I turned off eco settings and for one fabulous day my thermostat would work and heat my house to the target temperature.  Then my house went to 65 degrees again regardless of any thermostat setting I would put on.  We found a ghost "away" program that doesn't show.  I just went onto reset and wiped out the away setting on the thermostat and for the first time in 48 hours I have a house heated at the temperature I desire.  Let's see how long it lasts.  As so many of you have said, the thermostat worked perfectly for a few months and then took on a life of its own.  I have done 2 factory resets and nothing has solved this.  

Welcome @sboden2315 My logic would be go back to basics and build, given my experience since joining this group and following on from  what

steve99uk
Community Member said

"I think that the bottom line currently is that the NEST app doesn’t switch the NLT from ECO/HEAT reliably but SST does. I’m on day 3 with 2 phones and no probs."

 

For me I reset 3rd gen thermostat, re registered with my wifes google account rather than mine, reinstalled Nest app on her android phone and nothing on mine, so far, reinstalled Nest app and linked it to the Stat then shortcut version... set schedule for heating on the stat for the week (probably not essential) set hot water for week.... evrything else off as per my post above 5 hours ago....then configure Samsung Smart Things to do the home and away bit... it's routines based on If and Then statements as opposed to a simple switch home away on....If you take time and browse this thread properly you will get a good feel for our frustrations and recent successes....and hopefully it will make sense....It would appear that certain iPhone versions may have some problems with samsung smart things running in the background? but latest version seems to have fixed this issue, if i'm reading others responses correctly.  Good luck...

I don't have an iphone and none of us should have to do this work around.  A $300 thermostat from Google should just work.  All the time.  And be simple and intuitive.  And again for me the issue isn't operating my home/away feature from my phone, in fact they had me disable it as part of the fix - great fix - take away all of the features that you want and try to use the $300 product as a dumb cheap thermostat.  My problem. like many on this thread, is that we just can't get the thermostat to force our furnaces to reach the desired temperature consistently.  The fix can't and shouldn't be to turn off all of the features of the app in order to achieve that.  Shame on Google !!

We all totally agree, however, until we do get a fix which will probably be never, I am literally just using Nest app to have the device registered and using Smart Things for anything else, not good for Google to be ignoring our plight, but for me I just won't buy another single product from them ever again so that's gotta be their loss.

Ugly_Bloke
Community Member

Glad I've found this thread as thought I was going mad!  Same problem for me in the UK with my gen3 Nest Thermostat:  2 hour wait on average to switch to/from ECO despite the Nest app switching correctly straight away.  Sometimes it will get stick in ECO and I wake up to a freezing house.   Sometimes it doesn't go into ECO when I'm out at all wasting a whole day of energy.

I've tried everything:  factory reset, re-installing app, migrating account to Google, disabling auto-learn, resetting home/away, Google Home app re-install, checking all permissions on iOS, checking settings and log on router etc.....  

Sometimes resetting something results in the Home/Away function working perfectly for 1 or 2 days then it starts playing up again.

Had a ticket open with Google since November but they treat me like I'm stupid by asking me to try the most simple things.   They don't seem to understand I've exhausted all troubleshooting and would typically only contact a company's support desk as an absolute last resort.

Is there anything we can do to escalate this as the issue is becoming extremely frustrating to the point I'm on the verge of ripping it out?!  As it stands, the product is not fit for purpose.

What you are describing is exactly what is happening to me. I have been in contact with google tech support as well, they don’t seem to want to admit there is a problem.

I understand.