Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest learning thermostat flashing green light, will not turn on

Community Member

I'm starting a new thread on this because all similar ones have not been answered but rather have resulted in the original poster giving up and buying a new thermostat or never receiving any response greater than "are you still having this issue" or "have you tried turning it off, long press 10s"

Here are the details of the issue:

  • The thermostat was working perfectly until 4pm yesterday when it dropped off the network and I couldn't set the heat via my phone. Upon returning to the house, the thermostat screen was blank, a small green light at the top of the unit was flashing, and it would not respond to any press/rotation, power unplugged/plugged back in, etc.
  • I consulted the forums and the support section, to learn of the long press for 10s to restart the unit. It did not restart – completely unresponsive.
  • I also saw that the unit may need to be reseated on the stand so I did that too. Removed the thermostat and replaced it on the stand until it clicked properly into place. Still no life in the unit; screen still blank.
  • I changed the charging cable, plugged it into a wall socket and also attempted to trickle-charge via USB connection to a computer – still no life; no response from the unit; nothing.
  • Then I noticed that the flashing green light only flashes when the thermostat is connected to the stand. Even if the stand is not plugged into the wall charger or connected to a computer via USB! It does not flash when connected to the USB cable via the port on the back and it does not flash when removed from the stand either. Despite being disconnected from a power source for over 12 hours now, it's still flashing at me on my desk.

Obviously, the unit is able to receive power to make this light flash so the battery must be delivering something to the circuit. However, none of the approved ways to restart the unit are having any effect nor achieving any response. This has all the hallmarks of a firmware update gone wrong. I've seen this kind of thing from countless incidents during my career in IT of people incorrectly flashing their PC BIOS with the wrong image and other such events.

The green light is giving feedback about something. If the unit was dead or the battery was unable to power the circuit/charge it would not be able to power the little green LED for the last 12 hours while also not being able to briefly flash a message on the screen to indicate what the problem was.

The flashing green light, according to Google's own support documentation indicates that a software update could be in progress. This is obviously a default state for the device while the firmware on the device is not fully functional so a primitive circuit provides feedback in the form of a flashing green indicator. 

A lot of people on here are reporting this issue from what I can see and I would very much like to know if the possibility of an unsuccessful or corrupted software update is the reason behind this. I think we all deserve answers beyond "are you still having this problem?"

Can any of the support staff here help to indicate what is going on? Can we do some debugging together somehow? Is there another way besides the long press for 10 seconds that we can reset the device or load a functioning version of the firmware onto it? Saying that, it doesn't appear to mount as a device on my computer when connected by USB either.

I refuse to believe that the unit is just dead, something happened yesterday afternoon to cause this and nothing points to a unit just coming to end of life nor previously showing signs of malfunction, resulting in this state.

The light is still flashing. It has power and enough circuit logic to still do that. My gut tells me it's the software!


Community Member

I have exactly the same problem. My updated HVAC has two 3rd gen learning thermostats. Everything was fine for a few months and then one of the thermostats did exactly what you have described. And I too did everything recommended. Pressing for ten second and then restarting just causes red flashing for a few minutes and then back to green flashing. They have not been connected to WiFi as far as I know. So I don't see how they could try to update. The other thermostat still works. I hope for improved communications on this topic!

Sadly I am still here but there is an update to this story. After giving up hope that support would get back to me and faced with an out of warranty item anyhow, I opened the device, hooked up a small circuit of high-draw LEDs to the battery terminals and drained it completely. Then I plugged it back in on a trickle charge and after about 30 mins it magically came back to life, confirming that the screen was not kaput and that the board was functioning perfectly. The Nest worked perfectly for about 3 weeks after that and then returned to its offline blinking state again one day. Repeating the process described above did not resuscitate it this time sadly but I live with the belief that something other than hardware failure is causing this. Dead hardware does not magically come back to life and function perfectly for weeks on end. I'm convinced there's something software-related at play here.

Community Member

I decided to take the thermostat out of the attic again last night and see how it was feeling after 7 months of draining its battery and being idle. As if by magic, it returned to life yet again after being plugged into a USB charger for a while. There is nothing wrong with this device, its circuitry, screen, or the most part of its components. It even connects to my wifi again and is fully functioning here on my desk. I'm starting to think that this may be a battery issue. Like some old laptops that had the battery as part of the charging circuit and caused huge problems as a result (i.e. not being able to run off the mains input because the battery blocked the power). I'm tempted to spend the money on a replacement battery from a third party and see what happens. Will wait to see if the Nest last longer than 3 weeks this time first. Will update on any new findings. These devices that we and many, many more are complaining about are not fully broken. It's just a shame that Google does not seem to care at all about what might be a product fault and a simple fix for so many customers.

Community Member

Could there be a class action lawsuit for this?

Community Member

I don't think it's that kind of situation. What it has done is left a very bad taste in the mouth of many customers who are out of warranty and thus no comeback anyway, for what may turn out to be an incredibly simple problem that's easily resolved. Google's perceived lack of interest in it is baffling.

Community Member

UPDATE: 2 months now since it came back to life for the second time and it's still going strong. Don't discard your Nest Thermostat if it ends up as this thread describes at the outset, folks. Hold onto it, drain the battery for as long as you can and then try to charge it again. Can't say it will work for sure but I'm getting some more life out of mine for now.

Thanks. That's useful info. My two replaced units are still functional although one can't use WiFi. And life continues...

Community Member

I'm curious if you can tell me what the Vin and battery voltage readings are when your thermostat is working.  I had no problems with my old furnace which provided 24 volts to the common wire.  My new furnace is providing about 36 volts, and now after a year or so I'm seeing the same problem you have experienced (blinking green led, not resettable, unresponsive for long periods), although for now, the Nest does come back again after a day or so.  The max supported voltage is supposed to be 42 volts, but I'm wondering if furnaces that provide a higher voltage closer to the 42V max might lead to a faster degradation of the battery. The battery voltage on mine is 3.94 volts, which seems a little high and may be leading to battery degradation.  Anyway, I'm considering replacing the battery and seeing if that fixes the problem. If it doesn't fix the problem (or I botch the replacement -- although I'm fairly experienced at that sort of thing), I'm going to change over to an Ecobee.

Fully discharging a rechargeable battery and recharging it can sometimes bring a battery back to life, but it doesn't fix the root problem.  I'll be curious to see how long your thermostat continues to run without repeating the problem.  I can afford for the thermostat to be out of commission for days during the summer, since we rarely use the A/C.  But failing during the winter would be highly inconvenient.

Community Member


Our thermostat isn't wired in directly but in receipt of a standard DC output from a USB transformer. Unfortunately, I can't give you details on the wired-in versions. Our Nest has been working solidly (I hope I don't tempt fate!) since I posted the update here. I never did change the battery in the end but it's hugely confusing as to why something would stop working as if dead and then return to life about a year later. Hope you find some positive outcomes in your pursuits.

I'm not at my house now as I am taking care of my 100 year old mother. The problem I had was that the battery voltage would slowly fall and that would start turning off functions (as designed). I replaced the battery, but that didn't really help. It seems that the thermostat was taking more out of the battery than it was putting in. It says it is getting 200 mA and that makes sense as there is a common wire.
By the way, if you replace the battery there are several things to know:
1. Remove the two larger screws on the back.
2. Rotate the white panel 5 or 10 degrees counterclockwise and lift it up.
3. Remove the four screws on the black panel and lift it up being careful of the ribbon cable.
4. You will see the battery and connector. The connector has some foam attached with adhesive. The connector pulls straight UP to disconnect.
5. There is a black tab attached to double sided tape under the battery. Pull it sideways very slowly and gently and the tape will be removed, freeing the battery. This takes several minutes.
6. Now the new battery can be plugged in and held with double sided tape. It doesn't have to be as heroic as the stuff removed.
7. Reinstall the black panel and its four screws. The ribbon cable goes through the same hole that the connector will peek through, but next to it.
8. Reinstall the white panel, remembering that it must be rotated counterclockwise a bit to drop in and then back to lock.
9. Install the two screws to hold the white panel.
10. Charge the unit using a USB micro connector and a five volt supply. A computer will do in a pinch.
11. Plug it back on the wall.
12. Pray.

Community Member

Since I didn't install the thermostat, the builders did. I will have to check on the warranty. Thanks for the reminder and I hope the problem is solved for you and everyone (there seem to be a lot) else with the same issue.

Community Member

I have been have similar problems with mt unit for three weeks now. Don't want to waste my money to buy another one if this is a on going problem with this product. There should be a customer service live number for complain or resolves.

I used the chat function to "talk" to someone both times that a unit failed. They will want to do all kinds of tests. Set aside an hour. If they can't get it going and it is under warranty (2-5 years depending) they will email prepaid mailing labels to ship it back. Once it arrives they will test it again and ship a replacement. There are no shipping charges either way. I had one gen 3 unit fail after about a year. The replacement is still working. The second failed six months later and was still under warranty. I Fedexed it back a few days ago. I expect to get the replacement in a week or two. This is the time of year that I have no problems living without a thermostat. Besides, the upstairs thermostat is present and working.

Good luck.

Community Member

I had the exact same issue, I even talked to support over a phone but the person was quite unhelpful just stating that the device is bad and I need to purchase a new one, but even after his advice that the device is bad it started working again after I did some troubleshooting on my own. It worked fine again for a few months but now the same issue has reappeared! I just purchased an Amazon Smart Thermostat instead so that I can be away from this hassle.

Community Member

There was (is) definitely something odd about this issue. So many people reporting the same problem and many reporting this spontaneous return to life that dead hardware simply doesn't do. Dead hardware is dead – it doesn't start to function perfectly for weeks/months after a resurrection. At the time I made this post, the blinking, green light and dead screen didn't even feature in the help guides as evidence of a broken unit which let's face it, if it was designed to have a bypass circuit for the LED when everything else was dead to indicate to people that they had a problem, you'd think they'd include it in the documentation! I never purchased another unit in the end and after this experience, I don't think I will ever purchase another Nest Thermostat. Far too expensive for something with a one-year warranty and issues like this that have no support/fix service. A couple of smart switches, a Raspberry Pi, and put my old skills to use will be my next port of call I think!

Community Member

Same experience as everyone but its failure is on the coldest day of the year. I am about to get a reliable dumb thermostat to replace this menaced to my home. There needs to be a non software override.

Community Member

If you need an override just to turn on your heating, just press the centre button of the HeatLink installed beside your burner/boiler. It's the most expensive on/off switch you'll ever own but at least it turns the heat back on.