Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

FiOS and Google WiFi (NYC edition)

Community Member

I've recently ditched my cable company and have switched to FiOS. The initial swap went well, unplug from the cable modem and plug into the ONT and things just worked. However, every few hours my IPv6 connections would drop, this is both on my OG Google WiFi and my new Nest WiFi Pro. Here's what I've observed:

FiOS in NYC hands out an /56, Spectrum (cable) hands out a /64 - this is the primary difference that I can see. 

The v6 address my clients receive is a /64. 

When my connection drops, my Dynamic DNS script (via Cloudflare APIs) reports a new address in a new /64 but the same /56.

I believe that when the lease is renewed by the router a valid IP address in the /56 is offered with a random /64 prefix. This triggers the client to notice that they're not in the same /64 and destroy the previous address.

It seems like an easy solution is for the Google router to treat a /56 as a /64 and use a fixed (or configurable) pad to the /56 prefix. This would ensure that only addresses from a single /64 would be usable - once I have more than 2^64 devices that may be a problem but hopefully that won't be for a while...

Alternatively, changing the client prefix to a /56 may work, but I don't know if this will cause client-side limitations that assume a /64.

An alternative solution that could work for me is to expand the Google One VPN to the Nest WiFi product lines, passing on the IPv6 pinhole configuration from the Nest WiFi. This seems like a lot more work, but adds value to both product lines and expands the greater IPv6 footprint (it took me a while to figure out why my Pixel kept working on IPv6 even with it disabled on the router).

Temporarily (?) I've installed the carrier provided router to fix this issue, but I'd much prefer to switch back to a solution I could manage from the Home app. I have submitted a report via the Home app just after a prefix change occurred in hopes that it helps validate things on Google's end. Please let me know if I can provide any additional information!


Community Specialist
Community Specialist

Hey jdbower,


Thanks for posting — let's see what's going on. My apologies for the late reply.


Give these steps a try:

  • Make sure that there is minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) and the points are no more than two rooms apart.
  • Remove any special characters in your network name and password.
  • Turn off IPv6.
  • Change your DNS server into on the primary and on the secondary server. Hit the save/ floppy disk icon on the upper right.
  • Unplug the power from your Google Wifi devices for 2 minutes.
  • If the issue persists, try factory resetting your network
  • You may skip any step if you’ve done it already.

Let us know how it goes. Thanks for sending in your feedback as well.


Community Member

Most of those I've tried (except turning off IPv6, it's not 2010 anymore so that's not really an option for me!). The routers work great on cable, but on FiOS the IPv6 addressing keeps  changing prefix. The only real difference I can see is that on FiOS I get a /56 while on cable I get a /64. On cable things work fine because clients get an address from the same prefix. On FiOS the Google WiFi devices (both OG and Pro) offer an IP address from a random /64 within the /56 - so from a client perspective the IPv6 address prefix keeps changing and existing connections are appropriately destroyed. For a typical client this isn't a huge issue since most connections are ephemeral anyway, but I have persistent IPv6 connections via SSH which don't reconnect properly and inbound connections take up to five minutes to detect the change and update DNS.

Using the (gross!) carrier-provided router things are stable, mainly because it pads out the /56 with a user-configurable value and allocates IP space using a single /64 (there are also more advanced subnetting options via DHCPv6, but I don't use nor need those).

Community Specialist
Community Specialist

Hello jdbower,

Sorry we were unable to get back to you sooner. I want to check if you are still having issues with your Google Nest Wifi Pro. If you are, please fill out this form so we can provide you with the right level of help. Let me know once you're done.


Community Member

I've submitted the form, but unfortunately I don't know that I'll be able to test again until the fall. I know there's been at least one software release for the WiFi Pro since I last tried, is there a place where they're a changelog for things beyond "bug fixes and performance improvements?" I'm 99% certain I know the issue (and that it won't impact the majority of users who have a /64 from their ISP or don't use persistent IPv6 connections). I do love it at another property on cable with a /64, and I'll keep around the device in NYC to try periodically.

Community Specialist
Community Specialist

Hey jdbower,


We got your form — thanks for filling it out. Our team will reach out to you via email to further assist you. Also, please be advised that this thread will be locked after 24 hours.


Thanks for the help, Abi and Lovely.