cancel
Showing results for 
Search instead for 
Did you mean: 

Port Forwarding not working on Google Nest

docx
Community Member

I've been trying to configure forwarded ports for various services (VPN, ssh, HTTP, etc) and have been unsuccessful. While diagnosing the issue, it appears my Google Nest Wifi router (Model H2D, Software version 14150.43.81) is not properly forwarding ports.  Here are the steps I used to reproduce the error:

  • Pick an arbitrary port number higher than 1024. For this example, we'll use 21232
  • Go to the port forwarding section of the Google Home app (Wifi -> Gear Icon -> Advanced networking -> Port management -> '+')
  • Choose an IPv4 internal host (aka local-server) and configure the external and internal IP addresses to be '21232', configure forwarding for TCP & UDP, and save the setting
  • Verify my external IP address via https://icanhazip.com/ (let's say it's 1.2.3.4)
  • Use the netcat utility to open a TCP service on port 21232 (nc -l 21232)
  • On a host outside my network (aka remote-client), use netcat to connect to the port via my public IP address (nc -nvz 1.2.3.4 21232) and to send data to that port (echo "hello" | nc -nv 1.2.3.4 21232) .  The output says it is successful both times (Connection to 1.2.3.4 21232 port [tcp/*] succeeded!)
  • On local-server, listening with netcat as well as monitoring with tcpdump (tcpdump -nnSX port 21232) does not show any traffic on port 21232.
  • On a different host inside my network (aka local-client) I run the same commands I ran on remote-client. This time, I see output on local-server both from netcat as well as from tcpdump.

All of this indicates to me that local connections work fine, but remote connections, even though the client believes it's working, are not getting to the forwarded host inside my network.  I've tried this with multiple ports and using TCP only, UDP only, and TCP & UDP and none work.

Is there an update I can apply, or a configuration setting to tweak to get this to work? I would very much like to get this up and running.  I know it worked previously (having had this set up ~1-2 years ago) using the same configuration steps, so it is perplexing why it does not work now.

4 REPLIES 4

olavrb
Platinum Product Expert
Platinum Product Expert

Try a reboot/ power cycle. Worst case try to factory reset and set up from scratch.

I struggled too when port forwarding for Plex, but after some reboots, waiting, testing it suddenly worked.

Other things to check:

  • If double NAT, make sure to port forward on all routers.
  • Client device firewall allows traffic from external IPs.
  • ISP does not block chosen port.
  • Client MAC randomization is disabled.
  • Set static IP by DHCP reservation. I like to reserve the 10 first IPs in the DHCP scope for such use, so I set DHCP range to be from x.x.x.10-255.
  • Preferably connect client by ethernet cable to the primary Nest Wifi puck. Add more LAN ports by adding an unmanaged switch if neccessary: https://support.google.com/googlenest/answer/6274262?hl=en .

Maybe you can find other things to check from previous threads on this topic:


I don't work for Google.

docx
Community Member

I'll see about doing a reboot/power cycle, but it'll have to wait until the weekend (as I work from home and doing a reboot mid-week would be disruptive; a factory reset quadrupley so). For the other suggestions...

  • There might be a Double NAT situation, but that was not an issue previously.
  • The client device(s) (I've tried multiple different ones) do not have firewalls on them.
  • I have tried multiple ports (some of which were used previously), and I'm using the Business-class product from my ISP so if they're blocking ports, they got some 'splainin' to do.
  • No Client MAC randomization on the multiple devices I've tried
  • All devices have static IPs assigned that are outside the DHCP address range
  • One of the tested devices is connected by Ethernet cable to an unmanaged switch that is connected directly to the primary Nest Wifi router, so that's sorted already.

And thanks for the LMTGFY link. Found it amusing that this thread was the third link I saw 🙂 Looked through the first four pages of results and none of the pages that were similar to my issue had any new advice, though one did have a link to https://www.portchecktool.com/ which reports no services listening at my IP on the ports I'm testing, so it's not just my testing with nc that's failing.

docx
Community Member

After a lightning strike, a replaced cable modem, and a complete reset of the routers it appears I am getting some port forwarding with Plex (which was one of the apps I was previously having issues with).  I've not re-tried setting up the VPN due to lack of time. When I can get back to it, if I have additional issues I'll post on a separate thread. But for now, I'm closing this one since, while I don't know which of the many changes I did sorted the issue, it has been sorted.

Princesss
Community Specialist
Community Specialist

Hey docx,

 

Thanks for visiting the Community.

 

Glad to know that this has been sorted. I'll consider this post as complete and will lock the thread in 24 hours. Feel free to start a new thread if you need assistance with your Google Nest Wi-Fi devices. 

 

Best,

Princess