cancel
Showing results for 
Search instead for 
Did you mean: 

Speed limit on Mesh points

Alex__Ferro
Community Member

Hi! 

For some months I've been using a Google Nest mesh system at my home with my ISP provider connection of 100MBps, without any concerns. 

However, I now upgraded the service to a 500MB package and I realized that despite the connection at the router being tested and performing well, the speed at the endpoints is still capped at the maximum of ˜100MBps. 

I did some tests putting the access point side by side with the main router, which is connected to the ethernet port of the ISP modem. 

The results from Google Home tests are below: 

Nest Router + Nest Access point

Alex__Ferro_0-1667743452241.png

 

Nest Router + Google Wifi point

Alex__Ferro_1-1667743494614.png

It clearly shows a bottleneck from any mesh point to the main router. But, why?

Is there any config or limitation regarding the mesh connection on those devices? 

 

 

Thanks,

Alex

5 REPLIES 5

dannymeercat
Community Member

This is exactly what I have been experiencing since I installed last week. Outside of needing 3 additional Nest Wifi Pro points for 5000 sq/ft due to poor range compared to last gen Nest Wifi with two points.

I've seen talk about it being a glitch in the speed test and just reporting slower speeds than you are actually getting. For me, unless I'm connected directly to the main router, I get 60-80mbps on the home app speed test, fast.com, and speedtest.net. Even just downloading a file is limited to the 60-80mbps. I have a 1gbps connection from ISP and came from the previous gen Nest Wifi. I regularly saw 600-800mbps from the router and 500mbps on the points.

The only thing that helped speeds, even slightly, was making sure there were no ethernet connections to any of the points. That bumped my speeds up to 120-150mpbs. Still unacceptable imo. 

I've tried every combination of WPA3, 160Mhz, IPv6, and preferred activities and still get the same results. 

Have you tried various combinations of settings/wired vs wireless and experiences any variance in results?

AbigailF
Community Specialist
Community Specialist

Hey folks,

Thanks for posting — let's see what's going on. 

Are you using a modem/router combo from your Internet Service Provider (ISP)? How many devices are dropping from the network? Also, do you have any paused devices? 

Give these steps a try:

If you're using a modem/router combo, set that to bridge mode to avoid double NAT issues.
Make sure that there is minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) and the points are no more than two rooms apart.
Remove any special characters in your network name and password.
Turn off IPv6.
Change your DNS server into 8.8.8.8 on the primary and 8.8.4.4 on the secondary server. Hit the save/ floppy disk icon on the upper right.
Unplug the power from your Google Wifi devices for 2 minutes.
If the issue persists, try factory resetting your network.

Let us know how it goes.

Best,
Abi

Hi Abi, thanks for your answer. 

 

I use the Nest router connected directly to my ISP modem configured on bridge mode. 

I sued to have my network name with a hyphen "-" in the name, as per your recommendation I took it out and in the new network I configured it as requested: 

IPv6 disabled

Google DNSs set.

Network factory reset

Modem -> Nest Router: Only one device connected, wired. 

Nest Router -> Nest Wifi Access Point: I put them side by side, less than 10cm from each other. 

Access point -> iPhone 11 pro: Only one single device is connected to the whole network. 

The results are basically the same: It seems the connection is capped at 100˜150MBps and the bottleneck seems to be between the points and the router. 

Best,

Alex

AbigailF
Community Specialist
Community Specialist

Hi @Alex__Ferro,

I'm sorry to hear that you're still having an issue with your Google Nest Wifi. We'd like to take a deeper look into this — could you fill out this form and let us know once you're done?

Thanks,
Abi

AbigailF
Community Specialist
Community Specialist

Hey @Alex__Ferro

We got your form — thanks for filling it out. Keep your lines open as our team will reach out to you via email anytime soon. 

Also, please continue the conversation there as this thread will be locked after 24 hours.

Cheers, 
Abi