Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Cannot "open" Netflix

Community Member

Netflix does not open as it usually did  months ago with a curated list of Netflix shows based on my account.  If I ask the Hub or Hub Max to open Netflix, it repsonds with "I do not know where to play the video, please tell me the name of the exact screen".  When I try using the Netflix button in the app drawer, it says "I heard open Netflix on this device" with a list of options that lead to the same result as the voice command.  This had worked before, but feel like it might be a deprecated feature.  


Thank you for the reply - there are no issues with Netflix servers, stream quality has no impact here, and have signed our (unlinked/linked Netflix) with a factory reset of the hub.  To be clear - there used to be a “app” for lack of a better word on a nest Hub or Hub Max that looked like a slimmed down Netflix landing page with a curated list of shows to start form the device.  This is evident by the Netflix icon/app in the hub/hub max app drawer.  This no longer functions as intended and is extremely frustrating to use now.  Has there been a change to this feature?

Hi everyone, 


Thanks for visiting the Community.


@StuTheWizard, we're sorry to hear about the experience. Could you tell us what country are you located at? Also, have you tried using a different phone when you try linking your Netflix account?


@RachelGomez123, thanks for always chiming in.


Feel free to respond to this if you have additional questions.




Hi Princess,

1) USA

2) you’re saying link Netflix using the home app on a different phone?  I’ll give that a try - but if that has any different effect, how is that an appropriate troubleshooting step?  Are you trying to isolate if it’s my phone that’s causing the Netflix issue?  Just wanting to understand the troubleshooting strategy - what are we trying to isolate?  

Thank you!

@Princesss ,

Also - I haven’t had any issues linking Netflix as a video service in my Home App.  This is on the Hubs after being successfully linked.  I have performed factory resets and re-linked Netflix to ensure there wasn’t an issue there.  
My question is if the earlier feature of Netflix opening as a curated list of Netflix shows (akin to how YouTube opens with recommended videos to watch on the hub) has been removed without telling users.  I cannot get it to function like this anymore and the only way to watch Netflix on these hubs is to use the assistant with voice and know exactly what show, season, episode, and screen to watch it on… absolutely tedious.  It’s easier to cast from my phone instead - but I’m looking to use the original feature because I don’t always have my phone to cast with near a hub.  This worked before in the exact way I’m asking it to “open Netflix” now - this does nothing but return negative responses on why it won’t work.  

I’m interested if this works for anyone else and if a Google/Nest specialist can confirm/sent if this feature has been removed.

Community Specialist
Community Specialist

Hey StuTheWizard,


Sorry for the confusion. Could you try using the command "Hey Google, start Netflix" and see if you will get the same response from your device. Also, we'd be happy to take a look into this for you. Please fill out this form with all the needed information then let me know once done.



Thank you - I have sent the form.  

Community Specialist
Community Specialist

Hi there,


We got your form — thanks for filling it out. Our team will reach out to you via email anytime soon. Please continue the conversation there as this thread will be locked after 24 hours.