Showing results for 
Search instead for 
Did you mean: 

Google Speaker Groups not working

Community Member

I'm also having similar problems-  Have mix of Google audio cast and google enabled speakers across the house- most of the time casting doesn't work - If I go into the home app the groups are disappearing and re-appearing alot- I'll select a group that worked the day before and only one speaker plays - it still shows all devices playing-  I can try it a few times- go in and out of the google home app and try to force it that way- sometimes it works, sometimes it doesn't - all the firmware is up to date and it's just SOOOOO frustrating -  I even went and got a new google home speaker thinking maybe gen1 was causing an issue- nope still same problem-  COME ON GOOGLE!!!  

395 REPLIES 395

Don't hold your breath.  We users have been reporting this problem to Google for over 2 years, and this thread is going down the same path as all the others before it.  Unfortunately I've learned that Google will pretty much half-a** anything that doesn't go straight to their Search, data collection, or other advertising wallet.  In those cases you can bet sh*t gets solved.

Community Member

So I did a factory reset on my router and attempted to set the devices again, but same, group audio failed and didn’t work. 
I turned off the Wi-Fi from my T-Mobile home gateway and plugged the nest Wi-Fi , set up a new Wi-Fi network, set audio devices as a group, issue resolved. 

I didn’t bother to go into the settings to see if there was an issue with 2.4ghz or 5ghz, but I honestly like the nest Wi-Fi so I’ll keep it like that.

Community Member

i have thousands of devices in my google home... no way im going to delete my google home and then re-adding all the devices....

Community Member

Ditto! Ditto! Ditto!

I'm experiencing the same issue referenced above, where the audio only plays from one speaker instead of syncing across both devices.

I'm using an iPhone 8 (iOS 15.1) with with a speaker group comprised of 2 Home Mini's. I've tried the following solutions with no success:

  1. Reset my wireless router multiple times
  2. Deleted and recreated the referenced speaker groups multiple times
  3. Performed multiple factory resets on both Google devices
  4. Deleted and recreated my 'Home' in the Google Home app
  5. Deleted and re-installed the Google Home app

What should I try next?

Additional information: I connected my Archer C7 gateway router to my "New" T-Mobile Home Internet gateway. Then, I connected my Goggle Home Mini's to my Archer C7 gateway router's WIFI. Guess what? The speaker group now works. 

Ohhhh, I wondered if it had to do with our T-Mobile WiFi. I'm going to look into this! Thanks!!

Community Member

My mixed brand speaker group is suddenly working stable with voice commands.

I dont know why - but the issue with voice commands not working on my speaker after 24 hours  seems to be resolved.
It has now been working fine several days!!!

See my post above...

Community Member

I'll add to the chorus of upset customers. I bought 

  • google nest (2nd gen)
  • (2) Two google home minis

Just this Sunday (11/14/2021), and already experience this inability to play music across all devices on a group. Music only plays from one device. Tried to play across the group using:

1) Voice commands 2) the google home app 3) the google nest display device 4) through the spotify app (selecting your audio device).

All my devices were updated upon installation, and the google home app (on my google pixel phone) is up to date. 

Spotify is my default music service. Please Help.

Community Member

A power cycle of my router seems to have led to it working fine... go figure

Community Member

Google broke something again for sure. Have one speaker group consisting of a Nest Hub Max, a Google Home, and a Chromecast with Google TV. This worked fine last time I tried, a few weeks ago. 

Now all of a sudden when casting audio to the group, only the Chromecast with Google TV plays the audio. The other device chime and act like they're gonna start playing but no sound comes out. The Nest Hub Max even shows the artwork of what should be playing and the playback controls but with no sound.

Rebooting all devices do nothing, volume is fine and is not muted, etc. Tried renaming the group and recreating a new one from scratch. Makes no difference.

I noticed if I take out the Chromecast with G TV from the group, then the group starts working again, the audio works as expected from the two remaining devices. As soon as I put the Chromecast back in the group, it stops working again.

Community Member

Another upset Google customer. We have several homes, minis, the Google Hub Max, and the giant speaker (not sure what it's called). Our groups worked great then BAM it will only play on one speaker. I've tried mirroring my phone, playing through Spotify app, tried everything through the Google Home app and NOTHING works. 

We've deleted every group, factory reset every Google home/minis (painnnn in my a$$), reinstalled app.. seriously we've spent hours this week trying to get it to work. We deleted the entire Home and started completely over! Glad I'm not the only one, but they need to fix this!! I just want to blare Christmas music throughout the house while I cook, clean, put up Christmas decorations!!

Also, our facial recognition on all our cameras have suddenly stopped working.. I love Google (seriously, we have everything Google including our phones) but I'm SO FRUSTRATED!!

Community Member

Hi, I'm having the same with speaker group google home not working on youtube music from my Samsung s20. It does try to play but no sound. Spotify works OK,


Community Member

I've been troubleshooting something similar and was wondering if it came down to multicasting.  i know chromecast utilizes multicasting.

I too was experiencing something similar with groups.  If I gave the command to a speaker to play on a group, it only played on the speaker i gave the command to.  i looked in my access point settings and there was something called "Multicast to Unicast Stream Conversion", which was enabled by default.  I disabled this setting, and the speaker group started working again.  If you have a more advanced router or access point, see if this is enabled by default.

Community Member

No suprises here, I have the same issues.

Groups just do not work with voice commands, the whole thing is broken.

I have a 2 1st gen minis, 7 2nds gen a google home a lenovo clock and 2 chromecasts.

It is great when it works, but months of hassle is not worth any amount of money.

I had this before, it went away for months and now it is back again.

I just keep trying, one day google will fix it?

Anyone tried the amazon stuff, is it any better?


sadly for me, too late to switch to the other side because my entire ecosystem is google home… too costly for me

Community Member


Any news about that? The groups management seems to be completely bugged from weeks!
I own a GoogleMini, GoogleMax, a bunch of Google chromecast and two JBL playlist.
- Sending music to a group containing only the two JBLs: no problem
- Sending music to a group containing Google stuff: no problem
- Sending music to a group containing GoogleMini and the two JBL: Bug. The music swaps from one JBL to the other every 10-20 seconds !!!?!?? 

(tried everything! rename/change groups, reboot router, reset jbls, reinstall home app, etc...)

Very disapointed!

Community Member

Same here… I have 8 home minis, 4 chrome cast audios and a home hub… several speaker groups, always been a bit iffy whether they would play but now none of them want to know…. I’ve started buying echo dots now and will be moving the house over to them over the coming months I think, they seem a lot more stable up to now anyway…

Community Member

Having tried every step imaginable, I cannot get my speaker group to work. I have a Google home and Google home mini. Both have been rebooted. Both are connected to a speaker group. But only one will play music when given command to do so. Even though Google says "got it, playing music on X group". The other shows as connected, but does not play the music. This is making me want to scratch the walls with frustration. Why have such a feature if it simply doesn't work?!

Community Member

your issue sounds exactly like mine, and it was a network/wifi setting that i changed in order to make it work.  do you know anything about unicast and multicast traffic? 

In my opinion, google has done something wrong with the design of how these systems should work.  The vast majority of users have no idea what unicast and multicast traffic is or how to troubleshoot it.
lmk if you'd like help with this.  I'd be happy to remote into your computer with teamviewer and diagnose the network, if you're comfortable.

Wondering what setting? 

I think it'll depend on the network setup you have at home.  Look into multicast settings.
If you just have a single router, what is the make/model?



I have one router with two different... channels? There is a media one and a non media one. I've been wondering if I need to just make it one channel or make the passwords different?


For the multicast settings, it's an Arris modem and belkin router. Any advice on where to look for those settings? 


I just want the speakers to play upstairs and downstairs at the same time 😫

Community Member

Add me to the list my groups won’t work done all the resets, reboots etc no joy. Please fix as the wife is now blaming me 

Community Member

I have a homegroup consisting of a Nest hub, and two nest minis (2nd gen). I can cast music to individual devices, but when I to cast to homegroup, the Nest hub won't show any action while the two minis work fine. 

Any idea how to fix that? 

Having similar issues as everyone else. 2 nest and 2 google home. Groups don't work for anything. Music and commands only work for individual devices. Any response from Google yet for anyone on here?

Community Member

To all those having problems with voice commands, just turn them off.  I had a ton of issues with Spotify stopping playing any audio, would just randomly stop.  Figured out that certain noises would cause it to stop.  Turned off all of the voice stuff and now it works.  Can't say that the wifi groups work well with Spotify since the last Android upgrade, but it doesn't stop playing anymore.

Community Member

Same here, I've just ordered 2 more Google Nest Audio and thinking about returning them back.

Community Member

Full uninstall of Spotify and reinstall fixed my issue.

Community Member

I'm also experiencing the same issue referenced above, where the audio only plays from one speaker instead of syncing across both devices.

The issue started one of two month ago. Groups on Home-App appears and disappears.

When the group is visible and i like to change the volume of the group, it will not be synchronized to the speakers.

When listing the members of the group i can set the volume for each speaker separately.

Please Google, fix that issue.

Additionally: some of my speakers disappeared and GoogleHome showed: new "Google Home Mini" detected. When starting the setup process, i can hear the beep sound but when i process with wifi credentials, the application is not able to find the device anymore. The app just want to connect with the same WiFi SSID but i am connected to the same WiFi.

When i try to interact with the GHM, it points me to the Assistant App to finish the setup.

I am not able to connect my GHM anymore. Tried 4 times with complete device reset.

Now things get very strange.


today i discovery these conditions to reproduce one and more issues:

In my home i have 12 APs, each room has it's own WiFi AP.

I can only see speaker groups of that AP where a Google Home device is connected to.

So every time i roam between APs, the groups will disappear and reappear. Devices in the same group but on another AP will not be shown. When i roam to the correct AP the device will show up correctly.

So there is an issue with multicast! Which protocol is in use for discovering groups? mDNS is not, because mDNS is used for discovery devices and this works as it should.

By the way. Groups will be displayed, but they are not functional. So you can not change the volume of a group and you can not broadcast to that group.

My WiFi Network: i am using ubiquiti networks.

Community Member

Same issue with google speaker group. I unplugged and plugged back in all 3, reset them, reset my router, updated everything to the most current software. Imagine my frustration when I speak the command to “play on speaker group” and it responds with “it looks like your video devices are offline”. I cannot play it by picking speaker group through pandora or Spotify either. GOOGLE…. Please fix this. Given the long thread of issues this is not something a “case by case” approach is going to help. Clearly your programmers needs assistance….

Community Member

Same issue. Renaming the group does the trick for a short time. I usually end up starting on one speaker and using the app to pick the group.

Community Member



Since some months my speaker groups aren't working anymore as described by all of you.... I have 3 Marshall stanmore en 3 Woburn multiroom speakers, 2 Sony SRS-XB501G and 2 chromecast audio's. These are all over my house/garden and I have a couple of speakers groups configured. They all WORKED FINE FOR MORE THEN A YEAR!! But since an couple of months "something" changed and the speakers in a group are trying to sync, one after another starts and stops,  it became a fiasco.... Whatever in heavens name is changed, PLEASE FIX THIS GOOGLE...



Community Member

I’m also having the same issue. Sometimes not only the groups cannot display, but also each individual devices are not available.

Community Member

Hi all,

I worked with Google Support on this and we figured out the basic cause... 

My Google Pixel 5 couldn't see the Groups section on the Google Home app when the Mobile Data was turned on. 

I could still see and control the speakers individually, but not the Groups.

I was able to recreate the issue several times, so I have now set up my phone to turn Mobile Data off when I'm at home.

They couldn't give me a good technical explanation, but at least I now have a reliable work around.

Community Member

I see. Thanks for the reply. For me, when this issue happens, individual controls are not available either. But I will try disabling data for now and see what will happen. Thanks again 🙂

Community Member

Well, I can explain that... The speaker groups are shown when you are on your own LAN as they propagate by mdns traffic. When on mobile network, that mdns traffic is not visible.

So or there was a bug in the pixel where LAN traffic was not read when mobile data was on, or you phone was simply not using your home internet connection... (which by example Samsung Galaxy does too when it believes your wifi or internet uplink is not stable enough)

Community Member

this works for me too! thanks

Community Member

This is by far the most frustrating issue.

I have speakers from Harman Kardon citation series, and the speaker group function is erratic at best, completely non functional at worst.


Any leads or improvements will be great.