cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Hub (2nd Gen) does not see all cameras

tbrudy
Community Member

I just bought a Nest Hub (2nd Gen), and it displays only 3 of my 4 Nest cameras. I can't figure out why the 4th camera is not showing and there is no "find camera" button. The camera that does not display is an older camera (outdoor). I did unplug and replugged the camera, that did not work.

14 REPLIES 14

MplsCustomer
Bronze
Bronze

Our new 2nd Gen Nest Hub displays the same cameras that are shown in the Google Home app in IOS. The Google Nest app (also in IOS) shows one less camera because one of our cameras is the new Google Nest Battery Camera, which, unfortunately, only appears in the Google Home app.

tbrudy
Community Member

Oh that's strange, I thought the Hub basically was the Home app. I know that my newest camera, which is NOT shown in the older Nest app or Nest online DOES appear in the Home App *and* it shows in the Hub Display. The camera that does not appear is my older camera.

The Google Home app, like the Google Nest app, are apps that run on mobile devices and phones. The Nest Hubs have their own operating system. Unfortunately, the new Google Nest cameras and doorbells released in the fall of 2021 can only be accessed from the Google Home app and do NOT appear in the Google Nest app or on the home.nest.com website that can be accessed from a computer's browser.

All of the cameras that appear in the Google Home app or in the Google Nest app should be accessible from a Google Nest Hub (1st or 2nd generation).

Does your older camera that does not appear on your Nest Hub appear in the Google Nest app? Does this older outdoor camera have a green light indicating it's on and connected?

Yes and Yes.

All 4 of my cameras show in the Google Home app. Only 3 of the cameras appear in the Hub. The one that does not show in the Hub, the older camera, does show in the Home app and Nest app.

This is a guess (from one customer to another), but do you have a "Room" specified for your one camera that doesn't show on your Nest Hub? (This is set in the Google Home app under Settings | Room.) Do your other cameras have "Rooms"? I'm just speculating that maybe the Nest Hub can't display a device that doesn't have a "Room". Here's why:

On our Nest Hub, if I swipe down from the top, I get a screen with "Home control" highlighted. If I click on "Cameras" in the upper left corner, I get a list of all of our cameras and doorbells. If I click on any of the cameras or doorbells, I get a live feed of the camera or doorbell.

If I click instead on "Rooms" on the "Home control" screen, I get a screen that lists the "Rooms" on the left and all of our devices (cameras, doorbells, hubs, minis, etc.) on the right, grouped by "Rooms". If I scroll up and down through the devices or the "Rooms", the "Room" that is highlighted changes.  So every device is in a "Room".

The "Room" is just a grouping, and can be anything you want.  Since our cameras are all outside, our groups are custom rooms called "Cameras", "Doorbells", and "Hubs" but they could just as easily be  the preconfigured "Living Room", "Dining Room", etc. rooms that Google provides.

(The Google Nest app doesn't have "Rooms".)

I do have the camera that does not show in a designated room. I even just tried to switch the room (from 'back door' to 'back yard') hoping that might jog the system. No luck. In the Hub, all the rooms appear except the room designated for the non-showing camera.

I wonder what would happen if you put it in the same room as one of your cameras that are showing in the Nest Hub.

That was a good try but it did nothing. I "moved" the camera into the "front yard" room and it still shows in Home app, Nest app, but not the Hub.

I'm stymied.  When you select your "front yard" room, does it display with one of your other cameras but NOT the problematic camera?  You could also unplug your Nest Hub for a minute and then plug it back in to make it restart.  (I'm just trying to think of low-risk solutions.)

Yeah when I tried the above and added the problem camera to another room, the camera that was already there still displayed fine but not the problem camera. Also when I made a new room for the problem camera, it showed everywhere except the Hub. I will restart the Hub and see, then maybe delete the camera from nest and add it back.

You can also reboot your Nest Hub by selecting it in the Google Home app, selecting Settings, then More (the three dots in the upper right corner) and then selecting Reboot.

OKAY !! SOLVED !!

I uninstalled the older camera through Nest app. Then reinstalled the camera through Nest. It is now visible in Nest App, Home App and the Nest Hub (2nd Gen).

I'm glad that worked!

GarrettDS
Community Specialist
Community Specialist

Hey folks,
It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread.

Have a great day.
Garrett DS