Showing results for 
Search instead for 
Did you mean: 

New Google Nest Hub stuck on "Connected...Follow the instructions in the Google Home app"

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community.  You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community. 

Original Poster: Sir_Timbit 


Hi there. I've had a Google Nest Hub for about two years and it was working great up until the past week or so, when it would start to freeze and not respond to voice commands. I assumed it was giving up the ghost. We really like having one, so we bought a new one from Costco. On the Google Home app on my iPhone, I removed the home and started from scratch.

1) Selected my personal gmail account to use.
2) Allowed Google Home to find and connect devices on my network, allowed Bluetooth.
3) Created a new home...
4) Google Home looked for and found the new Google Nest Hub device. It showed the same code on the phone and on the hub.
5) Where is this device? Kitchen, as was the old one.
6) Connected to WiFi, entered WiFi password, connected successfully.
7) At this point, the Nest Hub showed "Connected...Follow the instructions in the Google Home app"
😎 Finished configuring settings on my phone, such as photo frame and music settings.
9) Google Home shows "Kitchen Display is ready -- let's get started.. Continue."
The problem is the Nest Hub itself is still showing "Connected...Follow the instructions in the Google Home app" instead of working as a photo frame, which is typically what happens at this point. It responds to voice commands, I can ask it the temperature. If I ask it to play a YouTube video, I can hear the audio from a video, but the display is still showing "Connected...Follow the instructions in the Google Home app."
10) From the settings window in Google Home, I reboot the Nest Hub.
11) Once Nest Hub boots up, it now displays "Link Account: Open the Google Home app and link your account"
12) Back in Google Home app, under Home, Local Devices: Kitchen Display: link account
13) Tap Link Google Account
14) Goes back to showing "Where is this device?" from step 5 above...
What I've tried the following steps *multiple* times:
1) Factory reset the Nest hub.
2) Removed the device from Google Home, removed the home, deleted the Google Home App from my iPhone and reinstalled.
3) Went to and removed any old entries referring to the Google Nest Hub.
I'll just return it if I can't get it going. I've done these steps before and things usually just worked. It's really frustrating. Any ideas? I've been searching on these forums and there seems to be known issues but I haven't found a fix yet. Thanks.

Community Specialist
Community Specialist
Hello there, 
I am sorry that you are encountering this connectivity issue with your device. I understand your concern. The Google team is aware of this issue and is investigating a possible cause. There are no other steps to take at this time to troubleshoot.
I just wanted to check in, has this issue resolved on its own for your device?
  • If YES (has been fixed), could you please send feedback with the words: "GHT3 Nest Hub link account issue fixed" with an explanation of the situation?  
  • If NO (has NOT been fixed), could you please send feedback with the words: "GHT3 Nest Hub stuck on link account screen" with an explanation of the situation?
Your feedback is greatly appreciated, as it will help our engineering team address this issue. 
- From Frances (Community Specialist)