Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Error code na023 with Nest connect

Community Member

I have installed my Yale lock, and when I setup the Connect through the Nest app, I get failure to connect with two codes reported interchangeably: na021 and na023.  


I have reviewed several others with this issue on these forums and gone through the troubleshooting which includes:

- Restarting/resetting the Connect
- Uninstalling and reinstalling the Nest app
- Setting my wifi for only 2.4ghz
- Trying to set up on my wife's phone (get same error codes)

What else needs to be tried before I request a replacement Connect?




Community Specialist
Community Specialist

Hi jennin82,

I'm sorry to hear that you're experiencing an issue with your Nest Connect but thanks for doing some steps beforehand. Let’s sort this out — a few questions: what’s the status light of your Nest Connect? How far is your Connect from the router? Are there other devices connected to the same Wi-Fi where you’re trying to pair your Connect to? Also, were there any changes to your Wi-Fi network?  

Here are some troubleshooting steps you can try:

  1. Hold down your Connect’s button until the light pulses blue (about 10 seconds). Then, release the button. 
  2. Wait for Connect’s light to turn green, which means the restart is complete.
  3. Try plugging your Connect into a different outlet.
  4. Check for sources of wireless interference. Thick walls, floors, appliances, furniture, and even other electronics on the same network can cause interference.
  5. Factory reset your Connect. Hold your Connect’s button for much longer than 8 seconds, the light will turn yellow, which means your Connect is preparing to factory reset. Keep holding down the button, when the light flashes yellow then goes off, release the button. 

Let me know how it goes.




I appreciate your reply.  I have completed/addressed all of your recommended steps and still no success. The connect is <6 feet from the wifi and I've tried restarting and doing factory reset multiple times with no luck.  


I will say, when I hold down the button, you mention it turning green - it has never done this.  When I hold it down for 10 or more seconds, the light turns yellow, then off, then goes back to blue (fading in and out).  The light never turns green to my knowledge.

Thank you

Community Specialist
Community Specialist



I can imagine this has been frustrating trying to troubleshoot and none of those steps working. I believe it is in your best interest if you would please fill out this form, and a higher tier of support will reach out to you once the form is completed, to better assist you. Please let me know once you have filled out the form.


Best regards,


Community Specialist
Community Specialist

Hi everyone,

@jennin82 we got your form — thanks for filling it out. Our team will reach out to you via email to further assist you. If you have any questions or concerns, feel free to create a new thread as I will be locking this thread after 24 hours.

I appreciate the help, JT and Brad.