cancel
Showing results for 
Search instead for 
Did you mean: 

Best battery cam “can’t connect to assisting devices”

Ice
Community Member

All of my devices work fine. 2 hubs 1 doorbell 2 minis but the new cameras will not allow me to add them to my home. I’m extremely close to just returning them and going with something else. All devices have been unplugged and reset. Doorbell is new and works perfectly as does all other devices. When on the IOS app it will search for other devices to “help get connected faster” but every time, it says “can’t connect to assisting devices” I have 1500mbps download and 60 upload. It’s not the Internet. If also reset the modem. I’m a certified ARA for GeekSquad and can’t figure out these cameras. Says something about these products. It has to be something either on googles end or just an inferior product. To have all these issues with just a simple connect startup should not happen.

1 ACCEPTED SOLUTION

JOHN88
Community Member

So I called into tech support this morning and they provided a solution. A tedious one, but a solution nonetheless.

If you haven’t tried this already, they instructed me to uninstall all existing nest products I have, including any connected devices on my iPhones Bluetooth (which was only my iWatch). 

This way, the cameras take first priority in the install on the google home app and the app won’t continue to “connect to assisting nest devices” for frikin forever and never find any.

Low and behold, it worked just like the YouTube vids showed it and connected to my wifi right away and I was able to install both the cameras no prob. Then I just had to reinstall my nest doorbell again and iWatch.

Hoepfully it works for you! 

View solution in original post

12 REPLIES 12

JOHN88
Community Member

Same exact issue for me too! Been looking for an answer to this seemingly insignificant issue but the app won’t pickup my wifi. I have the best doorbell too which works perfectly fine. Wifi is not the issue. 

So excited to install the cameras, but been stuck on that frikin msg all night. 

hoepfully someone has an answer…

Ice
Community Member

I’m hoping man! Still having the same issue. I’ve tried everything. About to return them and see if it’s just a camera issue or software/Network issue. I’ll keep you posted.

JOHN88
Community Member

So I called into tech support this morning and they provided a solution. A tedious one, but a solution nonetheless.

If you haven’t tried this already, they instructed me to uninstall all existing nest products I have, including any connected devices on my iPhones Bluetooth (which was only my iWatch). 

This way, the cameras take first priority in the install on the google home app and the app won’t continue to “connect to assisting nest devices” for frikin forever and never find any.

Low and behold, it worked just like the YouTube vids showed it and connected to my wifi right away and I was able to install both the cameras no prob. Then I just had to reinstall my nest doorbell again and iWatch.

Hoepfully it works for you! 

Ice
Community Member

It worked for me as well! Thanks for the info! Saved me a hassle lol. Thanks again man!

Ice
Community Member

I’ll try it. Definitely tedious! Thank you! Hopefully this works. I feel like we shouldn’t have to do that though, just to get cameras to work. What happens when I want to add a camera? Am I going to have to delete all nest products again? Seems like a Temporary work around for a problem that requires a permanent solution.

MplsCustomer
Bronze
Bronze

Google Nest Support:  you really need to address this!  Asking a customer to uninstall all of their existing Google Nest products in order to install a new product because Google Nest has some kind of hidden hierarchy of installation is absurd.

Brad
Community Specialist
Community Specialist

Hey folks,

 

I will look into this further to see if this is a bug or something else. Thank you for your patience, and please continue to provide feedback, any fixes that worked for you, etc. I am glad to know that there seems to be a workaround for this issue, even if it is is not the best choice. 

 

Best Regards,

Brad.

@Brad 

Thank you for agreeing to look into this.  There are multiple posts concerning issues with "assisting devices," so anything you can do to address it would be helpful.

Brad
Community Specialist
Community Specialist
Hey folks, 
 
Thanks for sharing your feedback and I understand how frustrating this has been. Our team will need to gather additional information from each of you to check what's happening with your devices so we ask that you reach out to support using that form so we can get your case escalated. Someone from our team will be in touch with you soon once you've done so to work on appropriate next steps, 
 
Best Regards, 
Brad 

Brad
Community Specialist
Community Specialist

Hi there, folks.

 

Just checking in to see if you still need assistance with this issue.

 

Please let me know if you need further assistance. 

Best Regards,

Brad.

Ice
Community Member

No sir. Had to use the only work around that I know of, and remove all devices, and add the cameras first then the other devices one by one.. Appreciate the response though! 

Brad
Community Specialist
Community Specialist

Hey there,

 

I am glad to hear that the issue has been resolved with a work around! Thank you again for your patience. At this time, I'll go ahead and lock this thread. If you're still experiencing problems, feel free to start a new thread and we'll be happy to help.

 

Best Regards,

Brad.