Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Cam Battery Outdoor cannot connect, cannot live view, but connects fine in an alternate home

Community Member

This is quite frustrating. I have 4 Outdoor Battery Cams. All of them went off line a few weeks ago so I've been in the process of factory resetting them all (multiple times) to get them reset up. Live view has been hit or miss since then, mostly miss.

I have 3 of hte cams back up and setup, the 3rd and 4th gave me signifcant issues in setup. The 4th one just won't get setup. 


In my actual home I get all the way to the point of "downloading software" but it never progresses past 0%. 

If I use a test home environment, it connects right up and is working mostly fine. 

It appears that the firmware /download is all done already, but every time I try to connect it to my correct home it goes through the step of trying to download software, but fails over and over and over again. 


Community Member

Had same issue. Had google send me a new doorbell. The new one connected, finally got past 0. It worked for about a day and then live video ability stopped working again. 

Same problem with my floodlight. removed, factory reset, re set it up and it worked for about 1 day and did it again. It is connected to wifi (separated my 2.4ghz channel) as I can see it on my router. It records live video, sends notifications, but acts like it isn't connected. My nest doorbell battery is doing the same thing. 


I have 5 other nest cams (older gen) that don't do this and I have 3 nest protects.  All stay connected and viewable with no issues.


Community Specialist
Community Specialist

Hi everyone,


@nismos14 and @Rgtwng, thanks for reaching out here in the Community. To confirm, how far are your Nest Cameras from your Wifi router? Could you tell us your internet speed where your Nest Camera and Nest Doorbell are installed? If all connected devices in your home go offline, there might be an issue with the router or network. Restart your router, modem, and any Wi-Fi range extenders or repeaters that you have.

   1.Unplug your modem and router power cords. Tip: You may have a combination modem/router, or they might be separate devices. All the lights on your modem and router should be off.

   2.Wait for 30 seconds, then plug your modem and router back in.

   3.Your modem and router will restart. Wait a couple of minutes or until you see steady power and connection lights. You may also see a quickly flashing data light. Note: Every router is different. You might need to consult your router's user manual for specific instructions on how to restart your router.

   4.Open the offline camera's video stream and wait a few minutes.


If the live video stream appears, the camera has reconnected. If none of your devices reconnect, there might be a network outage in your area. Contact your internet service provider for more information.


Hit this link for more information and let us know your update here.




No issues with internet and it doesn’t matter the proximity of the camera to the router. My other three cams are fine. My issue about live stream is mostly resolved. The issue I have now is that I can’t add one of my camera to my actual home environment I can only add it to a secondary test environment I made. It doesn’t add to my standard home environment where all my other devices are, but it does add fine to a test environment. I reset it multiple times and try to add it to my home environment and it says downloading an update and then never progress past 0 and then fails to add the camera. 

Community Member

Fixed my problem sold my google cams and went to eufy outdoor cams. No issues now.


Judging from other similar posts in this forum, my guess is that there is some defect in Google Nest's processes that corrupts some customers' "home/structure", such that they cannot add (or add back) various devices. The fact that you could add your camera in a second "home/structure" supports that idea. Other customers have resorted to removing all of their devices, deleting their "home/structure", and reinstalling everything in a new "home/structure" to resolve the problem.

It's too bad you got caught by this defect.