cancel
Showing results for 
Search instead for 
Did you mean: 

DEFAULT TO ENGLISH AUDIO DESCRIPTION

Kapalua0727
Community Member

Have been through the ringer with all regarding this with no luck. I see there are still people having trouble with the same issue so I thought I would start a new thread since all the old threads are locked. I have tried all the fixes that were in the treads plus maybe a few more from the Peacock team, bottom line nothing works and no one has a clue how to fix. Interestingly enough I purchased another Chromecast 4k w/gtv and hooked it up without issue on another television. It does not default...yet...to English AD. I just factory reset the first one I got and right out of the reset it was back to defaulting on English AD, how annoying and disappointing. And I'll say it again, I've tried all of the suggested 'fixes' with no luck. If anyone has a verified fix, please post it here ty.

5 REPLIES 5

kiltguy2112
Silver Product Expert
Silver Product Expert

Return it if it is still under warranty. (1 yr in US)

Jeran
Community Specialist
Community Specialist

Thank you for helping out on this thread, kiltguy2112!

Hey there Kapalua0727,

I'm just checking up on this thread, do you have any more questions or need any additional help? 

Best regards,
Jeran

Was able to isolate the problem to one tv that didn't offer English 5.1 in the sound menu. It only offers English and English AD. On my tv with the sound bar the 5.1; option is available and there are no problems on that set. So the problem only exists when streaming peacock via Chromecast on a tv that doesn't have English 5.1 as an option.

Jeran
Community Specialist
Community Specialist

Hey there Kapalua0727,

That is an interesting interaction! In that case, try going into the Chromecast with Google TV settings and disabling surround sound to see if the sound plays properly. If it does, it looks like that particular TV won't work properly with the Chromecast with Google TV's surround sound.

 

I look forward to hearing from you!

Thank you,
Jeran

Hi and thanks for the reply.  I am not alone on this issue, there are many people, threads, discussing this same issue. That issue being streaming Modern Family on Peacock using a Google Chromecast.  You have to manually change the Chromecast sound setting to to accept all sound options so that when the show is playing you see the English 5.1 option in the subtitle menu.  If you don't see 5.1 it defaults to English AD after every show even if you change it to the English option during the show.  The not-perfect fix is to manually select all sound options in Chromecast settings then selecting English in the subtitle menu of the show.  The tradeoff is the commercials have no sound and you have to reselect English after each episode.  At least you don't have to listen to that super annoying English narrator (glad it's there for the people that really need it.)  Another workaround I have found is streaming Modern Family using another app like YouTube TV. Something is broken between Peacock and Chromecast and obviously it cannot be fixed or no one has the energy to try to fix it. I have wasted too much time reading about this issue and trying to resolve it with Peacock directly.  Chromecast  and Peacock are going to have to work together to fix the issue if they decide it's important enough.  I've already troubleshooted the device and the TV independently to know it's not either of those items and isolated it to the combo-problem described above.

 
Best regards,
k