Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Shark robot not syncing

Community Member

I have been having issues for months (Since I got my Shark robot). I have called Shark and they are stating it is an issue with google. When I go into the google home app to link the shark it states no device found. The device is showing on my shark account. I have uninstalled and reinstalled both apps and even deleted my shark account and re-added everything. Still have the same issue. What can be done in order to get google to work with it? I have tried so much already and it is getting frustrating not being able to link it. Everything else in my home work and has worked in the past.


Community Specialist
Community Specialist

Hey anniea2476,


I'm sorry for the trouble this may have caused you — let's see what's going on.


Was it working on the same network? What app are you using in controlling your Shark Robot device? Also, are your devices connected to the same Wi-Fi network? 


  • Make sure your devices are connected to the same network and within 15-20 feet of your router.
  • Try rebooting your Shark Robot devices, phone, Google Home and router to refresh the connection.
  • Try using the "OK Google, Talk to Shark" command.

Let us know how it goes.




Community Specialist
Community Specialist

Hi anniea2476,


Chiming in to see if you still need assistance with this. Hope the previous post helped. Let us know if you have additional questions, otherwise we’ll be locking the thread.



Community Specialist
Community Specialist

Hello there,


Bumping in to make sure that you saw our response. I'll be locking this thread if we won't hear back from you again in 24 hours. Should that happen, feel free to create a new one if you have more questions or have other concerns in the future.