cancel
Showing results for 
Search instead for 
Did you mean: 

Smart life devices appearing as offline in google home but working fine in smart life app. Help?

daithi2022
Community Member

I cant connect my smart life lights to google home. They all worked perfectly fine until I created  a new "home" in google home and now it won't work anymore. 

I am able to sync my Smart Life account to google home and the devices all show in the app. However, they all show as offline but work fine in the Smart Life app.

I tried deleting and installing both apps, I reset all devices, I unliked and linked again several times.

I do notice that smart life never appears in Linked Services no matter how many times i unlink or link smart life.

When i ask google to turn something on or off it says "Sorry i couldnt reach the smart life" or "Sorry, it looks like the smart life is unavailable"

If i go into google account / security and unlink smart life there it unlinks and is gone.  If i link it again and refresh that page it appears there again.  But still in google home all the devices are offline.  yet in the smart life app i can switch them on and off with no problems.

Ive been using google home for years with smart life and now it just wont work.

Can anyone help?

Thanks.

1 Recommended Answer

daithi2022
Community Member

Hi, Thanks for answering.  They just stay there as zombie devices all the time offline.  So I found a way to get them back online.  You need to move all the devices to an unused room I. Google home.  I made one called zombie room.  Then you go to each device and physically put it in pairing mode again.  Pair it to smart life.  And do this for each device.  Some of you zombie devices come back to life and you can move them back to normal rooms.  The others will appear as new devices but still with the correct name.  Then sync Google home again.  Pit you can just tap on a device and remove it from Google home though.

View Recommended Answer in original post

9 REPLIES 9

Jeffmueller2012
Community Member

Having the same dame problem.

Exact same. I dont wanna reset everything. Dont even know how.

Aiden1
Community Member

When you unlink smart life, do the devices disappear in Google Home or do they just move into the "linked to you" section whilst remaining offline?  This sounds like a "cloud sync" error to me at first glance and I haven't come across a true fix yet, only workarounds that make things usable again

 

daithi2022
Community Member

Hi, Thanks for answering.  They just stay there as zombie devices all the time offline.  So I found a way to get them back online.  You need to move all the devices to an unused room I. Google home.  I made one called zombie room.  Then you go to each device and physically put it in pairing mode again.  Pair it to smart life.  And do this for each device.  Some of you zombie devices come back to life and you can move them back to normal rooms.  The others will appear as new devices but still with the correct name.  Then sync Google home again.  Pit you can just tap on a device and remove it from Google home though.

I'm really glad that worked for you.  My situation required a brand new "home" to trap the devices in.  An unused room didn't do it.  Just so people know, that may work also if an unused room doesn't.  I have a separate home called ghost devices that has 8 offline devices trapped in it.  Not ideal but we do what we have to, right?

Dan_A
Community Specialist
Community Specialist

Hi folks,

 

@daithi2022, @Aiden1, I really appreciate the both of you showing us the resolution. 

 

@Jeffmueller2012, have you tried the steps they did to get this resolved? You can open this guide when creating and/or moving devices to a different room or home structure.

 

Tell me how it goes.

 

Best,

Dan

Thanks for the update Dan (and  daithi2022), let me try this out..it sounds like a solid solution its just I have a bunch of devices. stay tuned.

 

Azarco
Community Specialist
Community Specialist

Hey Jeffmueller2012,

 

Cool! Sounds like a plan. We'll be waiting for your update.

 

Thanks,

Alex

Azarco
Community Specialist
Community Specialist

Hello there,

 

We know you have other things to do but we'd like to check if you're able to try the steps above. Please let us know if you are still having any trouble from here, as we would be happy to take a closer look and assist you further.


Best,

Alex

Azarco
Community Specialist
Community Specialist

Hi Jeffmueller2012,

 

One quick final check in here since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need assistance, feel free to start a new thread in the Community and we’ll be happy to help.


Regards,

Alex