cancel
Showing results for 
Search instead for 
Did you mean: 

Heat link no lights

egor0916
Community Member

Hi, I have a problem with my heat link which has been working reliably until today. There is 240 volt supply, with no lights on, tried the 30 second button press, tried turning the power off for 10 minutes to see if that helped but nothing has worked. Please can you let me know what I need to do to get a replacement.

4 REPLIES 4

RXShorty
Gold Product Expert
Gold Product Expert

Hi @egor0916 

If your heat link is not working anymore the best thing you can do is reach out to Google Nest support😊

 

DragosC
Community Specialist
Community Specialist

Since I haven't heard from you in a while, I'll have to close this thread. Should anything else come up, please open another thread and we'll take it from there. Have a good one and stay safe!

AlexD
Community Specialist
Community Specialist

Hi @egor0916 . Sorry for the late reply. 

 

As @RXShorty mentioned, getting in touch with our live support service would be the fastest choice to get things back on track. 

 

If you need any further assistance, make sure to let me know. 

george_t
Community Specialist
Community Specialist

Hi @egor0916. Just checking in, did you manage to get in touch with our colleagues?

 

GeorgeT