Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Thermostat Gen 3 hot water schedule not working

Community Member

My thermostat has suddenly stopped controlling the hot water according to the schedule. I am able to boost on & off just fine but for some reason the hit water is not coming on at scheduled times so we often have cold water in the morning - not ideal!  Any suggestions?

It's a new installation with a system boiler and unvented cylinder. 



Community Member

I'm having this exact issue. My hot water is scheduled to come on, but is not... Boost works fine. 

Community Member

Have similar problem- have hot water scheduled for morning and evenings. Evening is working but in the morning heating working but hot water not working. Boost works fine

Still having this issue BUT (thanks to my plumber) it has now been pointed out to me that it is possibly a LEGIONELLA BACTERIA prevention.  There is an option in the thermostat to enable/disable the facility to HEAT the water to ensure that it prevents the bacteria growth.  Sooooo, this kicks-in if the water temp has been too low for 48 hours or so.  I checked & my thermostat is set to enable this facility.  Hey presto, this is why it sometimes randomly heat up !!!!  I don't know on earth Google didn't flag this up as a possibility ???  I am DELIGHTED & RELIEVED after 10 months of tearing my hair out.  Please all check this out.


My water heating was working all fine until last week when I set the thermostat to eco before going on holiday for 4 days. On return the water does not heat up. Boost does not work either. I reset the thermostat to factory settings a few times but this still has not resolved the issue. I then saw your post and tried to enable/disable the bacteria prevention setting but it still does not work 😞

Is there any other suggestion please?

Hi Blesson, does it work if you bypass the thermostat and press the button on the heat link?  Try that and it should turn on the heating and hot water. Otherwise it may be a fault with the relay between the boiler and healink, or the hot water cylinder thermostat.

Got a plumber to check and it seems to be an issue with the boiler and not the nest thermostat. Thanks for your response.

Disable eco on the hot water and ensure the schedule is on.

How do you disable the bacteria prevention? Thanks

Same problem hot water schedule works but heating schedule does not come on… can you help.., I can turn on heating manually from thermostat .. help appreciated 

same for me did you find a solution?

Yes I did!

Hi go settings on the actual nest thermostat and find Hot Water. Change from disabled to Enabled!!!

How frustrating is that!

This worked for me.   Idk why it became disabled.   I did have a power cut which may have caused it to reset 

Have moved into new house with Nest gen 3 learning thermostat and told by previous owner that hot water is wired in but there is no hot water schedule on Nest app so cannot control hot water. Heating is ok. Why is the hot water schedule not showing?

Try going into the menu on the thermostat and ensure hot water schedule is enabled. Software updates  in the past have set it off. 

Thanks but the menu does not have a schedule, or icon, for hot water, only heating. The previous owner has confirmed he did schedule hot water and it is wired for hot water. But there is no hot water schedule. Any ideas?

Thanks. I found the scheduling had been disabled 

After many calls with nest customer service when hot water schedule was working but heating schedule not.. with manual working for both it turns out that the way I scheduled heating was wrong… it now works… in summary on hot water schedule make sure you put in a start temperature then leave gap and put in stop temperature that is lower .. I put in 20.5 degrees start and then a second bubble later saying 17 degrees .. this sorted my problem and now both schedules work .. I made the mistake of putting in hourly heat bubble kn schedule at same temp ..thinking this was needed .. sorted!

Above mistake typo .. via the app..heating schedule should have a start bubble and stop bubble at lower temp with gap.. actually hot water has a duration you can put in and is different in latest thermostat

See below for my solution hope this helps

Community Member

Hi all,

I’ve the exact same issue - last two days the hot water hasn’t come on, boiler not firing up even tho it is scheduled & I’ve not changed any settings. Boost works ok & heating is ok.

I hope Google sorts this out ASAP as no hot water in winter isn’t good !

Hey, how did you resolve this?

Community Member

There is a setting on the Nest thermostat - enable schedule was off for some reason. I didn’t touch it so must have been an automatic update. Now it works fine 🤨. Can’t believe it really - good luck 

Community Member

Thanks for this... I've had the same problem over the last week or so... Hot water scheduled but not coming on, boost working fine. I've just checked and sure enough, enable schedule was off on the nest thermostat. I'd also not changed it. Just set ienabled schedule to on on the thermostat and now my hot water has come on according to my set schedule. So pleased.

Community Member

Great it worked for you! Unfortunately for me, my schedule is enabled on the thermostat but it still randomly doesn’t work (works around 50% of the time) otherwise manual boost always works. 

Same with me also.  Frustratingly for the past 3 months, my hot water stops working exactly every 48 hours.  I can always 'boost' BUT have to open the thermostat manually before it re-sets itself, only then lasting another 2 days before it knocks itself off again.  It's very strange.  To be honest, I've never had 100% service since the thermostat was installed in August 2021.  These issues seam to come & go & thought I had it fixed when I had 'enabled' the legionella setting & the hot water settings........  I'm tearing my hair out why these problems arise from nowhere & Google/Nest support is non-existent.

I am pulling my hair out too! I overlooked the 48hrs - it sounds about right now that you mention it. Could it possibly be something to do with home/away mode which kicks in after 48hrs? I'll let you know if I get anywhere.... 

Ah interesting,.....I've not looked at that but it could be a possibility.  Different glitches seam to affect it somehow ?  Let me know how you get on & I will too.  Good luck 🙂


My problem was that I didn't have a hot water schedule at all. I called a company called HANDA HEATING LTD 07929 080000 and someone talked me through the problem and resolved it. The problem was that my boiler was down as a combi boiler and I had to change it to just a system boiler. You may want to give them a call, there was no charge!


As per my earlier response, Try calling HANDA HEATING LTD, 07929 080000. They talked me through how to resolve my problem...I had my boiler listed as a combi boiler and it isn't! They didn't charge either.


Try calling HANDA HEATING LTD, 07929 080000. They talked me through how to resolve my problem...I had my boiler listed as a combi boiler and it isn't! They didn't charge either.

Community Member

I've just noticed that Nest Labs have been replying to reviews in the Play store so have re-posted my question there, let's see if we get an answer as looks like I'm not alone. 

Community Member

Good idea, I like your style.  Lets hope it works & they respond.

Community Member

Also the same here this week. 

Community Member
  • Me again,

I thought the problem was rectified but it didn’t come on again last night or this morning what the heck is going on Google ?! Please reply & fix these issues. 

Community Member

In the lack of a response from the community and from the developer via Play Store, I started messing around with settings on the Thermostat on the off chance and believe it or not found a setting that turns the hot water schedule on and off, which I didn't recognise and can only presume had been added in an update?  Somehow this had been set to off so I set it to on and now the schedule works fine. What a stupid thing but also simple to resolve, thankfully. Good luck all

Community Member

Thank you...was exactly this for mine too. Any idea why it disables itself?



Community Member

Arulras, could you confirm where you found that setting? Proper treat me like an idiot and tell me step by step as though I have no clue (I don't!) Appreciated! 

So I just went into settings on the thermostat (push it and then select the cog icon) then scroll along and up popped an option that said "Hot Water Schedule" and it could be set on/off

Community Member

Thank you!! Was so perplexed that my nest didn’t turn our hot water on. We’ve just changed this setting. So boggling that they would do this